Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 12-17-2021, 05:45 PM   #1
MidnightSun
 
Join Date: Oct 2018
Location: MN
Posts: 111
Vehicle: 91 D21 vg33 5speed 4x4
Thanks: 24
Thanked 16 Times in 15 Posts
Default Emergency help/advice

Hey all. Ran into some problems today. Ive been travelling from NV with my camper. Just got into a town in CO. As i was cruising down the highway there was kind of a hesitation and shift. It was real short and was thinking(hoping) it was the wind. When i got to the stoplight and was slowing down started acting all kinds of wrong and the truck died. Tried to fire it back up and sounded like the starter was grinding. Got out to look around while stopped in the middle of the road. Everything looked in place. Tried again and fired right up, pulled it into a parking lot to check it out more. There was a fair amount of oil it seemed around the starter, but couldnt see where it could be coming from. Checked oil and brake fluid and everything looked like it was at the same level. Real problem is im at least probably 1000 miles from anywhere i could work on it. My stubborn ass would keep going, if it happens again at least im carrying my home. What are your thoughts on things i can look at, that maybe i didnt.
MidnightSun is offline   Reply With Quote
Old 12-17-2021, 06:13 PM   #2
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 943
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 146 Times in 127 Posts
Default

Automatic or manual transmission?

"Acting all kinds of wrong" -- describe specifically.

Stop often, at least early on, to check things, if you continue. Potentially many causes.
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Old 12-17-2021, 06:41 PM   #3
MidnightSun
 
Join Date: Oct 2018
Location: MN
Posts: 111
Vehicle: 91 D21 vg33 5speed 4x4
Thanks: 24
Thanked 16 Times in 15 Posts
Default

Manual tansmission.

Re reading that, i was thinking it wouldnt be enough info, haha. It seemed like a lot going on, so ill try to describe it best i can. It seemed to be mostly increase in noise, like maybe rattling. Had the clutch in i believe when it died, possible i didnt. Because it stopped immediately. I took video of the clutch actuator and the line that goes to it, working both the clutch and brakes at the same time. Clutch actuator is working and didnt notice any additional oil from the line. I did however notice that some of the axle bolts were loose and two were missing on the left side. Got em all tightened back up.
Oh and, dont think this would matter, the back side of the carrier (the insert with the cap) is no longer connected. Something i wasnt happy with after the swap and wanted to get it replaced by a shop to make sure everything with it was good. Had a strong feeling at the time that he took my new part and just hammered it to the back.
MidnightSun is offline   Reply With Quote
Old 12-18-2021, 11:00 AM   #4
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,257
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,847
Thanked 1,836 Times in 1,598 Posts
Default

Following this.

My ex has a 2003 Frontier (V6 and auto trans). Hers also has weird issues with going dead at random. We have taken it to Nissan and 2 other shops. Nissan couldn't find anything. The better shop we took it to was out on a test ride when it died on them, and they had to have it towed back to their shop. They couldn't find anything either.

It died on her one night at work where she is a waitress. She had to leave the truck there. An Albanian dish washer who doesn't speak English had her give him the keys so he could look at it. The next day, he had it running. The best description we could get out of him was that he drained the oil out of the starter.

That left me with more questions than answers, but it also sounds like exactly what you are dealing with.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
MidnightSun (12-18-2021)
Old 12-18-2021, 12:20 PM   #5
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 943
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 146 Times in 127 Posts
Default

Quote:
Originally Posted by jp2code View Post
The best description we could get out of him was that he drained the oil out of the starter.
That's interesting. If true, bad rear seal, oil getting slung off the flywheel, starter positioned so that oil accumulates in the pinion cover/shell, then oil seeps past the bearing into the starter's motor? And/or the sliding-bearing wears from the dirt in the oil, thus causing the pinion gear to act strangely? If so, seems as if a new starter would cure the problem, at least temporarily.

OP: Have the V6 or L4?
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Thanked by:
MidnightSun (12-18-2021)
Old 12-18-2021, 06:34 PM   #6
MidnightSun
 
Join Date: Oct 2018
Location: MN
Posts: 111
Vehicle: 91 D21 vg33 5speed 4x4
Thanks: 24
Thanked 16 Times in 15 Posts
Default

@jp thats interesting. It would make sense of the oil around the starter without a visible leak. I can see if i can get a view of the flywheel, see if theres oil up there. Also try to drain the oil from the starter. See what that does. Luckily this all happened in society and pretty close to where i was making a stop anyways, haha.

@lugnut heres to hoping its not the rear main. Considering theres like 11k on the rebuild, ha. I have the v6, vg33.

Ill keep yall updated as a i can. Surprisingly no actual phone service, using the good ol McD's wifi.
MidnightSun is offline   Reply With Quote
Old 12-24-2021, 06:28 PM   #7
MidnightSun
 
Join Date: Oct 2018
Location: MN
Posts: 111
Vehicle: 91 D21 vg33 5speed 4x4
Thanks: 24
Thanked 16 Times in 15 Posts
Default

I made it back up to MN without any problems. Took a one hr trip for some supplies and the rear end locked up on me. With both tansfer case and tranny in neutral i couldnt push it. Got a tow coming to get me back to the farm. It hasnt snowed or anything, so ill tear into it after the holidays.
MidnightSun is offline   Reply With Quote
Old 12-24-2021, 07:45 PM   #8
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,257
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,847
Thanked 1,836 Times in 1,598 Posts
Default

Quote:
Originally Posted by MidnightSun View Post
I made it back up to MN without any problems. Took a one hr trip for some supplies and the rear end locked up on me. With both tansfer case and tranny in neutral i couldnt push it. Got a tow coming to get me back to the farm. It hasnt snowed or anything, so ill tear into it after the holidays.
That sounds like an axle problem.

Have you worked on the axle lately?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 12-24-2021, 09:30 PM   #9
MidnightSun
 
Join Date: Oct 2018
Location: MN
Posts: 111
Vehicle: 91 D21 vg33 5speed 4x4
Thanks: 24
Thanked 16 Times in 15 Posts
Default

Quote:
Originally Posted by jp2code View Post
That sounds like an axle problem.

Have you worked on the axle lately?
Yea, that was my thoughts. No, i havent. That will change soon enough though, ha. My plan is to start at the back and work my way forward.
MidnightSun is offline   Reply With Quote
Old 12-25-2021, 04:33 AM   #10
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,257
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,847
Thanked 1,836 Times in 1,598 Posts
Default

Your tow is probably already there and you are home by now, but I'll toss this out there:

Sometimes a tooth breaks off of the axle or spline gear, and that tooth can get jammed in between the axle and spline.

If this happens, you can try rolling the truck backward. If a tooth is jammed in there, it will fall out and go to the bottom of the axle housing. Now you can go forward.

Just be careful, though. If that broken gear is still floating around in the housing, it can always sling back up and get lodged in the gears again, causing your axle to lock up at any moment.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
MidnightSun (12-27-2021)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.