Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 04-07-2021, 06:28 PM   #11
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State
Posts: 532
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 542
Thanked 133 Times in 116 Posts
Default

OK... So, the PING'n sound happened before or after the drive shaft install?
__________________
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 04-07-2021, 06:47 PM   #12
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 10,499
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,679
Thanked 1,525 Times in 1,339 Posts
Default

Crawl under the truck with the transmission in gear and turn the driveshaft back and forth. Someone may have left some bolts loose.

Was there any other work done? I ask because what you describe sounds a lot like what I had happen when I replaced the rear leaf spring bushings and forgot to torque down the bolts. When I would go forward, the rear axle would lift up just a bit as the twisting force was applied to the axle.

Basically, you have something loose. Crawl under there and start trying to move stuff while it is stationary.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 04-07-2021, 09:58 PM   #13
Salsapants27
 
Join Date: Feb 2021
Location: TX
Posts: 37
Vehicle: 1992 Nissan D21
Thanks: 4
Thanked 3 Times in 3 Posts
Default

I just went under and think I found my problem. I repulled the shaft and found the rubber on the carrier bearing was split.
Salsapants27 is offline   Reply With Quote
Thanked by:
89'HBV6 (04-07-2021)
Old 04-07-2021, 10:04 PM   #14
Salsapants27
 
Join Date: Feb 2021
Location: TX
Posts: 37
Vehicle: 1992 Nissan D21
Thanks: 4
Thanked 3 Times in 3 Posts
Default

https://imgur.com/OdfoCsg

Last edited by 89'HBV6; 04-07-2021 at 10:20 PM.
Salsapants27 is offline   Reply With Quote
Old 04-07-2021, 10:08 PM   #15
Salsapants27
 
Join Date: Feb 2021
Location: TX
Posts: 37
Vehicle: 1992 Nissan D21
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Apparently I can't post a picture.
Salsapants27 is offline   Reply With Quote
Old 04-07-2021, 10:12 PM   #16
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State
Posts: 532
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 542
Thanked 133 Times in 116 Posts
Default

Quote:
Originally Posted by Salsapants27 View Post
I just went under and think I found my problem. I repulled the shaft and found the rubber on the carrier bearing was split.
Well, there's your problem! (o: Glad you found this, keep us posted...

RE: posting PICs: The URL needs to end in .JPG or PNG or some other image format. Understand?



EDIT: I'll del one of your image posts and leave the other. Post your image there, when you can. K?
__________________
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.

Last edited by 89'HBV6; 04-07-2021 at 10:18 PM.
89'HBV6 is offline   Reply With Quote
Old 04-07-2021, 10:30 PM   #17
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 10,499
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,679
Thanked 1,525 Times in 1,339 Posts
Default

Quote:
Originally Posted by Salsapants27 View Post
[url ]https://imgur.com/OdfoCsg[ /url]
I put some spaces in it so it shows.
  1. You used the [URL] tag instead of the [IMG] tag. URL is for Website addresses, IMG is for Images.
  2. Go to that URL https://imgur.com/OdfoCsg, find the image, and either copy the link to the image or open it in a new tab and copy the address out of the address bar. That address is https://i.imgur.com/OdfoCsg.jpg, but it is also a (3024x4032) sized photo. People will hate you if you post that. Imgur.com lets you resize the images in the [IMG] tags by adding letters: h for HUGE, l for LARGE, m for MEDIUM, etc. So:
    • https://i.imgur.com/OdfoCsgh.jpg
    • https://i.imgur.com/OdfoCsgl.jpg
    • https://i.imgur.com/OdfoCsgm.jpg
Those display with the [IMG] tags as follows:

HUGE:


LARGE:


MEDIUM:
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
89'HBV6 (04-07-2021)
Old 04-07-2021, 10:31 PM   #18
Salsapants27
 
Join Date: Feb 2021
Location: TX
Posts: 37
Vehicle: 1992 Nissan D21
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by 89'HBV6 View Post
Well, there's your problem! (o: Glad you found this, keep us posted...

RE: posting PICs: The URL needs to end in .JPG or PNG or some other image format. Understand?



EDIT: I'll del one of your image posts and leave the other. Post your image there, when you can. K?
No. Been trying to post, and upload in the album too, nothing is working. Tried following a previous post about it but even when it's sized correctly it won't work.
Salsapants27 is offline   Reply With Quote
Old 04-07-2021, 10:32 PM   #19
Salsapants27
 
Join Date: Feb 2021
Location: TX
Posts: 37
Vehicle: 1992 Nissan D21
Thanks: 4
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by jp2code View Post
I put some spaces in it so it shows.
  1. You used the [URL] tag instead of the [IMG] tag. URL is for Website addresses, IMG is for Images.
  2. Go to that URL https://imgur.com/OdfoCsg, find the image, and either copy the link to the image or open it in a new tab and copy the address out of the address bar. That address is https://i.imgur.com/OdfoCsg.jpg, but it is also a (3024x4032) sized photo. People will hate you if you post that. Imgur.com lets you resize the images in the [IMG] tags by adding letters: h for HUGE, l for LARGE, m for MEDIUM, etc. So:
    • https://i.imgur.com/OdfoCsgh.jpg
    • https://i.imgur.com/OdfoCsgl.jpg
    • https://i.imgur.com/OdfoCsgm.jpg
Those display with the [IMG] tags as follows:

HUGE:


LARGE:


MEDIUM:
Thank you
Salsapants27 is offline   Reply With Quote
Old 04-08-2021, 03:04 AM   #20
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 747
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 101 Times in 89 Posts
Default

Driveshaft! :-)
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.