Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 05-03-2022, 05:45 AM   #1
DatCamaroGuy
'91 D21 V6 4wd 5spd
 
Join Date: May 2022
Location: Marshfield, WI
Posts: 5
Vehicle: 1991 Nissan D21
Thanks: 0
Thanked 1 Time in 1 Post
Default Lost instrument/gauge cluster lights, tail lights, and marker lights.

(1991 model) Headlights, turn signals and brake lights work. Yesterday I went on a 4 hour round trip to pick up some parts and used a small trailer to transport them home, which is a standard 4 pin connection. I noticed that my end was corroded a little as this is the first time trailering with my pickup since I got it 6 months ago. I cleaned it and the tail lights on the trailer looked better than when I first saw them. I probably didn't clean the connector out enough, though.

As the cluster, marker, and tail lights all turned on when I turn the lights switch on the "markers only" spot on the light knob, I think it may be the switch. Funny enough, I bought one a few months ago because I thought it was the problem to a headlight out, but it wasn't, so I have the entire light switch/turn signal/cruise stick on hand. But if it was a fuse or a relay, where would it be located?

EDIT: I changed the tense of "turn" to "turned" to clarify that i have no cluster, marker, or tail lights at all.

Last edited by DatCamaroGuy; 05-03-2022 at 02:43 PM.
DatCamaroGuy is offline   Reply With Quote
Old 05-03-2022, 12:31 PM   #2
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 819
Vehicle: 2004 Frontier
Thanks: 0
Thanked 151 Times in 133 Posts
Default

Sounds like a bad headlight switch to me. Instrument cluster illumination, tail lights, and marker lights are all on the same circuit. Sounds like the contact for those in the headlight switch when in the "headlights on" position is not "closing" that circuit.


Your choice whether to replace the switch, or to "engineer" wiring so the cluster illumination, tail lights, and marker lights only come on in the headlight position (I did just that on my '8 Mazda truck before I replaced the headlight switch).
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Old 05-03-2022, 12:31 PM   #3
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 8,109
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 921
Thanked 1,106 Times in 996 Posts
Default

Fuse in the kick panel.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 05-03-2022, 12:39 PM   #4
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 819
Vehicle: 2004 Frontier
Thanks: 0
Thanked 151 Times in 133 Posts
Default

Quote:
Originally Posted by Deerhurst View Post
Fuse in the kick panel.

No, he stated cluster, marker, and tail lights all turn on when he turns the lights switch on the "markers only" spot on the light knob.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Old 05-03-2022, 01:46 PM   #5
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,741
Vehicle: 96 HB
Thanks: 223
Thanked 926 Times in 807 Posts
Default

I vote headlight switch needing cleaning or replacement as well.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 05-03-2022, 01:51 PM   #6
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 8,109
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 921
Thanked 1,106 Times in 996 Posts
Default

Quote:
Originally Posted by Cusser View Post
No, he stated cluster, marker, and tail lights all turn on when he turns the lights switch on the "markers only" spot on the light knob.



Missed that.





I have had issues with trailers causing my dash to go dead in the past. Was always a fuse issue.



If it comes back with the switch in a certain spot it's the switch.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 05-03-2022, 02:26 PM   #7
DatCamaroGuy
'91 D21 V6 4wd 5spd
 
Join Date: May 2022
Location: Marshfield, WI
Posts: 5
Vehicle: 1991 Nissan D21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Edit: forgot to clarify that my gauges, markers, and tail lights do not work at all. I just knew that they are all on the same circuit. That circuit is completely dead.
DatCamaroGuy is offline   Reply With Quote
Old 05-03-2022, 05:31 PM   #8
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 56
Posts: 8,009
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 71
Thanked 1,037 Times in 942 Posts
Default

Fuse should be bottom row far right. You can take a test light, and probe the end of each fuse to check them, probe top and bottom of the fuses.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 05-03-2022, 11:39 PM   #9
DatCamaroGuy
'91 D21 V6 4wd 5spd
 
Join Date: May 2022
Location: Marshfield, WI
Posts: 5
Vehicle: 1991 Nissan D21
Thanks: 0
Thanked 1 Time in 1 Post
Default

UPDATE: It was the 10 Amp fuse. For anyone looking at this issue that stumbles on this thread, the gauge clusters, marker lights, AND tail lights are on the same circuit. The fuse location is the bottom right of the panel underneath the left blower vent. It is labeled "Tail Lamp". I thought I had to replace the switch but nope, it was a fuse. Nice and simple.
DatCamaroGuy is offline   Reply With Quote
Thanked by:
89'HBV6 (05-04-2022)
Old 05-04-2022, 12:11 AM   #10
Tropicalcats
 
Tropicalcats's Avatar
 
Join Date: Aug 2017
Location: Perrysburg, Ohio
Posts: 671
Vehicle: 1995 Nissan King Cab XE
Thanks: 75
Thanked 70 Times in 65 Posts
Default

Quote:
Originally Posted by dvdswan View Post
I vote headlight switch needing cleaning or replacement as well.
Ditto It’s happened to me a couple times
__________________
The one constant in life is change.

“Never, Never, Never give up” Winston Churchill
Tropicalcats is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.