Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 12-30-2021, 02:40 AM   #1
torranosaurus
 
Join Date: Dec 2011
Location: Texas
Posts: 11
Vehicle: 96 D21
Thanks: 1
Thanked 1 Time in 1 Post
Default Removed my cluster to unplug airbag light now all lower bulbs not coming on

So I removed my 96 cluster to undo the airbag light and mow when I turn the ignition no lights come on in the cluster, only the guages work.
Also, the steering lock does not work and the key can be pulled out while running.
Any ideas?
torranosaurus is offline   Reply With Quote
Old 12-30-2021, 02:51 AM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,785
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,091
Thanked 2,227 Times in 1,828 Posts
Default

My guess is that something is poorly connected
__________________
alabama_lowlife is offline   Reply With Quote
Old 12-30-2021, 03:19 AM   #3
torranosaurus
 
Join Date: Dec 2011
Location: Texas
Posts: 11
Vehicle: 96 D21
Thanks: 1
Thanked 1 Time in 1 Post
Default

I checked everything.
Only thing working down there is the battery light which stays dimly lit constantly.
torranosaurus is offline   Reply With Quote
Old 12-30-2021, 03:44 AM   #4
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,785
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,091
Thanked 2,227 Times in 1,828 Posts
Default

Quote:
Originally Posted by torranosaurus View Post
I checked everything.
Only thing working down there is the battery light which stays dimly lit constantly.
This means your alternator is not charging.
__________________
alabama_lowlife is offline   Reply With Quote
Old 12-30-2021, 03:32 PM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,129
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,825
Thanked 1,783 Times in 1,555 Posts
Default

Quote:
Originally Posted by alabama_lowlife View Post
This means your alternator is not charging.
And if the alternator is not charging, it can cause a lot of other odd issues.

...except the key pulling out while the truck is running. That just means your ignition switch is worn out. You can replace those, or live with it.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 12-31-2021, 12:31 PM   #6
torranosaurus
 
Join Date: Dec 2011
Location: Texas
Posts: 11
Vehicle: 96 D21
Thanks: 1
Thanked 1 Time in 1 Post
Default

Figured it out.
The "Meter" fuse blew.
Battery light does come on dimly but it's charging at 13.9 so not sure on that.
I ordered a new ignition switch, should be here today.
torranosaurus is offline   Reply With Quote
Thanked by:
jp2code (12-31-2021)
Old 12-31-2021, 03:04 PM   #7
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 792
Vehicle: 2004 Frontier
Thanks: 0
Thanked 145 Times in 128 Posts
Default

Quote:
Originally Posted by torranosaurus View Post
Figured it out.
The "Meter" fuse blew.
Good !!!




Quote:
Originally Posted by torranosaurus View Post
Battery light does come on dimly but it's charging at 13.9 so not sure on that.
Sounds like it's charging fine; voltage across battery terminals while engine is running is typically 13.5 to 14.5 volts.


DO NOT DISCONNECT A BATTERY CABLE WHILE THE ENGINE IS RUNNING, EVER !!! BAD FOR ALTERNATOR-EQUIPPED VEHICLES, was used in old days as Gomer test on generator-equipped cars.




Quote:
Originally Posted by torranosaurus View Post
I ordered a new ignition switch, should be here today.
I had a bad ignition switch (electrical part) on my 1998 Frontier, was easy R&R.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.