Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 10-19-2021, 04:52 AM   #1
ctucker33
 
Join Date: Oct 2021
Location: WA
Posts: 17
Vehicle: Nissan Pickup 1994
Thanks: 13
Thanked 2 Times in 1 Post
Default Instrument lights go out when I turn brights on

1994 Hardbody 4x4

I have quite a few electrical light issues and not sure if they are all related or not (I'm new to this truck). If these are not all related, disregard the bottom 2 because I don't want to blow this up into what should be 3 different threads:

*When low beams are on, instrument panel lights works fine, chime works if engine is not running and door open. When I turn the hi-beams on, the instrument panel lights go off and the chime goes off as well (like it thinks the lights are not turned on).

*Parking lights do not come on when switch is turned on. Instrument panel lights don't turn on either.

*Side marker lights do not get any power with any setting.

Again, if none of these are related, ignore and please help me with the first one (instrument panel lights turn off when hi-beam is turned on). This sucks driving at night.

Thanks!

Craig

Last edited by ctucker33; 10-19-2021 at 04:59 AM.
ctucker33 is offline   Reply With Quote
Old 10-19-2021, 10:03 AM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,615
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,044
Thanked 2,167 Times in 1,780 Posts
Default

They could all be related. First off, check the fuses. I believe the 10 amp fuse in the bottom right corner is for the parking lights. Same wire feeds the interior lights.

Do the high beams actually work?

The headlight switches are prone to failure and cause a lot of weird lighting issues. Do you have a test light or a multimeter?

Also, welcome to infamous nissan!
__________________
alabama_lowlife is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 12:41 PM   #3
PoBoi850
 
PoBoi850's Avatar
 
Join Date: Aug 2019
Location: Tallahassee
Posts: 847
Vehicle: 88 2wd Z24i HB D21
Thanks: 364
Thanked 119 Times in 102 Posts
Default

Sounds like the switch has a bad ground or cross wired some where.
PoBoi850 is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 01:38 PM   #4
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 731
Vehicle: 2004 Frontier
Thanks: 0
Thanked 134 Times in 117 Posts
Default

Quote:
Originally Posted by ctucker33 View Post
*Parking lights do not come on when switch is turned on. Instrument panel lights don't turn on either.

These, and the tail lights, are all on the same circuit.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 03:38 PM   #5
ctucker33
 
Join Date: Oct 2021
Location: WA
Posts: 17
Vehicle: Nissan Pickup 1994
Thanks: 13
Thanked 2 Times in 1 Post
Default

Is this the headlight switch in the steering column?
ctucker33 is offline   Reply With Quote
Old 10-19-2021, 03:43 PM   #6
ctucker33
 
Join Date: Oct 2021
Location: WA
Posts: 17
Vehicle: Nissan Pickup 1994
Thanks: 13
Thanked 2 Times in 1 Post
Default

Thanks man. Yes, the hi beams work just fine. It just shuts off the instrument lights off.

Nevermind...Googled it:

Question: how do you test a switch using a multimeter (sorry for the juvenile question)?

Last edited by ctucker33; 10-19-2021 at 03:54 PM.
ctucker33 is offline   Reply With Quote
Old 10-19-2021, 04:48 PM   #7
PoBoi850
 
PoBoi850's Avatar
 
Join Date: Aug 2019
Location: Tallahassee
Posts: 847
Vehicle: 88 2wd Z24i HB D21
Thanks: 364
Thanked 119 Times in 102 Posts
Default

you can probably Google that too ...
PoBoi850 is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 07:41 PM   #8
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 1,160
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 981
Thanked 278 Times in 252 Posts
Default

Quote:
Originally Posted by ctucker33 View Post
Question: how do you test a switch using a multimeter (sorry for the juvenile question)?
Google is your friend...

https://youtu.be/lB-aULIjiog
__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 08:31 PM   #9
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,615
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,044
Thanked 2,167 Times in 1,780 Posts
Default

After you check the fuse let me know and I’ll tell you what wires to check for power at the switch.
__________________
alabama_lowlife is offline   Reply With Quote
Thanked by:
ctucker33 (10-19-2021)
Old 10-19-2021, 10:01 PM   #10
ctucker33
 
Join Date: Oct 2021
Location: WA
Posts: 17
Vehicle: Nissan Pickup 1994
Thanks: 13
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by alabama_lowlife View Post
After you check the fuse let me know and Iíll tell you what wires to check for power at the switch.
Ok, now I feel kinda dumb. The bottom right fuse is labeled 'Tail light'. I didn't think I had a problem with my tail lights. The fuse was blown in that (they had a 20a in a 10a slot, but whatever). Replaced the fuse and everything works fine now? WTF. Parking lights get power in the parking light position. Hi-beams come on and don't dark out my instrument panel. Chime stays on for all lights without key and door open. I didn't realize the 'Tail light' could've impacted all of that?

Thank you so much. Super helpful!
ctucker33 is offline   Reply With Quote
Thanked by:
89'HBV6 (10-20-2021), alabama_lowlife (10-20-2021)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.