Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 04-26-2021, 03:39 PM   #1
jimstl99
 
Join Date: Aug 2017
Location: St. Louis, MO
Posts: 41
Vehicle: 1995 Nissan XE V-6 King Cab 2wd w/5sp manual
Thanks: 17
Thanked 16 Times in 8 Posts
Default Unexpected surprise!

Sometimes bad leads to good. My brake lights were staying on so I researched here for the answer. Sure enough the correct fix was easily found in that the rubber grommet on brake pedal was most likely cause. One of the responses mentioned that there are two holes if you have cruise control. Interesting, my cruise hasn't worked for 5+ years and I could never figure out why no matter what I checked. Low and behold the 2nd hole on the pedal was missing a grommet. I replaced both and not only fixed my brake light issue but the cruise control works again just perfectly.


I can't thank the members on this board enough! Cheers to you!


Jim in St. Louis.
__________________

1995 Nissan XE V-6 King Cab 2wd w/5sp manual. 225/55-17 on 2004 Pathfinder wheels.

Last edited by jimstl99; 04-26-2021 at 06:15 PM. Reason: clarification
jimstl99 is offline   Reply With Quote
Thanked by:
89'HBV6 (04-28-2021), alabama_lowlife (04-26-2021), dvdswan (04-26-2021), EffinHaole (07-30-2021), Foul_Mouth (04-27-2021), Midnight Tech (04-29-2021), Project510 (07-30-2021), XoXSciFiGuy (04-27-2021)
Old 04-26-2021, 05:39 PM   #2
Reserector
the Flaming Marshmallow
 
Reserector's Avatar
 
Join Date: Oct 2015
Location: Laurel, MS
Posts: 1,833
Vehicle: Nissan HB KC 4x4
Thanks: 63
Thanked 489 Times in 382 Posts
Default

Sweet!
Reserector is offline   Reply With Quote
Old 04-26-2021, 08:04 PM   #3
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,399
Vehicle: 96 HB
Thanks: 191
Thanked 822 Times in 723 Posts
Default

Glad the forum helped.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Thanked by:
jimstl99 (04-26-2021)
Old 04-26-2021, 09:22 PM   #4
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 822
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 116 Times in 103 Posts
Default

Quote:
Originally Posted by jimstl99 View Post
Sometimes bad leads to good. My brake lights were staying on so I researched here for the answer. Sure enough the correct fix was easily found in that the rubber grommet on brake pedal was most likely cause.
May have been my post! Unfortunately, I learned the hard way, with the truck just stitting, parked -- battery was dead due to that light-switch stopper failing.

I recommend that others replace that bumper proactively.
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Thanked by:
jimstl99 (04-26-2021)
Old 04-28-2021, 03:48 AM   #5
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 49
Posts: 10,397
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 435
Thanked 1,322 Times in 1,201 Posts
Default

I keep one of those green stoppers with me.
cadillacdude1975 is offline   Reply With Quote
Old 04-28-2021, 05:24 PM   #6
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 912
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 790
Thanked 205 Times in 187 Posts
Default

Kudos! 2 birds... one stone... GOTTA LUV IT!
__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 07-30-2021, 03:50 AM   #7
EffinHaole
 
EffinHaole's Avatar
 
Join Date: May 2012
Location: Windward Oahu
Posts: 24
Vehicle: 97 King Cab
Thanks: 17
Thanked 2 Times in 2 Posts
Default

I swapped out the grommets with a pair 1/4" x 1/2" length bolts and nyloc nuts. One of the first things I do when getting a hardbody because the grommets will always fail.
__________________
Always give them a moving target.
EffinHaole is offline   Reply With Quote
Old 07-30-2021, 06:36 AM   #8
XoXSciFiGuy
 
XoXSciFiGuy's Avatar
 
Join Date: May 2017
Location: Yakima, WA
Posts: 3,238
Vehicle: 1997 D21 King Cab XE 2WD
Thanks: 219
Thanked 643 Times in 582 Posts
Default

The Facebook page for Infamous Nissan is a solid one with many contributors. But I always tell people that sometimes you are better off just coming to the main forum here. More tools to use, etc. It helps.

Glad you fixed your problem.
__________________

2009 Xterra, 4.0 liter, automatic, 4WD. Need a technical manual? Drop me a message. Chilton's for amateurs.
XoXSciFiGuy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.