Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 08-31-2021, 08:26 AM   #1
86KC
 
Join Date: Aug 2021
Location: Arizona
Posts: 4
Vehicle: 1986 nissan hardbody king cab
Thanks: 0
Thanked 0 Times in 0 Posts
Default Vg30i 86.5(?) King Cab 2wd 5 Manny I'm new owner and new to forums

To begin if anyone has any diagrams that can be shared that would amazing. Forum are old but knew to me just like this truck

I have no history of how many owners or maintenance beyond a fuel pump replacement last month. My old baby is sitting at over 270k miles which is last recorded on the Odometer-(notworking).
Now i am worried that #1 A head gasket is probably trashed on left side-(left when facing truck looking under the hood) sadly come to find was no oil in it (looking under oil refill was very discouraging). #2 Put 4 quarts in based off of what autozone found in they're system assumeing that all information given to me was correct. #3 maybe have guessed is water pump concern for my Thermostat is no longer working(only after some heavy rain). I do feel like their is some decompression/loss of power and slight "whine". The whine can be controlled based acceleration/shift timing. #4 lower radiator hose angles make me worried it looks kinked/pinched before that just after leaving the block (upper section of same hose). It looks like belts have been rubbing/shredding it periodically 4.5---- could possible motor mount/vibration cause said issue (when looking belts are not that close) plus I question the hose as it is not just one hose. #5 fluids I see only one dipstick? Being a standard and lack of owner history I'm worried about the transmission fluid.

In the cluster Odometer, Speedometer, Thermostat and oil temp i believe it is? are not working and radio aswell. I have a clusterwith the 2 different fuel gauges one being the 1/4 gauge. All fuses under the wheel are good.

I will provide any pics or any other information upon any inquiry.

I would love to know of any "normal" issues

Please any thoughts or suggestions will not be over looked.

Thank you to all who inquires, suggests or even just reads everything
86KC is offline   Reply With Quote
Old 08-31-2021, 08:55 AM   #2
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 1,039
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 889
Thanked 236 Times in 217 Posts
Default

WOW, hope we can help you get some of this squared away... and welcome...

It will help us if you can provide some PICs. If you can figure this out, it will help us to know what you're looking at. Many good "Image Hosts" on the WEB, look them up.

Normal issues? TIMING BELT! ...and get the FSM. (check my sig area below)
__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 08-31-2021, 12:36 PM   #3
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,866
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 903
Thanked 1,033 Times in 933 Posts
Default

Timing belt is important. Should be on your list.



The FS5R30A tranny has a TSB that says it makes.noise and that is normal. Otherwise it could be a too tight timing belt or a failing timing belt tensioner.



Of it's a 5wd it uses ~3.8qts of oil. I usually just go until I hit full on the dipstick.



If you do a water pump.you are 90% of the way to a timing belt. Thermostat should be a 170F.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is online now   Reply With Quote
Old 08-31-2021, 01:12 PM   #4
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 34
Posts: 4,062
Vehicle: '86.5 Nissan D21, '87 Mercedes 190D Turbo, '10 Mercedes E350 AWD, '16 Suzuki GSXS1000
Thanks: 415
Thanked 525 Times in 453 Posts
Default

If you have bad motor mounts, Rugged Rocks makes really nice solid mounts for the VG30i. I've had them in my truck since '12 or so.


Regarding the electrical issues, check your fuses and relays, particularly the accessory relay. Get you a FSM from the link in 89HBV6's sig to help track down which fuses do what. That accessory relay seems to be a fairly common source of problems on these trucks.


If the speedo and odo aren't working, most likely it's the speedometer cable. I'm fairly certain these are still available to purchase new. I bought a new one for mine in the early '10s.


Welcome to the forum! These trucks can be a bit of work to get going when they've been neglected for a while, but they're a blast and are super reliable once you get them squared away.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 8 MAR 2021
1986.5 FSM GI section - https://imgur.com/gallery/mjT18bV

OldGreyBeast is offline   Reply With Quote
Old 08-31-2021, 04:50 PM   #5
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,866
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 903
Thanked 1,033 Times in 933 Posts
Default

Speedo cable might be good, the little plastic pin behind the cluster could have failed. Pull the cluster and move the truck a little. See if the cable is spinning.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is online now   Reply With Quote
Old 08-31-2021, 09:49 PM   #6
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 1,039
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 889
Thanked 236 Times in 217 Posts
Default

Quote:
Originally Posted by Deerhurst View Post
Of it's a 5wd it uses ~3.8qts of oil.
I gots to see this... how does that work???
__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 08-31-2021, 09:59 PM   #7
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,866
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 903
Thanked 1,033 Times in 933 Posts
Default

Derp! I fat fingered!





The 5th wheel is the spare under the bed.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is online now   Reply With Quote
Thanked by:
89'HBV6 (08-31-2021)
Old 09-01-2021, 03:14 AM   #8
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 10,747
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,734
Thanked 1,629 Times in 1,423 Posts
Default

The 1989 Service Manual is available in free downloadable PDF. See the link below in my signature.

The 1989 has OBD codes, where your 1986.5 is preOBD. The rest of the file should have everything you need.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 09-01-2021, 05:08 AM   #9
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 49
Posts: 10,429
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 436
Thanked 1,325 Times in 1,204 Posts
Default

Welcome to IN. With no known service history, the timing belt, water pump, coolant bypass hose, cam and crank seals need to be done ASAP. The cylinder heads (valves) are toast imif the tinibg belt breaks.
cadillacdude1975 is offline   Reply With Quote
Old 09-03-2021, 12:54 PM   #10
86KC
 
Join Date: Aug 2021
Location: Arizona
Posts: 4
Vehicle: 1986 nissan hardbody king cab
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey sorry everyone I have read each of the responses I'm figuring out to put pictures on here. I plan on getting a Haynes Maintenance book. At the moment I don't have a way to just order an fsm unless I'm jus blatantly over looking something. I can do majority of these things myself but you can see why I think it's futile to jump on getting just the "hose/belt" replaced as my roommates tell me. Feel free to keep sending/replying any ideas or suggestions for well anything . Thanks
86KC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.