Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-28-2021, 04:39 AM   #1
tannerg1223
Tannerg1223
 
Join Date: Feb 2021
Location: USA
Posts: 31
Vehicle: Nissan D21 1996
Thanks: 5
Thanked 2 Times in 2 Posts
Default KA mysterious misfiring...

Hey guys! Im new to the forum so bear with me as I get used to the formatting. I own a '96 extended hardbody with the KA24E. I have big plans in the near future of installing a turbo and making the ultimate daily drifter. before such goals are achieved, I am slowly preparing the truck for the boost it will soon receive.

I bought the truck 4 years ago and have always had a slight misfire that's been plaguing my life. Ive replaced the fuel filter, distributer, did a timing chain and guides, spark plugs (iridiums) and wires, as well as the coolant temp sensor. Not to mention the copious amounts of fuel additives to try and clean my fuel system. I am stumped.

The miss is very subtle. So much so as that it doesn't throw any codes or give me a check engine light at all! It gets worse as I give it throttle or let off till about 3k rpms. Any help out there is much appreciated! I will try and answer as many questions as possible to help you guys further understand my dilemma...

Last edited by tannerg1223; 02-28-2021 at 04:47 AM. Reason: to help better explain my problem
tannerg1223 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.