Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 05-13-2020, 06:33 PM   #1
Tepidguacamole
 
Join Date: Mar 2020
Location: VA
Posts: 10
Vehicle: 1993 D21
Thanks: 7
Thanked 2 Times in 2 Posts
Default Weird starting/starter relay issue?

Hey guys, I'm pretty much at the end of my knowledge regarding this subject and maybe someone here can help me.

I have a 1993 D21, 2WD, with the KA24E.
My problem is that, when turning the key, all I hear is the click of a relay under the dashboard and nothing happens.

However, the previous owner installed a pushbutton to start the car, and this is the beginning of my confusion. One terminal of the button runs to the positive battery post, and one is spliced into a wire going into the starter relay. It's a pink/black wire and connects to the starter solenoid. The truck will start right up when the button is pushed, but I'm trying to eliminate the need for this.

I've replaced the ignition switch, the starter relay, and checked all fuses. The safety switch that the clutch pedal is supposed to press in order to start has been eliminated and its wires are twisted together.

I just can't figure out why the engine will start with the button, which appears to bypass the starter relay (which is a new relay), but otherwise won't, after eliminating some likely culprits.
Tepidguacamole is offline   Reply With Quote
Old 05-13-2020, 09:05 PM   #2
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,688
Vehicle: 96 HB
Thanks: 215
Thanked 908 Times in 792 Posts
Default

Have you tried swapping the relay? It sounds like that is what the push button is for.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Thanked by:
Tepidguacamole (05-19-2020)
Old 05-13-2020, 10:47 PM   #3
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 50
Posts: 10,688
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 459
Thanked 1,403 Times in 1,268 Posts
Default

This problem has plagued me for almost a year and a half. But when my key is turned, it does nothing. All internal power does what it should while the key is in the start position. I have changed the starter, the ignition switch and swapped all the relays. It startrd doing this out of no where. It will go weeks and not start with the key. I ended up putting a toggle switch from a switched 12v source direct to the starter solenoid. If the key does not work, i simply flip the switch and go on with my day.

It has frustrated the hell out of me. Oh and this problem is with my 87 kingcab v6.
cadillacdude1975 is offline   Reply With Quote
Thanked by:
Tepidguacamole (05-19-2020)
Old 05-14-2020, 12:06 AM   #4
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,135
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,825
Thanked 1,786 Times in 1,558 Posts
Default

I pulled my clutch relay out and soldered the power wires together. It will crank every time now.

Like SBJ hinted at, it sounds like a bum relay.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
Tepidguacamole (05-19-2020)
Old 05-15-2020, 08:37 PM   #5
Tepidguacamole
 
Join Date: Mar 2020
Location: VA
Posts: 10
Vehicle: 1993 D21
Thanks: 7
Thanked 2 Times in 2 Posts
Default

Thanks for the replies, guys.
I tried 2 different starter relays and nothing. Then I tried to jump the power wires together like jp2code said, and nothing. So I tested for power at the yellow wire, and.... it's not getting any, even when the key is turned. This is weird. According to the starting system diagram, the ignition switch should route power straight to that wire, but it's not...

I tested both ignition relays under the dash just to be sure, and they seem to be working fine. I don't get it.

Well, if I can't figure that out, is there any harm in running a wire from the ignition switch's terminal to the starter solenoid? I tested it out and it will start that way, when the key is turned to ignition. It just bothers me that this wiring situation is funky. Maybe I'm overthinking it when it comes to an old vehicle.
Tepidguacamole is offline   Reply With Quote
Old 05-15-2020, 08:53 PM   #6
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,135
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,825
Thanked 1,786 Times in 1,558 Posts
Default

I've seen a lot of members here that had to replace the ignition switch. So far, I have not. Knock on wood.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
Tepidguacamole (05-19-2020)
Old 05-15-2020, 09:22 PM   #7
Tepidguacamole
 
Join Date: Mar 2020
Location: VA
Posts: 10
Vehicle: 1993 D21
Thanks: 7
Thanked 2 Times in 2 Posts
Default

Ok, now I've got something figured out, uh, maybe. I just went outside and played with it.

I put the starter relay back in.
I turned the key to ignition and it clicked like before, right?
I unscrewed the ignition switch, and, just for fun, turned its tumbler over to ignition using a screwdriver.
The truck starts.

Uhhhh...what?
It's like the cylinder that the key turns is not turning the ignition switch all the way over. I can make it click but not start if I barely turn the switch with the screwdriver, and start if I turn it a little bit more. What the hell?
It's doing this with both the old and the new switch.

Do I need a key cylinder? I've never seen this sort of problem.
Tepidguacamole is offline   Reply With Quote
Old 05-15-2020, 10:46 PM   #8
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,135
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,825
Thanked 1,786 Times in 1,558 Posts
Default

Quote:
Originally Posted by Tepidguacamole View Post
Ok, now I've got something figured out, uh, maybe. I just went outside and played with it.

I put the starter relay back in.
I turned the key to ignition and it clicked like before, right?
I unscrewed the ignition switch, and, just for fun, turned its tumbler over to ignition using a screwdriver.
The truck starts.

Uhhhh...what?
It's like the cylinder that the key turns is not turning the ignition switch all the way over. I can make it click but not start if I barely turn the switch with the screwdriver, and start if I turn it a little bit more. What the hell?
It's doing this with both the old and the new switch.

Do I need a key cylinder? I've never seen this sort of problem.
God bless. It's like the ficking ignition switch is out or something, huh?

What r u gonna do bra????
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
Tepidguacamole (05-19-2020)
Old 05-16-2020, 06:02 PM   #9
Tepidguacamole
 
Join Date: Mar 2020
Location: VA
Posts: 10
Vehicle: 1993 D21
Thanks: 7
Thanked 2 Times in 2 Posts
Default

Well I've got the key lock as well as replacement door locks incoming, 'cause none of them really work very well, so we'll see. If this new one won't turn the ignition switch fully I might have to get creative...
Tepidguacamole is offline   Reply With Quote
Old 05-16-2020, 07:06 PM   #10
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 52
Posts: 11,135
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,825
Thanked 1,786 Times in 1,558 Posts
Default

Quote:
Originally Posted by jp2code View Post
God bless. It's like the ficking ignition switch is out or something, huh?

What r u gonna do bra????
Apologies. I was drinking a Four Loco last night and that just seemed funny to me. Sober Joe (me now) just thinks that it's stupid.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
nunya (05-16-2020), Tepidguacamole (05-19-2020)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:19 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.