Go Back   Infamous Nissan - Hardbody / Frontier Forums > Infamous Nissan > Introductions

Reply
 
Thread Tools Display Modes
Old 11-25-2021, 02:50 PM   #1
HardbodyGirl84
 
Join Date: Nov 2021
Location: AR, USA
Posts: 1
Vehicle: Nissan D21 1995
Thanks: 0
Thanked 1 Time in 1 Post
Default New girl, old truck

Hi guys! So I bought my 95 Hardbody about 3 years ago but just found out about this forum. I named him Space Ghost because he's white and I fully plan to take him coast to coast. He's a 5 speed with lots of mileage. He's currently around 331k. When I got him, he had been used as a delivery truck for auto parts and he was so raggedy on the interior. Bench seat didn't move (I'm 5' tall so that definitely wasn't going to be ok), no headliner, the passenger side of the seat looked like a raccoon and made a nest in it, etc. The guy really didn't take care of it. It has since has a new headliner, bucket seats, center console, new speakers, radio, tweeters, sub and amp, and a handful of other things to make it ride more smoothly. In the 3 years I've had it, I've put almost 40k miles on it. Would have been more but it sat for about 6 months until I had money to fix the power steering pump.

I do have some questions that I was told I could find the answers to on here but I'm not sure where to post them. Maybe so.ekne can point me in the right direction:
- it didn't have a dimmer switch when I got it so I have no dash lights. There was a switch in the glove box but it isn't the one that should go with it I don't think. Could I just rewire this to make the 3 prong work? For reference, my dimmer switch is to the right of the steering wheel above the AC button.
- No reverse lights. I have replaced the fuse a few times and it blows the fuse almost immediately. Does it just need rewired or is there something else going on?
- The other week my odo and trip stopped working for a little bit which bummed me out. The mileage is a point of pride for me at this point and I want to make sure I get all the miles added on properly. I haven't been able to find a video or manual that shows me where to find and check that cable.

If you happen to know the answers or can point me to the correct forum topic, that would be awesome. Also, does anyone else have random strangers show up to your house asking you to sell your truck to them? I get that multiple times a month. They always try to lowball me, too. I love my truck and have no intention of selling. People think it's weird to love a little beat up truck so much but you guys get it.
HardbodyGirl84 is offline   Reply With Quote
Thanked by:
PoBoi850 (12-07-2021)
Old 11-25-2021, 03:14 PM   #2
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 742
Vehicle: 2004 Frontier
Thanks: 0
Thanked 137 Times in 120 Posts
Default

Quote:
Originally Posted by HardbodyGirl84 View Post
it didn't have a dimmer switch when I got it so I have no dash lights.
One can wire up the dash cluster lights to come on when the key is in the "Run" position; and you won't notice this during the day. My own 1970 VW has been wired this way since late 1976 !!!




Quote:
Originally Posted by HardbodyGirl84 View Post
Bench seat didn't move
That can be made to work, or if seat from a different vehicle that was simply bolted in, new holes can be made.




Quote:
Originally Posted by HardbodyGirl84 View Post
No reverse lights. I have replaced the fuse a few times and it blows the fuse almost immediately. Does it just need rewired or is there something else going on?
My guess - without seeing the truck - would be (1) more likely a bad socket for the reverse lights or (2) bad reverse light switch on the transmission. It's also possible that the wire is rubbing somewhere and shorting out. But I'd take out the 2 reverse light bulbs FIRST and then see if the fuse blows and if it does, then disconnect the wires to the two reverse lamps and see if the fuse blows then.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Old 11-25-2021, 04:45 PM   #3
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,537
Vehicle: 96 HB
Thanks: 203
Thanked 862 Times in 754 Posts
Default

Welcome to the site. We like pictures of our trucks. Please post some.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 11-25-2021, 06:07 PM   #4
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 1,371
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 1,123
Thanked 326 Times in 297 Posts
Default

Yea, we "get it"... Welcome to IN!


__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 11-26-2021, 06:07 AM   #5
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 49
Posts: 10,554
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 446
Thanked 1,364 Times in 1,236 Posts
Default

Does the truck have a trailer wiring harness? When these trucks were made, add-on trailer pigtails were the splice type. The problem with that is the hardbody uses a five wire system (left turn, right turn, brake, tail light and ground) and 9 out of 10 trailers use a 4 wire system. If that is not the case, the rear wire harness runs down the right side of the frame. Like it was mentioned above, check for damage/pinched/chafed wiring.

Does the speedometer still work? The speedo cable is still available. I bought a new one a few years back. The cable is notorious for having problems, but those problems usually do not happen unless the cluster is repeatedly removed. With that many miles, it probably just died. The cable can be changed in about an hour.

welcome to IN.
cadillacdude1975 is offline   Reply With Quote
Old 11-27-2021, 06:50 PM   #6
Foul_Mouth
Pounding Rox Truck
 
Foul_Mouth's Avatar
 
Join Date: Mar 2010
Location: Western NY
Posts: 4,813
Vehicle: Too Many to List Here
Thanks: 581
Thanked 870 Times in 681 Posts
Default

You need a green hb to name Zorak.
__________________
*1992 Supercharged and Body Swapped WD21 Pathfinder
*1995 D21 Regular Cab 2wd
*(2)1991 D21 Regular Cab
*1990 WD21 Pathfinder Frame
*2004 Xterra
*2010 Infiniti G37x

Nissan Truck Videos (Builds-Racing-Shows-Tech)
https://www.youtube.com/c/NissanTruckguy
IG@ rainmaker_d21









Foul_Mouth is offline   Reply With Quote
Old 12-06-2021, 09:04 PM   #7
IntotheVoid69
 
IntotheVoid69's Avatar
 
Join Date: Apr 2021
Location: LA/Vermont
Posts: 36
Vehicle: 1995 Nissan Hardbody 4x4
Thanks: 16
Thanked 3 Times in 1 Post
Default

your back up lights.... sounds like the fuse is getting overloaded. what is the amp your putting in there? also are your tail lights stock or after market? i was driving around with aftermarket lights and had no idea my lights werent working. turns out i had to pay 35$ for ALL NEW LIGHT BULBS! so annoying.
IntotheVoid69 is offline   Reply With Quote
Old 12-07-2021, 04:13 AM   #8
PorknBeans
 
Join Date: Dec 2019
Location: Where I can see the air I breathe...
Posts: 597
Vehicle: 1997 XE King Cab with 3 pedals, KA24E & 2WD, Y’all
Thanks: 66
Thanked 187 Times in 153 Posts
Default

HardbodyGirl…

If you want to keep the miles original and it’s a point of originality and pride…Don’t drive the vehicle. If you have a secondary ride. Use that until the odometer, blown fuse and other issues are resolved.
__________________
PorknBeans is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:38 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.