Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 12-01-2020, 04:34 PM   #1
Bucketgod
 
Join Date: Dec 2020
Location: Mexico
Posts: 2
Vehicle: Nissan d21 SE 1987
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with idle ing

ok Hi i just changed the spark plug wires of my 1987 nissan d21 (vg30i) and when i finished changing the cables the pickup didnt want to turn on i returned to the original cables and not even with that wanted to turn on then i put the new ones again and to my surprise it turned on fine so i let the pickup rest and the next day i wanted to turn it on it just turned on like nothing happened i went to take a test drive and it did good ,turned the pickup off again and the next day it didnt want to turn on again and now it doesnt stay on if i dont press the gas pedal and it smells like gas too any ideas ?

Btw sorry for the kinda broken english
Bucketgod is offline   Reply With Quote
Old 12-01-2020, 09:53 PM   #2
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 774
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 105 Times in 93 Posts
Default

Did you replace anything else" E.g., the distributor cap?


If not, it sounds as if the installation or wireset were incorrect. And possibly one or more wires/connections/cap was/were damaged.
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Old 12-01-2020, 11:42 PM   #3
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,539
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 894
Thanked 940 Times in 856 Posts
Default

First, check the install. Second, pull codes.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 12-02-2020, 12:38 AM   #4
Bucketgod
 
Join Date: Dec 2020
Location: Mexico
Posts: 2
Vehicle: Nissan d21 SE 1987
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i didnt replaceed the cap just the cables a i double check the install and nothing and i dunno how to see codes it doesnt have a obd2 port i have a video on what is doing i have to mention it worked fine though it have a small gas smell when i turned it on or when i revved the engine on a cold start https://youtu.be/-zfXqwUzkkI
Bucketgod is offline   Reply With Quote
Old 12-02-2020, 01:37 AM   #5
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,539
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 894
Thanked 940 Times in 856 Posts
Default

There is a good guide here on checking codes. Also the process is outlined in the FSM. OBD wasn't standard here in the states until the mid 90s.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:03 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.