Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 06-28-2020, 09:55 PM   #1
Cfern85
 
Join Date: Sep 2018
Location: VA
Posts: 6
Vehicle: 93 hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default CV axle c clip

Hello all. I'm trying to get this new cv axle back on but the shaft doesn't stick out of the knuckle far enough for me to get the c clip on past the hub parts. I've looked at the opposite hub and a diagram to ensure that I'm putting everything back in the correct order and direction. I'm only an 1/8in short or so and it's definitely the correct cv axle for this truck. What gives? Thanks in advance.
Cfern85 is offline   Reply With Quote
Old 06-28-2020, 11:38 PM   #2
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,862
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 901
Thanked 1,033 Times in 933 Posts
Default

Is it seated in the hub all the way?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 06-29-2020, 03:21 AM   #3
Cfern85
 
Join Date: Sep 2018
Location: VA
Posts: 6
Vehicle: 93 hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It seems to be, is there a way I can tell? I don't know how I could put any more pressure on it, and believe me I've tried. I also tried removing the abs dust cover, which didn't give me anything either.
Cfern85 is offline   Reply With Quote
Old 06-29-2020, 03:53 AM   #4
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,862
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 901
Thanked 1,033 Times in 933 Posts
Default

ABS? I don't know if the D21 got ABS, just the equalizing valve on the rear.





Might have to bump it from the other end with a dead blow or try to seat it a little more forcefully. I believe there is a little dust seal or similar in there that will fight you some. I remember fighting with it when I replaced an axle shaft.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 06-29-2020, 04:18 PM   #5
Cfern85
 
Join Date: Sep 2018
Location: VA
Posts: 6
Vehicle: 93 hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I believe you're right about the lack of abs. The new axle came with an abs dust cover but the one I removed from the truck did not. It's going to be hard to hit the axle from the other end but I'll give it a shot, thanks.
Cfern85 is offline   Reply With Quote
Old 06-29-2020, 05:19 PM   #6
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,862
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 901
Thanked 1,033 Times in 933 Posts
Default

It's a pain. With how it is will it even mate up to the diff flange?



Coming with the abs stuff sounds like maybe they sent you the wrong part.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 09-05-2021, 02:27 AM   #7
94SEV6
 
Join Date: Sep 2021
Location: WA
Posts: 2
Vehicle: 1994 D21 SEV6 4x4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wondering how this got resolved because I am running into a simaler issue while reinstalling my CV axles. Thanks
94SEV6 is offline   Reply With Quote
Old 09-05-2021, 04:27 AM   #8
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,862
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 901
Thanked 1,033 Times in 933 Posts
Default

No idea. Fern never updated us. My guess is the part was wrong or just not seating all the way.



For years I ran without those clips. Didn't know I needed them until I found the with my warn hubs. The 86.5 has a few different things like that anyways like the missing retainer clips on the torsion bars.



I'd just make sure the CV is seated all the way. Look for burrs in the spline that could cause an issue.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 09-05-2021, 04:58 AM   #9
94SEV6
 
Join Date: Sep 2021
Location: WA
Posts: 2
Vehicle: 1994 D21 SEV6 4x4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine is a 94. I know I've put it all back together correctly. I just replaced the entire front suspension and steering and now I'm stuck not getting the clips on. I also got warn hubs for mine. I dont want to force anything to the point of breaking; I already had to replace a needle bearing because I was dumb.

I got the rough country 2 inch lift that came with new upper control arms but I thought the stock length cv axles would be fine. It just doesn't stick through the knuckle enough and I'm kinda annoyed ��
94SEV6 is offline   Reply With Quote
Old 09-08-2021, 10:48 PM   #10
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 49
Posts: 10,426
Vehicle: 87 VG33 Pathfinder SE 4x4 & 87 D21 SE
Thanks: 436
Thanked 1,325 Times in 1,204 Posts
Default

Did you replace the inner wheel bearings?
cadillacdude1975 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:41 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.