Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 03-25-2010, 03:46 AM   #1
bmxican
 
bmxican's Avatar
 
Join Date: Mar 2010
Location: jefferson city, mo
Posts: 29
Vehicle: 97' nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default motor bogging down

well first off im new to infamous i was on the old site awhile back, but anyways i got a 97 ext cab hardbody 2.4L 5-speed, well it just started happening, mostly in low rpms in first and second gear the truck kinda bogs down like its putting along, then around 3000rpms itll take off good. i have no clue what the problem is, also i hooked it up to a computer today and its throwing one code: air intake temperature circuit malfunction? i look at the temp thing in the air filter box and the two wires are snipped can this cause this?? well any info from you guys is always great so please throw in your 2cents thanks
bmxican is offline   Reply With Quote
Old 03-25-2010, 04:04 AM   #2
david29
Administrator
 
Join Date: Sep 2008
Location: Spring(Houston), Texas
Age: 44
Posts: 4,930
Vehicle: 1987 Nissan King Cab
Thanks: 26
Thanked 254 Times in 229 Posts
Default

Quote:
Originally Posted by bmxican View Post
well first off im new to infamous i was on the old site awhile back, but anyways i got a 97 ext cab hardbody 2.4L 5-speed, well it just started happening, mostly in low rpms in first and second gear the truck kinda bogs down like its putting along, then around 3000rpms itll take off good. i have no clue what the problem is, also i hooked it up to a computer today and its throwing one code: air intake temperature circuit malfunction? i look at the temp thing in the air filter box and the two wires are snipped can this cause this?? well any info from you guys is always great so please throw in your 2cents thanks
What happens when the air temp sensor is not hooked up, the ECM runs the truck rich. This in turn will clog up the catalytic converter. Replace the air temp sensor and see what happens.
__________________
My stable of Nissan trucks includes:
1987 Nissan King Cab(full frame off restoration)
1989 Nissan Pathy 2 door XE V-6(SOLD)
2000 Nissan Frontier(bagged, will clear 20"s)
david29 is offline   Reply With Quote
Old 03-25-2010, 04:09 AM   #3
bmxican
 
bmxican's Avatar
 
Join Date: Mar 2010
Location: jefferson city, mo
Posts: 29
Vehicle: 97' nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by david29 View Post
What happens when the air temp sensor is not hooked up, the ECM runs the truck rich. This in turn will clog up the catalytic converter. Replace the air temp sensor and see what happens.
well see the problem is i looked at the temp sensor and whoever had the truck before me clipped the sensor wires so i have no clue where they even hook up
bmxican is offline   Reply With Quote
Old 03-25-2010, 04:12 AM   #4
david29
Administrator
 
Join Date: Sep 2008
Location: Spring(Houston), Texas
Age: 44
Posts: 4,930
Vehicle: 1987 Nissan King Cab
Thanks: 26
Thanked 254 Times in 229 Posts
Default

Quote:
Originally Posted by bmxican View Post
well see the problem is i looked at the temp sensor and whoever had the truck before me clipped the sensor wires so i have no clue where they even hook up
The 2 wires come out of the harness that comes through the firewall right next to the AC lines. Not sure right off hand what color they are but I can find out tomorrow.
__________________
My stable of Nissan trucks includes:
1987 Nissan King Cab(full frame off restoration)
1989 Nissan Pathy 2 door XE V-6(SOLD)
2000 Nissan Frontier(bagged, will clear 20"s)
david29 is offline   Reply With Quote
Old 03-25-2010, 04:30 AM   #5
bmxican
 
bmxican's Avatar
 
Join Date: Mar 2010
Location: jefferson city, mo
Posts: 29
Vehicle: 97' nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by david29 View Post
The 2 wires come out of the harness that comes through the firewall right next to the AC lines. Not sure right off hand what color they are but I can find out tomorrow.
ok cool dude thanks so could this be causing this problem?
bmxican is offline   Reply With Quote
Old 03-25-2010, 04:45 AM   #6
david29
Administrator
 
Join Date: Sep 2008
Location: Spring(Houston), Texas
Age: 44
Posts: 4,930
Vehicle: 1987 Nissan King Cab
Thanks: 26
Thanked 254 Times in 229 Posts
Default

Quote:
Originally Posted by bmxican View Post
ok cool dude thanks so could this be causing this problem?
Its possible. Sounds more like the MAF sensor to me though. Or a timing issue.
__________________
My stable of Nissan trucks includes:
1987 Nissan King Cab(full frame off restoration)
1989 Nissan Pathy 2 door XE V-6(SOLD)
2000 Nissan Frontier(bagged, will clear 20"s)
david29 is offline   Reply With Quote
Old 03-25-2010, 04:55 AM   #7
bmxican
 
bmxican's Avatar
 
Join Date: Mar 2010
Location: jefferson city, mo
Posts: 29
Vehicle: 97' nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by david29 View Post
Its possible. Sounds more like the MAF sensor to me though. Or a timing issue.
ya i was thinkin earlier that it might involve the MAF sensor
bmxican is offline   Reply With Quote
Old 07-18-2010, 09:32 PM   #8
DRAGN20S
DRAG THAT SH?T
 
DRAGN20S's Avatar
 
Join Date: Dec 2008
Location: Ellerbe north carolina
Posts: 50
Vehicle: NissaN hardbody
Thanks: 0
Thanked 1 Time in 1 Post
Default

well i waz haveing the same problem and i replaced the MAF and that didnot fix it ...so i need help too i also replaced the plugs wires rotor buttom and dizzy cup and the pcv valve and fuel filter too i dont know what else too do .......
__________________
drag or die
DRAGN20S is offline   Reply With Quote
Old 07-19-2010, 03:03 AM   #9
zmanchee
 
Join Date: Dec 2009
Location: Columbia, SC
Posts: 91
Vehicle: Nissan Hardbody 1995
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.oreillyauto.com/site/c/detail/BOR0/EC461.oap?year=1995&make=Nissan&model=Pickup&vi=12 12174&keyword=air+temperature+sensor&pt=02185&ppt= C0033


Is that the air temp sensor cause my truck is doing the same thing except if i can get it past 3000rpms it stops
zmanchee is offline   Reply With Quote
Old 07-25-2010, 06:58 AM   #10
93hb4me
 
Join Date: Apr 2010
Location: phx arizona
Posts: 218
Vehicle: 93 nissan d21
Thanks: 0
Thanked 1 Time in 1 Post
Default

actually thats your maf that wont let it rev past 3000 rpms

im throwing an air temp code as well on my 240sx motor never was hooked up so if you could tell me the colors of the wires that would be great !
93hb4me is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:29 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.