Infamous Nissan - Hardbody / Frontier Forums  

Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 08-11-2010, 10:16 PM   #1
hayesracer
 
Join Date: Aug 2010
Location: iowa
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
View hayesracer's Photo Album
Default 87 d21 problems

i have a 87 d21 with the vg30iv6 its starts and runs for 3-5 secounds then dies. i have put new throttle body and replaced distributor, It maintains fuel pressure but acts like the injectors are not pulsing wondering if any other sensors/switches make injectors pulse? It wil run as long as u spray starter fluid down the intake if anyone has any ideas please let me know

thanks alex

Last edited by hayesracer; 08-11-2010 at 11:11 PM..
hayesracer is offline   Reply With Quote
Old 08-12-2010, 12:03 AM   #2
Garbar Norris
 
Garbar Norris's Avatar
 
Join Date: Apr 2009
Location: Holloman AFB NM
Age: 23
Posts: 161
Thanks: 6
Thanked 4 Times in 4 Posts
View Garbar Norris's Photo Album
Default

does this engine have a MAF?
Garbar Norris is offline   Reply With Quote
Old 08-12-2010, 01:50 AM   #3
1800bucks
 
1800bucks's Avatar
 
Join Date: Mar 2009
Location: Newark, Ohio
Posts: 317
Thanks: 0
Thanked 5 Times in 4 Posts
View 1800bucks's Photo Album
Default

It's obviously a fuel starvation issue. Have you tried something as simple as a new fuel filter? There are also 2 injectors in the throttle body that can get clogged. Altho you may have pressure, is it enough pressure? Maybe the pump is getting weak. Do you have a lot of miles on it?
1800bucks is offline   Reply With Quote
Old 08-12-2010, 03:07 AM   #4
hayesracer
 
Join Date: Aug 2010
Location: iowa
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
View hayesracer's Photo Album
Default

yes it has a new filter on it according to chiltion it has 36psi and holds steady but the book dont have alot of info on the v6 thats why i was wondering if there could be a sensor or switch that also makes the injectors pulse? i dont know i really havent delt with the nissans at all so i need any ideas i can get the hole throttle body is a reman unit with new injectors and the miles are high like 150000 any ideas im open to
hayesracer is offline   Reply With Quote
Old 08-12-2010, 02:37 PM   #5
TruckMods
 
TruckMods's Avatar
 
Join Date: Sep 2008
Location: Stover, MO
Age: 29
Posts: 997
Thanks: 0
Thanked 0 Times in 0 Posts
View TruckMods's Photo Album
Default

as mentioned not getting enouph fuel. If its getting good fuel pressure than it may not be the pump. Sounds more like Injectors though
TruckMods is offline   Reply With Quote
Old 08-13-2010, 02:38 AM   #6
mike2225
 
Join Date: Aug 2010
Location: phoenix
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
View mike2225's Photo Album
Default

try checking the codes. might help instead of throwing parts at it.
mike2225 is offline   Reply With Quote
Old 08-13-2010, 03:02 AM   #7
hardbodylwb
WHAT! A Longbed?
 
hardbodylwb's Avatar
 
Join Date: Feb 2010
Location: Chattanooga, TN
Age: 24
Posts: 448
Thanks: 5
Thanked 6 Times in 6 Posts
View hardbodylwb's Photo Album
Default

mine did the same thing...every other month it would do that and ran like shit when it decided to let me put it in drive...i just did a tune up(complete wires, plugs, distributer) then a new maf, and tps, fuel filter, oil filter and oil change.now it drives like new no problems....oh and seafoam with a 1/2 bottle of rubbing alchol in gas tank...hope it helps
__________________
When I get naked in the bathroom, the shower gets turned on.

------------------------------------------------
S-10 Project build
http://www.infamousnissan.com/forum/...ad.php?t=28813
1991 Nissan Hardbody Lwb-SOLD
1990 Isuzu Pickup-SOLD
2000 Nissan Frontier- Traded
1995 S-10- Winter project
hardbodylwb is offline   Reply With Quote
Old 08-14-2010, 05:16 PM   #8
hayesracer
 
Join Date: Aug 2010
Location: iowa
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
View hayesracer's Photo Album
Default

im going to sound dumb but wheres the maf sensor located?
hayesracer is offline   Reply With Quote
Old 08-17-2010, 08:18 AM   #9
mike2225
 
Join Date: Aug 2010
Location: phoenix
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
View mike2225's Photo Album
Default

drivers side of throttle body
mike2225 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:11 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.