Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 07-14-2019, 04:32 PM   #1
Madrazo
 
Join Date: May 2019
Location: Las Vegas
Posts: 2
Vehicle: 1987 d21 se 3.0 L
Thanks: 1
Thanked 0 Times in 0 Posts
Default Spark from the center of the cap

so I'm running a 1987 SE 3.0. I went to time the truck and the cap shocked me. I went and got new plug wires, cap, and rotor. With all the new stuff on it I still get zapped. Tracing where the ark comes from, its coming from the center of the cap as stated. Like where the spring loaded pin is at. It is the same spot with the old and the new cap. Anyone know what would causes this I've dug and cant find anything. To also clarify, there is no arking from around any of the wires or anywhere else on the cap, just the top center.

Any suggestions would be awesome
Madrazo is offline   Reply With Quote
Old 07-14-2019, 04:39 PM   #2
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 47
Posts: 9,366
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 345
Thanked 1,091 Times in 1,006 Posts
Default

Replace the cap with one from Nissan. I went through three at auto zone before I got a good one.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is online now   Reply With Quote
Thanked by:
Madrazo (08-23-2019)
Old 07-14-2019, 04:39 PM   #3
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 47
Posts: 9,366
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 345
Thanked 1,091 Times in 1,006 Posts
Default

And welcome to IN.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is online now   Reply With Quote
Old 08-23-2019, 02:41 AM   #4
Madrazo
 
Join Date: May 2019
Location: Las Vegas
Posts: 2
Vehicle: 1987 d21 se 3.0 L
Thanks: 1
Thanked 0 Times in 0 Posts
Default

thanks for the quick update sorry for the delay, I got a Nissan cap and it no longer zaps.
Madrazo is offline   Reply With Quote
Old 08-24-2019, 05:51 AM   #5
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 47
Posts: 9,366
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 345
Thanked 1,091 Times in 1,006 Posts
Default

Glad it is normal again. Those cheap caps are junk.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is online now   Reply With Quote
Old 08-26-2019, 12:31 PM   #6
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 422
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 40 Times in 36 Posts
Default

Interesting. Y'all using anything other than OEM ignition coils?
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.