Go Back   Infamous Nissan - Hardbody / Frontier Forums > Infamous Nissan > General Discussion

Reply
 
Thread Tools Display Modes
Old 05-12-2016, 02:32 PM   #1
Slidewayz86
 
Join Date: May 2016
Location: Nebraska
Posts: 2
Vehicle: Nissian d21 1986
Thanks: 0
Thanked 0 Times in 0 Posts
Cool 86 2wd v6 hb

Ok so I'm new to here just have a quick question... Last week my battery died on me so I replaced it then 2 days later I lost all power ( shut down while I was driving ) so I imagined it was my alternator that was bad replaced it and now I have no power no dash lights nothing...I also realized that i don't really have a fuse box under my hood..... All help appreciated... Thanks
Slidewayz86 is offline   Reply With Quote
Old 05-12-2016, 03:02 PM   #2
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 30
Posts: 3,355
Vehicle: 1986.5 Nissan D21
Thanks: 284
Thanked 376 Times in 328 Posts
Default

Sounds like a fusible link to me. My 86.5 4x4 has the fusible links in a box along the passenger side fender behind the battery under some plastic covers. Some of them have a fusible link on the positive battery cable where it connects to the battery terminal.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
OldGreyBeast is offline   Reply With Quote
Old 05-12-2016, 05:23 PM   #3
Slidewayz86
 
Join Date: May 2016
Location: Nebraska
Posts: 2
Vehicle: Nissian d21 1986
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I'll have to check that out
Slidewayz86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:19 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.