Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 01-08-2021, 06:27 AM   #1
VaughnA
 
Join Date: Jan 2021
Location: South Africa
Posts: 1
Vehicle: Hardbody vg30 1999
Thanks: 0
Thanked 0 Times in 0 Posts
Default Starter motor wants to run constantly

Hi all,
I had a starter problem, slowly over time worked less often, then one day nothing. Found a site (itstillruns), found that solenoid needed replacing. Confirmed with local elec shop, so replaced it. Now, starter runs as soon as battery connected. Elec shop says rotate the solenoid....does this sound right? Cannot find similar information anywhere.thanks
VaughnA is offline   Reply With Quote
Old 01-08-2021, 11:51 AM   #2
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 51
Posts: 10,452
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,669
Thanked 1,506 Times in 1,324 Posts
Default

It sounds like you might have the wires backwards on it. Perhaps that's what the shop means when it says to rotate the solenoid.

South Africa? You are a long way from me. Good luck.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 01-08-2021, 07:05 PM   #3
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 2,333
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 210 Times in 197 Posts
Default

^^ this sounds right. sounds like the wire from the battery is on the wrong lug of the starter so its always "hot"
street_rulerr is offline   Reply With Quote
Old 02-26-2021, 12:15 AM   #4
Pinstripe
 
Join Date: Apr 2015
Location: Canada
Posts: 154
Vehicle: 1991 Nissan D21 King Cab, KA24E, 2WD, Manual Transmission
Thanks: 41
Thanked 10 Times in 10 Posts
Default

I did that when I installed my starter for the first time, I hooked up the wires wrong. What jp2code and street_rulerr said sounds right.

So you only replaced the solenoid and not the whole starter?
Pinstripe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.