Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 08-29-2013, 12:56 AM   #11
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,673
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 315
Thanked 955 Times in 884 Posts
Default

yes static. the left one blinks the first digit of the code and then the right one is the last digit.

a code 43 would be 4 blinks of the left light (its green or red, and the other one is the opposite) and 3 blinks of the right light.
cadillacdude1975 is offline   Reply With Quote
Old 01-19-2014, 01:26 PM   #12
Jim_Rockford
 
Join Date: Jan 2014
Location: Richmond,Va
Posts: 8
Vehicle: 1993 sev6 4x4
Thanks: 0
Thanked 1 Time in 1 Post
Default

here is one for ya, I have a 1993 se v6 king cab 4x4 when I got it it had sat up for 6 years, changed the fuel tank, blew out the lines and it fired right up, while under the truck i noticed the o2 sensor wires where chewed off, but i drove it around for a while and never got a check engine light, it comes on when you start the truck like normal, but never comes on the show a code, so i repaired the o2 sensor, and plugged it back in, changed the thermostat cause the other one wasn't getting very hot, no it get to operating temp and once it does it idles so high it hits the fuel shutoff. and still no check engine light
Jim_Rockford is offline   Reply With Quote
Old 01-19-2014, 11:28 PM   #13
Jim_Rockford
 
Join Date: Jan 2014
Location: Richmond,Va
Posts: 8
Vehicle: 1993 sev6 4x4
Thanks: 0
Thanked 1 Time in 1 Post
Default

checked the codes tonight and all I got was a speedo signal code, thats because the cable is broke, nothing dealing with the o2
guess the ECM figures its not that important
Jim_Rockford is offline   Reply With Quote
Old 01-19-2014, 11:35 PM   #14
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 39
Posts: 8,882
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 567
Thanked 1,556 Times in 1,270 Posts
Default

You should start a new thread in the engine forum to get more help
__________________
alabama_lowlife is offline   Reply With Quote
Old 03-13-2014, 09:22 PM   #15
esch
rust bucket
 
esch's Avatar
 
Join Date: Feb 2014
Location: Fargo, ND
Posts: 113
Vehicle: Nissan D21 1986.5
Thanks: 7
Thanked 8 Times in 7 Posts
Default

Didn't see any updates for the 86.5 z24i ECU so I'll add it.

As Jr. said, seat removal not necessary for this but it will make it much easier.
There is no plastic cover on the ecu (at least not mine) so just move the passenger seat to it's most forward position.
There is a sticker along with a toggle that says <-ON-OFF>
Turn your ignition key to the on position and flip the switch to ON (*note, my toggle is long gone so I had to reach in there with a pen to move it, as the sticker says don't use the force of thor)
Now move the seat as far back as you can and you will see the ECU with a semi-clear box right in the center. on the right side (towards the passanger door) there is a red LED and on the left a green LED.
The red LED will flash out the first number of the code, the green the second.
Don't worry about catching them all right away as they will repeat until you turn the switch off.
After you've written down or memorized all the codes slide the seat forward again and turn off the switch.


Picture of the ecu, sorry for the mess. Yes that is a shotgun shell, a gift from the previous owner apparently. At least it wasn't touching any hot wires :/

Found a useful image that is worlds better than my instructions.

Last edited by esch; 03-13-2014 at 09:39 PM.
esch is offline   Reply With Quote
Old 05-04-2014, 10:10 PM   #16
randy111
 
Join Date: Apr 2014
Location: Kiamichi, Ok
Posts: 48
Vehicle: 91 pickup
Thanks: 1
Thanked 0 Times in 0 Posts
Default after watching the 1-5 test signal

I turned the knob all the way counter clockwise, and neither light was lit, or blinking.
randy111 is offline   Reply With Quote
Old 10-20-2014, 12:16 AM   #17
johnber
grouchy old man
 
Join Date: Oct 2014
Location: Lynden WA
Age: 61
Posts: 986
Vehicle: 89 4X base
Thanks: 6
Thanked 116 Times in 106 Posts
Default

Quote:
Originally Posted by Static808 View Post
My truck doesnt habe a check engine light do i just follow the leds
yup, thats it........
__________________
89 regular cab, plain as it gets with a z-24 and posi's
johnber is offline   Reply With Quote
Old 01-02-2015, 08:55 PM   #18
Ghosty
 
Ghosty's Avatar
 
Join Date: Apr 2014
Location: tupelo mississippi
Posts: 324
Vehicle: 1993 hardbody ka24 2wd
Thanks: 4
Thanked 13 Times in 11 Posts
Default

My check engine light and the led on the ecu are telling me different things. The led are telling me 55. And the engine light is telling me 23. The engine light says 23 then it blink 4 fast then 5 fast. Then 1 slow the. Two slow. And repeat process
__________________
1993 nissan hardbody drift/drag project
2wd ka24 (soon to be a twin turbo 350 sbc)
Ghosty is offline   Reply With Quote
Old 01-02-2015, 09:24 PM   #19
ahardb0dy
The Post Count Whore
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 52
Posts: 7,273
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 62
Thanked 823 Times in 763 Posts
Default

Just noticed today when I pulled the seat to get to the ECU screw that the check engine light would flash when the red LED was blinking, but it doesn't flash when the green LED flashes.

I tried to adjust the idle using the screw on the ECU as supposedly you can, didn't make any difference on my truck.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 01-02-2015, 09:27 PM   #20
ahardb0dy
The Post Count Whore
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 52
Posts: 7,273
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 62
Thanked 823 Times in 763 Posts
Default

Quote:
Originally Posted by Ghosty View Post
My check engine light and the led on the ecu are telling me different things. The led are telling me 55. And the engine light is telling me 23. The engine light says 23 then it blink 4 fast then 5 fast. Then 1 slow the. Two slow. And repeat process

When the engine light is blinking 1-2-3-4-5, those are not codes, those are what mode it is in, the ecu goes through the 5 modes when ever you turn the screw or flip the switch (depending on the year)

If you have the key turned to "ON" , engine off and turn the screw ( or flip the switch), after the LED's or check engine light flashes 3 times you turn the screw fully back than you will be in mode 3 where you can read any stored codes.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.