Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 10-10-2011, 02:55 AM   #1
SkinnyG
UYFBR
 
SkinnyG's Avatar
 
Join Date: Sep 2008
Location: Okanagan Valley - Canada, eh?!
Posts: 1,500
Vehicle: 1994 Hardbody
Thanks: 0
Thanked 204 Times in 147 Posts
Default Retrofitting Interval Wipers



My 1994 4cyl Hardbody did not come with interval wipers. It also did not appear to have it as an option. Like Cruise Control, I think it is a V6 or Pathfinder option.

You will need the following components:
  • Wiper Switch (snag the wiring pigtail while you're at it)
  • Intermittent Wiper Amplifier (snag the wiring pigtail)

In the factory application, the Intermittent Wiper Amplifier is clamped to the wiper motor itself. This cannot be fitted with the KA24E because the air filter housing is in the way. It could be located elsewhere, however I found that the wiring ordeal was much easier by mounting the Amplifier at the steering column (no stringing wires to the engine bay).

First, study the wiring diagram. There are a number of connections to un-pin:



I found it easiest to just re-pin and add pins following each wire in the Factory Wiring Diagram. There were a couple online tutorials that I had found that allegedly made this easier, but I found them more frustrating. I'm good with "real" schematics.

Disassemble the steering column covers, unplug and remove the switch:



The interval wiper switch should fit in place easily (I had picked up a square dash switch, but I ended up using a round dash switch. The attachment appears to be the same between both):



Remove the plastic clip and un-pin the connectors in the switch pig tail (the new switch has more connections - you need these ends and their colours). You need to insert a wee pin through the connecting side of the plug to remove the connector - it's easy once you get the hang of it:



Some wires will be moved within your truck's plug, and some will have to be added. The BLUE (heat-shrink coming soon), BLACK, WHITE-BLUE and RED-BLUE wires are going to the Amplifier. The extra BLUE-RED (used for "mist") is disconnected and unused (I sealed it off later):



I needed to tap into the BLUE wire, so I pulled the pin and just soldered to it (yes, that's my Palm-Pilot - a reminder I need a 1-5/8" hole saw for another project):



The BLUE-YELLOW wire needs to be tapped in at the fuse box. Start by removing the fuse box, and pulling back and towards the floor so we can deal with it:



Pull this white plastic clip out of the side of the fuse box:



Unpin the BLUE-YELLOW side of the wiper fuse and pull it out the back. Solder another BLUE-YELLOW wire from here to the Amplifier:





Replace the fuse box:



Here's the mess so far, ready for wrapping in electrical tape and zap-strapping out of the way:



I strapped the Amplifier to the column with two large zap straps:



Replace the steering column plastic and you're ready for light rain!

I can hear the Amplifier clicking when the Intermittent Wipers are on (truck not running), however I don't know if I will hear it when I'm driving. If it's bothersome, I'll lengthen some wires to put it in the engine bay, or wrap it in something to quieten it down. Time will tell.
__________________
No longer an active member - The Hideous Hardbody has been sold

Last edited by SkinnyG; 10-10-2011 at 09:59 PM.
SkinnyG is offline   Reply With Quote
Thanked by:
DenverDude (10-04-2013), Hardbody92 (11-28-2014)
Old 09-30-2013, 01:10 AM   #2
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,301
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 293
Thanked 915 Times in 848 Posts
Default

someone was just talking about how they did this the other day. bump for newer members to see this useful information.
cadillacdude1975 is offline   Reply With Quote
Old 10-01-2013, 02:26 AM   #3
jwc1080
 
Join Date: Feb 2012
Location: NC
Posts: 56
Vehicle: 93 Hardbody 4x4
Thanks: 0
Thanked 1 Time in 1 Post
Default

Did this to mine and i honestly think it was the best upgrade yet. I have another spare kit to if anyones interested.
jwc1080 is offline   Reply With Quote
Old 10-27-2014, 06:36 PM   #4
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,217
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,165
Thanked 1,023 Times in 900 Posts
Default

I picked up the amp at the local yard this weekend and snagged the strap that it uses to mount to the wiper motor as well.

Since I have the VG30e, I have plenty of room to mount this in the engine compartment.

Looking at the wiring diagram and what you wrote up there Skinny, it looks like the necessary wires should go all the way back to the steering column.

I can't tell from your picture, though. Can anyone confirm or deny this?

Here is a bigger wiring diagram pic:

__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Old 10-27-2014, 08:39 PM   #5
CasanovaGDP
 
CasanovaGDP's Avatar
 
Join Date: Aug 2013
Location: Dallastown PA
Posts: 557
Vehicle: 86.5 Nissan Hardbody
Thanks: 49
Thanked 55 Times in 52 Posts
Default

Joe that brown thing i sent you was the amp... also someone should make this a sticky
CasanovaGDP is offline   Reply With Quote
Old 10-27-2014, 09:23 PM   #6
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,217
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,165
Thanked 1,023 Times in 900 Posts
Default

Quote:
Originally Posted by CasanovaGDP View Post
Joe that brown thing i sent you was the amp...
I wasn't sure where it went or how it connected. When I saw one at the yard, I wasn't sure if I had as much wiring as was sitting in front of me - so I snagged it.

Now, I have an extra.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Old 10-27-2014, 11:04 PM   #7
Midnight Tech
 
Midnight Tech's Avatar
 
Join Date: Jan 2013
Location: Back in SC again...in the back of the parts store...
Posts: 1,099
Vehicle: 1986.5 D21 Hardbody 2WD
Thanks: 78
Thanked 104 Times in 94 Posts
Default

Joe, you may already have the pigtail for the amp on your truck...I've seen mention that the later models came prewired.
__________________
"Off To See the Lizard"... courtesy of J. Buffett
__________________
"Project NX" aka "Hector" - 86.5 D21 Hardbody ... with a slight drop in its future...
__________________

Out of Round Tuits....
Midnight Tech is offline   Reply With Quote
Old 10-30-2014, 04:07 PM   #8
Dragon
Lowered Class c.c
 
Dragon's Avatar
 
Join Date: Jul 2013
Location: Yucca valley ca
Age: 35
Posts: 130
Vehicle: 1994 Nissan hardbody
Thanks: 1
Thanked 20 Times in 18 Posts
Default

my 94 with the ka came with this from the factory, but i would like to know how to add the cruise control to it
Dragon is offline   Reply With Quote
Old 10-30-2014, 05:05 PM   #9
johnber
grouchy old man
 
Join Date: Oct 2014
Location: Lynden WA
Age: 60
Posts: 972
Vehicle: 89 4X base
Thanks: 6
Thanked 112 Times in 102 Posts
Default

I want to put em on mine as well......got used to them on all my other rigs and really miss it.
__________________
89 regular cab, plain as it gets with a z-24 and posi's
johnber is offline   Reply With Quote
Old 02-09-2015, 07:00 AM   #10
vancouverhardbody
 
Join Date: Feb 2015
Location: Vancouver canada
Posts: 13
Vehicle: nissan hb1996 2wd 4cyl 5spd SB
Thanks: 0
Thanked 1 Time in 1 Post
Default

is it true that towards the last few years of production that intermittant wipers were prewired for the amplifier?
I have installed the intermittent wiper arm of the same style, but did not grab the amplifier, im hoping my 96 is prewired fot the amp.
vancouverhardbody is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.