Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 10-15-2018, 10:55 PM   #1
VOTS95
 
Join Date: Apr 2015
Location: Phoenix
Posts: 264
Vehicle: 1995 XE King Cab V6, Desert Runner
Thanks: 26
Thanked 56 Times in 45 Posts
Default My Engine Whistles and I don't Know Why

My truck whistles when I accelerate and sounds just like a turbo. The noise is coming from the engine. It also sounds like the noise you get from the alternator that comes out thru the stereo/speakers as interference. My radio isn't hooked up so it's not coming from there.

Anyone dealt with this before? Thanks

VOTS
__________________


1995 XE, V6, 5 Speed
VOTS95 is offline   Reply With Quote
Old 10-15-2018, 11:01 PM   #2
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 5,193
Vehicle: 1986.5 Hardbody
Thanks: 712
Thanked 487 Times in 450 Posts
Default

Vacuum leak in the intake. Could be anything from a bad gasket, a crack, bad vaccum line, etc.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 10-15-2018, 11:16 PM   #3
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 1,847
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 132 Times in 126 Posts
Default

maybe it finally assumed its final form and that includes a turbo
street_rulerr is offline   Reply With Quote
Thanked by:
datsn (10-16-2018)
Old 10-16-2018, 11:29 AM   #4
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 49
Posts: 8,760
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,266
Thanked 1,092 Times in 963 Posts
Default

There a resistor that mounts to the alternator next to the power pigtail that is supposed to eliminate this noise. I've heard of people taking those off because they didn't know what they were for.

I looked in the Electrical section of the Service Manual, but it doesn't mention it, so I don't have any pictures.

Does your alternator still have this resistor?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
VOTS95 (10-19-2018)
Old 10-16-2018, 11:40 AM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 49
Posts: 8,760
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,266
Thanked 1,092 Times in 963 Posts
Default

I tried to get you a picture of mine just now, but there just isn't room to get a camera down there on the V6. Maybe if the truck were up on a lift, someone could get a good picture from the bottom.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 10-16-2018, 06:50 PM   #6
Dragon
Lowered Class c.c
 
Dragon's Avatar
 
Join Date: Jul 2013
Location: Yucca valley ca
Age: 35
Posts: 145
Vehicle: 1994 Nissan hardbody
Thanks: 1
Thanked 25 Times in 21 Posts
Default

Mine will whine like that after I tighten the belts up until they start to loosen up
__________________
Current rides:
94 hardbody(bob), single cab, system, shit ton of mods
00 altima(wade), few mods, huge system
06 armada(bertha), 24's, system, looking to slam it
Dragon is offline   Reply With Quote
Thanked by:
Hands On (10-16-2018), VOTS95 (10-19-2018)
Old 10-16-2018, 08:53 PM   #7
Hands On
XXXXXXXXXXXX
 
Hands On's Avatar
 
Join Date: Aug 2017
Location: United States
Posts: 363
Vehicle: A Hardbody
Thanks: 119
Thanked 65 Times in 61 Posts
Default

The new alternator I installed a couple months ago whines a bit under the hood but not through the speakers. There was no resistor on it that I noticed. Old one did not make this noise.
__________________
Yep.
Hands On is offline   Reply With Quote
Old 10-16-2018, 09:23 PM   #8
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 31
Posts: 3,584
Vehicle: 1986.5 Nissan D21, 1987 Mercedes 190D Turbo, 2010 Mercedes E350 AWD
Thanks: 317
Thanked 414 Times in 363 Posts
Default

This can happen if your timing belt is too tight as well.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
OldGreyBeast is offline   Reply With Quote
Thanked by:
Hands On (10-16-2018)
Old 10-16-2018, 09:49 PM   #9
Hands On
XXXXXXXXXXXX
 
Hands On's Avatar
 
Join Date: Aug 2017
Location: United States
Posts: 363
Vehicle: A Hardbody
Thanks: 119
Thanked 65 Times in 61 Posts
Default

I will double check tension on the belt then. Assume you mean the v-belt. I had over-tightened the alt belt initially, then let up a bit before locking it down. Thought it felt about right, but I don't wanna wear out the bearings in the thing. AC belt makes the tiniest chirp when the compressor kicks on, so i know it's not that one.
__________________
Yep.
Hands On is offline   Reply With Quote
Old 10-16-2018, 09:54 PM   #10
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 31
Posts: 3,584
Vehicle: 1986.5 Nissan D21, 1987 Mercedes 190D Turbo, 2010 Mercedes E350 AWD
Thanks: 317
Thanked 414 Times in 363 Posts
Default

The VG engines have a timing belt rather than a chain. That belt can be noisy if it's too tight. I overtightened mine on the last go round and had to take all that crap back off again to loosen it a bit. The timing stuff on the VG engines sucks so much peen.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
OldGreyBeast is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:24 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.