Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 02-13-2018, 12:55 PM   #1
Tropicalcats
 
Tropicalcats's Avatar
 
Join Date: Aug 2017
Location: Wildwood, Florida
Posts: 343
Vehicle: 1995 Nissan King Cab XE
Thanks: 44
Thanked 24 Times in 24 Posts
Default Idle problem ? Sometimes

My truck runs pretty well. It has developed this little habit that on occasion it will stutter from a stop when I give it gas. I will also idle fine but when I put it into park the RPMs go up to about 1500
What do you all think? Itís a 95 4 Cyl
__________________
The one constant in life is change
Tropicalcats is offline   Reply With Quote
Old 02-13-2018, 01:11 PM   #2
YEPEE
 
Join Date: Mar 2013
Location: Phoenix
Posts: 1,550
Vehicle: 86.5 HB, 02 Sentra Spec-V
Thanks: 149
Thanked 227 Times in 200 Posts
Default

there is a ficd (fast idle control device) solenoid, maybe sticking. thermo element or aacv, couple of thoughts
YEPEE is offline   Reply With Quote
Old 02-15-2018, 08:28 PM   #3
whyit
 
Join Date: Mar 2016
Location: Norfolk, VA
Posts: 67
Vehicle: 1995 d21 v6 4wd
Thanks: 1
Thanked 0 Times in 0 Posts
Default

can be a bad ground at the MAF sensor
whyit is offline   Reply With Quote
Old 02-15-2018, 10:13 PM   #4
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,354
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 294
Thanked 924 Times in 856 Posts
Default

No CEL?
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 02-16-2018, 12:40 AM   #5
Tropicalcats
 
Tropicalcats's Avatar
 
Join Date: Aug 2017
Location: Wildwood, Florida
Posts: 343
Vehicle: 1995 Nissan King Cab XE
Thanks: 44
Thanked 24 Times in 24 Posts
Default

Quote:
Originally Posted by cadillacdude1975 View Post
No CEL?
? Not sure what you mean
__________________
The one constant in life is change
Tropicalcats is offline   Reply With Quote
Old 02-20-2018, 08:47 PM   #6
whyit
 
Join Date: Mar 2016
Location: Norfolk, VA
Posts: 67
Vehicle: 1995 d21 v6 4wd
Thanks: 1
Thanked 0 Times in 0 Posts
Default

He means is there a check engine light, have you wiggled the wires for the MAF sensor? it is right past the air filter in the intake tube.
whyit is offline   Reply With Quote
Old 02-20-2018, 09:26 PM   #7
Tropicalcats
 
Tropicalcats's Avatar
 
Join Date: Aug 2017
Location: Wildwood, Florida
Posts: 343
Vehicle: 1995 Nissan King Cab XE
Thanks: 44
Thanked 24 Times in 24 Posts
Default

No check engine light.
__________________
The one constant in life is change
Tropicalcats is offline   Reply With Quote
Old 02-20-2018, 11:54 PM   #8
ahardb0dy
The Post Count Whore
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 52
Posts: 7,042
Vehicle: 1993 Nissan Hardbody
Thanks: 58
Thanked 785 Times in 731 Posts
Default

sometimes there is no light, best thing is to check the ECU for any codes. A stutter from a stop could be bad plug wires.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 1993 Nissan Hardbody king cab 2wd
, (formerly owned: 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.