Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 05-06-2018, 06:17 PM   #11
Natnater
 
Join Date: May 2018
Location: Missouri
Posts: 50
Vehicle: 97 D21 for the most part
Thanks: 16
Thanked 7 Times in 7 Posts
Default

Could it be the MAF? I had very similar issues with my 97 and replacing the MAF solved it for me. Truck would sputter and jump for a while whenever I'd switch gears before "catching" and driving just fine for a while.

Ended up going out on me on the highway and I had to roll it in first gear for a few miles to get into my covered tow zone due to being broke haha
Natnater is offline   Reply With Quote
Old 05-06-2018, 07:47 PM   #12
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,482
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,204
Thanked 1,057 Times in 931 Posts
Default

Yes, it could be the MAF.

Generally, the ECU throws a code when it goes into limp mode for the MAF.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.