Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 08-26-2010, 12:11 AM   #1
SkinnyG
UYFBR
 
SkinnyG's Avatar
 
Join Date: Sep 2008
Location: Okanagan Valley - Canada, eh?!
Posts: 1,500
Vehicle: 1994 Hardbody
Thanks: 0
Thanked 204 Times in 147 Posts
Default How to: Retrofitting A/C

I’m getting old.

My sweetie’s Sunfire has air conditioning. I like having air conditioning in my vehicles. The truck gets brutal hot in the summer, and the wind noise with all the windows open (not cooling you down, I might add) is brutal – 102dB measured at 100km/h. That’s hearing damage zone.

So, I scoffed all the parts to install A/C from both Kelowna Pick-N-Pull and Vernon Auto Wreckers.

If you can get all the parts from ONE vehicle, that would be best. From an R134a vehicle, even besterest. If you have the KA24, get the parts from a KA24 vehicle.

Things you will need to get, most of which can be used:

1. Compressor
2. Compressor bracket with belt tension idler
3. Pressure line to Condenser (and support bracket)
4. Condenser
5. Drier (buy new, such as Four Seasons #33582) & Dual Pressure Switch
6. Hard line from Drier to Evaporator
7. Evaporator and housing (Buy a new Expansion Valve, such as Four Seasons #38637)
8. Suction line to Compressor
9. A/C Relay #1 (mounted on RH inner fender – closest to firewall)
10. A/C Relay #2 (mounted in fuse box – middle)
11. A/C Switch on dash
12. Evaporator drain hose and grommet
13. Evaporator firewall grommet
14. New O-Rings
15. (not shown) A/C belt - Dayco #17340 fit my truck



Luckily, Nissan really planned this out, and installing it all is really easy and all the wiring is already there. The final filling needs to be done with specialized equipment, so you may need to farm that out.

This is merely the order I installed the parts:



Pull the grill off and remove the center support. The Condenser fits into existing holes in the lower panel.

Drier hard line is supposed to be stuffed through the round hole in the upper left, where the wiring connection is shown below. I, however, stuffed it through the lower hole because I thought that's where I got it from (below the overflow bottle). My bad. Either way, use 3/8" rubber insulated P-Clips to secure to the inner fender.



Dual Pressure Switch wiring is tucked behind the headlight, taped out of the way.



Drier attachment. Wires should actually go behind bulkhead. (This picture was taken after the system was fully assembled and charged up.) ALSO the solid line should enter the engine bay through the TOP hole, not the bottom one. Stupid me. Works though.

This is where I discovered that the R134a Pathfinder evaporator I had acquired did not match the R12 lines I got from a Hardbody. Installing the Evaporator had to wait until another trip into Vernon….



Compressor Bracket is attached to existing bosses in the engine block.



Compressor is attached to bracket (hard lines are installed in this picture).



Shot from the bottom. Removing the splash pan makes this easier.



Existing A/C Compressor wire is here….



…. but it needs to look like THIS to connect to the R12 pump I have. Solder & heat shrink tubing.



One relay connection is tucked under the wiring harness here.



The relay is attached beside an existing relay. I used a 1/4-20 RivNut and bolt.



http://www.gwellwood.com/project-car...y/hideous-air/

Last edited by SkinnyG; 03-14-2018 at 10:42 PM. Reason: Re-directed images to my website; curse you, Photobucket!
SkinnyG is offline   Reply With Quote
Old 08-26-2010, 12:12 AM   #2
SkinnyG
UYFBR
 
SkinnyG's Avatar
 
Join Date: Sep 2008
Location: Okanagan Valley - Canada, eh?!
Posts: 1,500
Vehicle: 1994 Hardbody
Thanks: 0
Thanked 204 Times in 147 Posts
Default

Picked up the correct evaporator. No visible difference other than the suction end.



Remove all the clips from the Evaporator housing, carefully separate the two halves, and carefully remove the old Expansion Valve. You could gamble on using the old one, but you’re in there anyway – it’s easy to change it now.



The original Expansion Valve was wrapped in some sort of foam tape wrap stuff that I couldn’t find when I needed it. I ended up using some pipe wrap from Home Depot, with some tape to help secure it. The point of it is so that the Expansion Valve ONLY sees temperature from the tube it’s clamped to, not ambient air. This should work.



Remove the glove box door and rear panel. In mine, the ECU had been relocated from under the seat to the rear panel – you won’t see all that nasty wiring on yours.



Notice the extra connector taped to the blower resistor wires. It plugs into the top of the Evaporator housing.

3 screws and the whole empty tube comes right out.



Poke out these plugs. These are where the A/C goes. The drain hole is about 3″ to the left of my baby finger.

Install the evaporator housing into the vehicle.



A different plug seals the lines through the firewall. It uses the same hardware though.



Dash push button wiring is just hanging right behind this panel. Here it is hooked up to the switch. Evaporator is already installed. 3 bolts, two plugs. Easy.



Push button just snaps in place once you remove the blanking cover. Snake the wires around to connect as shown previously. You will need to remove the center trim piece, and pop the heater control ends and bezel off to get at all of this.



Had to chop a hole in the rear panel and deform the glove box a bit to clear the ECU and everything. Again, this is abnormal – yours won’t be like this. I’m sure there is a tidier approach, however, but I’ll worry about that later. I don’t spend a lot of time in the glove box.



This relay isn’t listed in the FSM wiring diagram I have, but it is mentioned in the pictures. Or maybe I mis-read it. You will need it. Plugs right in. I used one of the two relays I stole from under the hood of the Pathfinder.



Evaporator to Compressor line attaches easily to existing plastic plugs in the firewall.

Next, the system is fully evacuated (using vacuum to boil out any moisture) and charging with R134a and some sort of ester-based oil……



High-pressure retrofit fitting attached.

Last edited by SkinnyG; 03-14-2018 at 10:43 PM. Reason: Images hosted off my own site
SkinnyG is offline   Reply With Quote
Thanked by:
rat410 (04-08-2015)
Old 08-26-2010, 12:32 AM   #3
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 38
Posts: 8,727
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 509
Thanked 1,495 Times in 1,229 Posts
Default

nice job, i'll stick this one.
alabama_lowlife is offline   Reply With Quote
Old 08-26-2010, 01:08 AM   #4
smpresco9027
 
smpresco9027's Avatar
 
Join Date: Jan 2010
Location: Virginia
Age: 26
Posts: 106
Vehicle: 92 HB
Thanks: 0
Thanked 3 Times in 3 Posts
Default

glad i asked about it earlier. thanks a bunch for this post.
smpresco9027 is offline   Reply With Quote
Old 08-26-2010, 01:56 AM   #5
MurderedOutHardBody
MurderedOut Moderator
 
MurderedOutHardBody's Avatar
 
Join Date: Mar 2010
Location: Greenville, North Carolina
Age: 34
Posts: 1,613
Vehicle: 98 sonoma, 2000 bagged durango, 86 bagged toyota
Thanks: 50
Thanked 112 Times in 90 Posts
Default

yea even though i completed mine just before seeing this write up, this is an awesome write up on it. i just finished putting my new condensor in mine today, and its really a simple job for anyone who doesnt have ac now and has access to a junk truck with ac, or is willing to spend the cash for new stuff. i got most of mine used, and a few peices new, will have it charged hopefully next week, if it works it will be well worth it.



oh but one more thing you will need, that is not listed, u will need the 3rd belt for the crank to the ac compressor and bracket.
__________________
1986 Toyota - bagged, 20s, in progress
2000 Durango - Project, bagged, billet 22s and 24s,
MurderedOutHardBody is offline   Reply With Quote
Old 08-26-2010, 03:16 AM   #6
SkinnyG
UYFBR
 
SkinnyG's Avatar
 
Join Date: Sep 2008
Location: Okanagan Valley - Canada, eh?!
Posts: 1,500
Vehicle: 1994 Hardbody
Thanks: 0
Thanked 204 Times in 147 Posts
Default

Quote:
Originally Posted by MurderedOutHardBody View Post
oh but one more thing you will need, that is not listed, u will need the 3rd belt for the crank to the ac compressor and bracket.
Doh. Fixed.
SkinnyG is offline   Reply With Quote
Old 08-26-2010, 03:25 AM   #7
MurderedOutHardBody
MurderedOut Moderator
 
MurderedOutHardBody's Avatar
 
Join Date: Mar 2010
Location: Greenville, North Carolina
Age: 34
Posts: 1,613
Vehicle: 98 sonoma, 2000 bagged durango, 86 bagged toyota
Thanks: 50
Thanked 112 Times in 90 Posts
Default

Quote:
Originally Posted by SkinnyG View Post
Doh. Fixed.
haha, happens to the best of us man, great write up though, gonna be helpful for some folks i think.
__________________
1986 Toyota - bagged, 20s, in progress
2000 Durango - Project, bagged, billet 22s and 24s,
MurderedOutHardBody is offline   Reply With Quote
Old 10-11-2010, 05:56 PM   #8
MurderedOutHardBody
MurderedOut Moderator
 
MurderedOutHardBody's Avatar
 
Join Date: Mar 2010
Location: Greenville, North Carolina
Age: 34
Posts: 1,613
Vehicle: 98 sonoma, 2000 bagged durango, 86 bagged toyota
Thanks: 50
Thanked 112 Times in 90 Posts
Default

hey skinny, ive got everything installed on mine, but because ive been working on other things, i still havent had it vacummed and charged. when i hit the button on the dash, it lights up, but i dont feel a difference in the way the motor runs, i would think u would feel the compressor kick on even though its not charged, how can i check to make sure the compressor and all is getting power??? just use a volt ohm meter on the connection??? its showing some power to the relay under the hood, but i dunno how to check at the compressor, the prongs on my meter wont fit in the connection.
__________________
1986 Toyota - bagged, 20s, in progress
2000 Durango - Project, bagged, billet 22s and 24s,

Last edited by MurderedOutHardBody; 10-11-2010 at 06:17 PM.
MurderedOutHardBody is offline   Reply With Quote
Old 10-11-2010, 06:50 PM   #9
SkinnyG
UYFBR
 
SkinnyG's Avatar
 
Join Date: Sep 2008
Location: Okanagan Valley - Canada, eh?!
Posts: 1,500
Vehicle: 1994 Hardbody
Thanks: 0
Thanked 204 Times in 147 Posts
Default

The Drier to the right of the Condenser has a big switch on the top of it - it will not turn on the Compressor if there is no pressure in the system. I jumped that switch to make sure everything electrically worked.

The ECU also raises the idle speed slightly too - it's all wired to do that already.
SkinnyG is offline   Reply With Quote
Old 10-11-2010, 07:41 PM   #10
MurderedOutHardBody
MurderedOut Moderator
 
MurderedOutHardBody's Avatar
 
Join Date: Mar 2010
Location: Greenville, North Carolina
Age: 34
Posts: 1,613
Vehicle: 98 sonoma, 2000 bagged durango, 86 bagged toyota
Thanks: 50
Thanked 112 Times in 90 Posts
Default

ok so i may not have an issue, its just because i have preassurized yet? u said u jumped yours, how can i do that to make sure everything works before i spend the cash to charge it?
__________________
1986 Toyota - bagged, 20s, in progress
2000 Durango - Project, bagged, billet 22s and 24s,
MurderedOutHardBody is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:12 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.