Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Nissan Cars

Reply
 
Thread Tools Display Modes
Old 10-16-2015, 07:31 PM   #1
tylerr
 
Join Date: Oct 2014
Location: KY
Posts: 4
Vehicle: 95 hardbody 4cyl 4wd manual & 87 hardbody SE V6 4wd manual
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2007 Altima 2.4

2007 Altima 2.4 has about 180,000 on it. All plugs and coil packs have been recently replaced. The car has had a "drop out" in the throttle intermittently for the past few years. Go to pull out and there is no throttle then all of the sudden it throws your head back. The problem has now become worse, but still intermittent. It usually dies the first two times you start it and when it does start it idles rough for 30 seconds or so. The throttle has gotten to the point that it acts up almost every time you pull out. You can hold it to the floor and nothing, then it starts creeping back (has been several times I didn't think it was coming back). At times the throttle doesn't disappear all together, when it is accelerating it will cut in and out making the car lunge forward rather than the smooth acceleration it should have. Scan tool showed the MAP sensor. I replaced it made no difference. My guess is the throttle body is going out.

Thoughts?
tylerr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:43 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.