Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Early Frontier Forum (D22)

Reply
 
Thread Tools Display Modes
Old 02-19-2021, 01:25 PM   #21
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 609
Vehicle: 2004 Frontier
Thanks: 0
Thanked 112 Times in 98 Posts
Default

Still having a stalling issue when idling, drove it down 100 miles today, was perfectly fine until the first red light after 95 miles and then it stalled, would've had no clue there was something wrong. So I dropped the truck at the shop (stalled 2 or 3 times idling on the way there; I swapped MAF sensors with my 1998 Frontier did not affect things at all. '98 still runs fine, 2004 still has stalling while idling.

Before the 100-mile trip yesterday, I did change spark plugs (looked like rich mixture to me, may be a clue), and added a can of Berryman B-12 Chemtool fuel injector cleaner to the gas tank. No change, and one cannot tell that anything is malfunctioning while actually driving. Did get a P0172 service engine code, too much gasoline detected in exhaust.


I should hear something from the shop today, will post. not going to throw parts at it !!!
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Thanked by:
alabama_lowlife (02-19-2021)
Old 02-19-2021, 09:03 PM   #22
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State
Posts: 332
Vehicle: 89' D21 KingCab SE V6 5spd 2WD - 87' D21 KingCab SE V6 5spd 2WD
Thanks: 386
Thanked 89 Times in 76 Posts
Default

Running rich, correct? Not enuf airflow? What air filter RU running? Last changed?

What about resetting the ECU? Is there any (short term) change (good), that maybe reverts back to where it is now?
89'HBV6 is offline   Reply With Quote
Old 02-20-2021, 03:01 PM   #23
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 609
Vehicle: 2004 Frontier
Thanks: 0
Thanked 112 Times in 98 Posts
Default

I did hear from the shop Friday afternoon. They believe that they found a couple of issues, said I could pick up the truck and drive it several days, and bring back on Monday if it still acted up, or I could leave it at the shop and they could drive it more on Monday. The shop owner preferred that I leave the truck there, so I did that.


Going from our phone conversation, he said some wiring issue in the cabin compartment going to the ECU so the EGR circuit wasn't getting electrical power, and I think a rich running condition due to a bad oxygen sender (I never had an O2 sender check engine code). I'll update further next week when I pick up the truck.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Thanked by:
89'HBV6 (02-20-2021)
Old 02-23-2021, 02:53 PM   #24
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 609
Vehicle: 2004 Frontier
Thanks: 0
Thanked 112 Times in 98 Posts
Default

OK, truck runs fine now, so that's good, and I'm happy. Here's the report: There was no electrical power to the EGR sensor; one pin in the ECU connector was bent slightly and not making good contact with the ECU. Also, they replaced a bad oxygen sensor (Denso 234-3113).

I cannot remember if I even TRIED to access the ECU back in Jan. 2014 when I installed the Rostra aftermarket cruise control (I may have tried such on this truck, or maybe on the 1998 Frontier, cannot remember). In any event, "if" that bent pin in the harness was due to ME, that would've been 7 years ago and the stalling just started recently, so being OK for 7 years doesn't sound like it was due to anything I did.

Anyway: finding the harness pin bent is way above my pay grade. Obviously, I am capable of replacing an oxygen sender, but from the Service Engine Codes, I wasn't directed to a bad oxygen sender. So I'm satisfied with what shop did, and I no longer have the P0406 EGR temperature sender and P0462 Low fuel sensor codes.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Thanked by:
89'HBV6 (02-23-2021)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.