Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 01-16-2018, 08:23 PM   #1
knxpnw
 
knxpnw's Avatar
 
Join Date: Jan 2018
Location: Washington
Posts: 2
Vehicle: Nissan D21
Thanks: 0
Thanked 0 Times in 0 Posts
Default Power Loss but still runs?

So I have a 5 speed manual 1990 d21. She starts right off the bat like she should but her idle is not consistent. When driven, there seems to be no power whatsoever; RPM's wont get above 3 grand. Ran the codes from the computer under the seat and it pulled up knock sensor. Replaced it and the problem is still there, now accompanied by a screeching sound. I know for a fact she has a small oil leak and an exhaust leak. Wondering if maybe it could be a head gasket or a valve somewhere. Any thoughts?
knxpnw is offline   Reply With Quote
Old 01-16-2018, 08:28 PM   #2
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 1,843
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 132 Times in 126 Posts
Default

tps out of range

late timing

those are the two id check out of the holster.
street_rulerr is offline   Reply With Quote
Old 01-17-2018, 07:07 PM   #3
knxpnw
 
knxpnw's Avatar
 
Join Date: Jan 2018
Location: Washington
Posts: 2
Vehicle: Nissan D21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm.. Those will be next to check. Thank you
knxpnw is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.