Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 05-26-2018, 02:01 PM   #1
wen2008
 
Join Date: May 2018
Location: GU
Posts: 18
Vehicle: 93 D21
Thanks: 5
Thanked 1 Time in 1 Post
Default No injector pulse but has spark

i have a 93 d21 thats has no injection pulse but has spark would i still have spark if the crank angle sensor is bad?

What ive done so far
Checked spark - good
Check injector pulse - no good
Power to injectors - good
Checked wiring to injector both feed and pulsed ground - good no shorts

thinking its the CAS but just wondering if a bad CAS would still give me spark but no injector pulse.
wen2008 is offline   Reply With Quote
Old 05-26-2018, 02:24 PM   #2
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 4,906
Vehicle: 1986.5 Hardbody
Thanks: 693
Thanked 451 Times in 417 Posts
Default

Have you pulled codes? It could help you narrow in on an issue.



You do have fuel pressure, correct?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is online now   Reply With Quote
Thanked by:
wen2008 (06-03-2018)
Old 05-26-2018, 10:54 PM   #3
johnber
grouchy old man
 
Join Date: Oct 2014
Location: Lynden WA
Age: 60
Posts: 979
Vehicle: 89 4X base
Thanks: 6
Thanked 112 Times in 102 Posts
Default

not sure on the nissan but i do know the gm version you can lose either and it comes back to the distributor.
__________________
89 regular cab, plain as it gets with a z-24 and posi's
johnber is offline   Reply With Quote
Thanked by:
wen2008 (06-03-2018)
Old 05-26-2018, 11:12 PM   #4
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,308
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 293
Thanked 917 Times in 849 Posts
Default

The V6 has a so called crank sensor located inside the distributor. It is a rotor wave plate that sends the signal to the coil. I’m not sure if it disables the injector pulse upon failing. You need to check the ECM for codes and let us know what you find.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Thanked by:
wen2008 (06-03-2018)
Old 05-27-2018, 01:40 PM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,230
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,166
Thanked 1,029 Times in 905 Posts
Default

Like others are implying, if the Crank Angle Sensor is bad, you will have that code in your ECU. There is a link in my signature to a thread that has a nice video on it.

If the injector does not have power, I'd say to check the Fusible Links (link), but since you say they do have power, you would need to check to see if the injectors are in spec (d21_truck_1990.pdf, page EF & EC-317) with 10 - 15 Ω. Bad injectors also throw codes (13 for injector leak, 16 for a bad injector)
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Thanked by:
wen2008 (06-03-2018)
Old 05-28-2018, 07:40 AM   #6
wen2008
 
Join Date: May 2018
Location: GU
Posts: 18
Vehicle: 93 D21
Thanks: 5
Thanked 1 Time in 1 Post
Default

okay story short the crankangle sensor is somewhat good. issue was no gas lol so i guess if no gas the ecu wont pulse the injectors i guess failsafe but i have done a 240sx intake swap and my issue now is that it misfire and runs rich when warm i have regrounded maf and everything tested okay i just dont know how to tune the air screw on the side of manifold and also read up on some forums that it still can be the dizzy due to the pickup or bearing when hot but i consider this thread closed ill make a new thread for my new issue
wen2008 is offline   Reply With Quote
Old 05-28-2018, 07:41 AM   #7
wen2008
 
Join Date: May 2018
Location: GU
Posts: 18
Vehicle: 93 D21
Thanks: 5
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by wen2008 View Post
okay story short the crankangle sensor is somewhat good. issue was no gas lol so i guess if no gas the ecu wont pulse the injectors i guess failsafe but i have done a 240sx intake swap and my issue now is that it misfire and runs rich when warm i have regrounded maf and everything tested okay i just dont know how to tune the air screw on the side of manifold and also read up on some forums that it still can be the dizzy due to the pickup or bearing when hot but i consider this thread closed ill make a new thread for my new issue
i put 2 gallons in before i put the truck down for the swap but i guess that wasnt enough lol
wen2008 is offline   Reply With Quote
Old 06-01-2018, 02:17 PM   #8
wen2008
 
Join Date: May 2018
Location: GU
Posts: 18
Vehicle: 93 D21
Thanks: 5
Thanked 1 Time in 1 Post
Default

okay problem still exist it was just coincidence my truck started when i put gas. my issue if when i spin dizzy(CAS) slowly injectors pulse but fast they dont weird im looking to swap my harness
wen2008 is offline   Reply With Quote
Old 06-01-2018, 02:17 PM   #9
wen2008
 
Join Date: May 2018
Location: GU
Posts: 18
Vehicle: 93 D21
Thanks: 5
Thanked 1 Time in 1 Post
Default

anyone has either d21 harness or 89 90 sohc 240sx harness?
wen2008 is offline   Reply With Quote
Old 06-01-2018, 02:29 PM   #10
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,230
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,166
Thanked 1,029 Times in 905 Posts
Default

Quote:
Originally Posted by wen2008 View Post
anyone has either d21 harness or 89 90 sohc 240sx harness?
The entire engine harness? Those are hard to come by because someone has to strip the vehicle in order to get the whole harness out intact. Then, people do not generally need a full harness, so they are hard to sell.

Your problem is probably not the harness, unless you have had a fire or rats in the engine bay.

Maybe a bad distributor ...or the wrong distributor!
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Thanked by:
wen2008 (06-03-2018)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.