Go Back   Infamous Nissan - Hardbody / Frontier Forums > Infamous Nissan > General Discussion

Reply
 
Thread Tools Display Modes
Old 10-19-2021, 01:09 AM   #1
jazzvecchio
 
Join Date: Oct 2021
Location: Madison, VA
Posts: 4
Vehicle: 1997 Nissan Pickup
Thanks: 0
Thanked 1 Time in 1 Post
Default Aftermarket Stereo & Taillight Fuse

I recently picked up a 97 Nissan extended cab Pickup (for free) and there was no radio installed but the owner threw in a free Aiwa aftermarket stereo. The original stock wiring harness is there under the dash but connected to it were numerous wire, a poor job. So I cut everything, restripped to reveal enough copper and bought a wiring harness adaptor set from local auto parts store. From under the dash, original wiring harness has two sets of white blocks that match up with aftermarket adaptor wiring harness. Wire clusters for the adaptor had two sets of wires: larger cluster has 8 wires and smaller cluster has 5. Stereo came with a harness that plugs into the back of stereo and all colors coordinate with adaptor EXCEPT for black. On the adaptor, there is no black, but an orange. So I connected it. Stereo worked just fine, but taillight fuse (10A) blew.

I removed everything and found a black ground wire under the dash - I assumed to connect orange, black and this new black all together. Stereo doesn't work. Any thoughts on what the right combination is for the mystery orange wire? It appears to control the illumination.
jazzvecchio is offline   Reply With Quote
Old 10-19-2021, 01:21 AM   #2
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,898
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 906
Thanked 1,048 Times in 947 Posts
Default

Orange is probably illumination.



Do you have a copy of the FSM? Should have a wiring diagram in there.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 10-19-2021, 01:37 AM   #3
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 1,171
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 989
Thanked 280 Times in 254 Posts
Default

Orange on the stereo should tie to your lighting switch...
__________________
. . . Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.
89'HBV6 is offline   Reply With Quote
Old 10-19-2021, 10:58 AM   #4
jazzvecchio
 
Join Date: Oct 2021
Location: Madison, VA
Posts: 4
Vehicle: 1997 Nissan Pickup
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Deerhurst View Post
Orange is probably illumination.



Do you have a copy of the FSM? Should have a wiring diagram in there.
No I don't. But I did find one on nicoclub website. Studying the diagram doesn't do me any good since it doesn't list color codes.

I haven't yet tried black wire from the original harness to black ground and leave orange unconnected. Will let you know what happens.
jazzvecchio is offline   Reply With Quote
Old 10-19-2021, 10:58 AM   #5
jazzvecchio
 
Join Date: Oct 2021
Location: Madison, VA
Posts: 4
Vehicle: 1997 Nissan Pickup
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by 89'HBV6 View Post
Orange on the stereo should tie to your lighting switch...
And which one would that be?
jazzvecchio is offline   Reply With Quote
Old 10-19-2021, 12:20 PM   #6
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,898
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 906
Thanked 1,048 Times in 947 Posts
Default

JP2code and SiFi have a link to the FSM in their signature. It's worth it and free.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 10-19-2021, 01:10 PM   #7
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,618
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,045
Thanked 2,167 Times in 1,780 Posts
Default

Pink/blue is the factory wire for illumination.

The factory radio doesn’t use a dedicated ground wire. It grounds through the radio chassis and the antenna. Just take the black wire from the aftermarket radio harness and connect it to a metal ground.
__________________
alabama_lowlife is offline   Reply With Quote
Old 10-19-2021, 01:35 PM   #8
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 731
Vehicle: 2004 Frontier
Thanks: 0
Thanked 134 Times in 117 Posts
Default

Quote:
Originally Posted by alabama_lowlife View Post
Pink/blue is the factory wire for illumination.

The factory radio doesnít use a dedicated ground wire. It grounds through the radio chassis and the antenna. Just take the black wire from the aftermarket radio harness and connect it to a metal ground.

Modern stereos do NOT connect to the illumination wire, they have built-in LEDs.
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Old 10-19-2021, 02:47 PM   #9
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 42
Posts: 10,618
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 1,045
Thanked 2,167 Times in 1,780 Posts
Default

Quote:
Originally Posted by Cusser View Post
Modern stereos do NOT connect to the illumination wire, they have built-in LEDs.
This is incorrect. They connect to the illumination wire. Iíve used some really dirt cheap head units that did not have an illumination connection. But the ones Iíve used that were quality radios use the illumination wire. They donít need the 12vdc as a source to power the illumination, but itís an indication to the radio that the headlights/parking lights are turned on in the vehicle. This causes the radio to dim the illumination on the buttons and screen because they donít need to be as bright because itís dark.
__________________
alabama_lowlife is offline   Reply With Quote
Old 10-19-2021, 04:54 PM   #10
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 7,898
Vehicle: 1986.5 SE-V6 4WD D21, 2003 Audi A4 Avant 3.0 Quattro
Thanks: 906
Thanked 1,048 Times in 947 Posts
Default

The Sony in my D21 dims with the illumination wire signal just like bama said.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.