Go Back   Infamous Nissan - Hardbody / Frontier Forums > Site Info > FAQs and General Info

Reply
 
Thread Tools Display Modes
Old 12-10-2022, 05:09 PM   #1
danmandan
 
danmandan's Avatar
 
Join Date: Dec 2022
Location: south carolina
Posts: 20
Vehicle: 1991 nissan pickup D21
Thanks: 17
Thanked 8 Times in 5 Posts
Default electrical problem

Hi ,,I have a 91 hardbody 4X4 ,, turn headlights on they work shut them off they shut off ,, turn on again nothing , they work then they dont ,, blinkers work normally but the side markers do the same thing,, work then not ,, I have never seen anything like this ,, anyone have any ideas? Thanks Dan
danmandan is offline   Reply With Quote
Old 12-10-2022, 06:27 PM   #2
89'HBV6
Ol'school Geek
 
89'HBV6's Avatar
 
Join Date: Mar 2020
Location: Washington State / the Left Coast
Posts: 2,051
Vehicle: 89' D21 KC SE V6 5spd 2WD - 87' D21 KC SE V6 5spd 2WD
Thanks: 1,600
Thanked 462 Times in 424 Posts
Default

Welcome Dan...

I suspect your signal stalk could be failing. They are still available. Might search the site and do a bit of reading... GL

__________________
. . . Factory Service Manuals: https://www.nicoclub.com/nissan-service-manuals
Quote:
Originally Posted by Deerhurst
What he is saying is the aerodynamics of a D21 is a brick in the wind.
Probably at least as bad as a Jeep so worse than a cow.

-"No electrons were harmed during the creation, transmission or reading of this posting.
However, many were excited and some may have enjoyed the experience."
89'HBV6 is offline   Reply With Quote
Thanked by:
danmandan (12-11-2022)
Old 12-10-2022, 09:36 PM   #3
USCGamecocks20
 
Join Date: Jul 2022
Location: South Carolina
Posts: 982
Vehicle: 1993 Nissan D21 (KA24E) 2WD automatic King Cab
Thanks: 180
Thanked 200 Times in 175 Posts
Default

My only somewhat similar issue with my headlights was only one came on, and when I turned on the brights it would go out and the other one would come on (“switching” headlights issue).

Replacing the headlight switch/stalk (like $23 on Amazon) fixed the issue for me. It may be something more complex on the circuit happening, but it could just be that stalk.

Takes like 5-10 min to change it out….just a handful of screws.
USCGamecocks20 is offline   Reply With Quote
Old 12-10-2022, 09:44 PM   #4
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 3,232
Vehicle: 1994 Pathfinder XE
Thanks: 354
Thanked 649 Times in 569 Posts
Default

It's probably the switch. Usually you can (carefully) take them apart, sand all the terminals clean and put it back together to make it work again. I'd try that before spending any money.
__________________
SBJ is offline   Reply With Quote
Thanked by:
danmandan (12-11-2022)
Old 12-11-2022, 02:23 PM   #5
danmandan
 
danmandan's Avatar
 
Join Date: Dec 2022
Location: south carolina
Posts: 20
Vehicle: 1991 nissan pickup D21
Thanks: 17
Thanked 8 Times in 5 Posts
Default

Quote:
Originally Posted by 89'HBV6 View Post
Welcome Dan...

I suspect your signal stalk could be failing. They are still available. Might search the site and do a bit of reading... GL
Thanks for the comeback ,,I started to back and forth the headlight switch over and over to knock the corrosion out of it "so to speak" .Now before I did that the side marker lights would come on sometimes then not and after wiggling the switch arm about they seem to work the way they should , but now only the right headlight works but its intermittent,the switch looks to be easy to swap out so I'm going to try that ,,Thank you sir
danmandan is offline   Reply With Quote
Old 12-11-2022, 02:34 PM   #6
danmandan
 
danmandan's Avatar
 
Join Date: Dec 2022
Location: south carolina
Posts: 20
Vehicle: 1991 nissan pickup D21
Thanks: 17
Thanked 8 Times in 5 Posts
Default

Quote:
Originally Posted by USCGamecocks20 View Post
My only somewhat similar issue with my headlights was only one came on, and when I turned on the brights it would go out and the other one would come on (“switching” headlights issue).

Replacing the headlight switch/stalk (like $23 on Amazon) fixed the issue for me. It may be something more complex on the circuit happening, but it could just be that stalk.

Takes like 5-10 min to change it out….just a handful of screws.
Hi,, After fiddling with it last night mine is doing the same thing now . I am going to order a new headlight/signal switch today Thanks for the help
danmandan is offline   Reply With Quote
Old 12-11-2022, 06:08 PM   #7
danmandan
 
danmandan's Avatar
 
Join Date: Dec 2022
Location: south carolina
Posts: 20
Vehicle: 1991 nissan pickup D21
Thanks: 17
Thanked 8 Times in 5 Posts
Default

Quote:
Originally Posted by SBJ View Post
It's probably the switch. Usually you can (carefully) take them apart, sand all the terminals clean and put it back together to make it work again. I'd try that before spending any money.
Hi,, Thanks for the info and did what you said ,, I took the switch apart and sanded the contacts down some and it works ,, all but the drivers headlight on hi beam,, the contact there looked overheated to me and cant get that one to work unless I push hard down on the contact and Im afraid if I bend it down more my luck the light will come on all by itself and cash the battery so going play it safe and just install a new one , you were right it was easy to remove and interesting to see how it works inside ,, Thx again Dan
danmandan is offline   Reply With Quote
Thanked by:
USCGamecocks20 (12-12-2022)
Old 12-11-2022, 10:14 PM   #8
danmandan
 
danmandan's Avatar
 
Join Date: Dec 2022
Location: south carolina
Posts: 20
Vehicle: 1991 nissan pickup D21
Thanks: 17
Thanked 8 Times in 5 Posts
Default

Hi again , I just replaced the headlight/turnsignal switch and everything works again like it should ,, the previous owner had ran 3 wires from the right side headlight plug that worked to power the left side headlights that didn't,, I guess thats why the contacts on the powered side of the headlite switch were so dark and corroded ,,,,I guess from the extra strain of powering both,,AnywayI removed the jumper wires and they work normally now so thanks for all the help
danmandan is offline   Reply With Quote
Thanked by:
89'HBV6 (12-11-2022), USCGamecocks20 (12-12-2022)
Old 12-12-2022, 02:22 AM   #9
USCGamecocks20
 
Join Date: Jul 2022
Location: South Carolina
Posts: 982
Vehicle: 1993 Nissan D21 (KA24E) 2WD automatic King Cab
Thanks: 180
Thanked 200 Times in 175 Posts
Default

Thanks for the updates. Always good to know what solved a problem.
USCGamecocks20 is offline   Reply With Quote
Thanked by:
danmandan (01-07-2023)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:19 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.