Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 03-17-2018, 06:40 PM   #11
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 1,592
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 170
Thanked 186 Times in 169 Posts
Default

4cyl is the same, inside the distributor.
SBJ is offline   Reply With Quote
Old 03-17-2018, 06:46 PM   #12
jeremyd21
 
Join Date: Mar 2018
Location: Gatlinburg TN
Posts: 96
Vehicle: 1989 d21 pickup
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Success.. It was a vacuum leak, when the engine is running erratically the timing marks are every ware. Thought this whole time I had the air cleaner assy off, it would cause the engine to stall while coasting. So I replaced the air cleaner and hooked a vacuum line to it, and that was it the engine runs fine now.

Last edited by jeremyd21; 03-17-2018 at 11:10 PM.
jeremyd21 is offline   Reply With Quote
Old 03-18-2018, 10:02 AM   #13
jeremyd21
 
Join Date: Mar 2018
Location: Gatlinburg TN
Posts: 96
Vehicle: 1989 d21 pickup
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Ive got good drivability and the truck runs fine. Now I have a rising and falling when at idle. The engine is not stalling but will flutter abit at idle.

Here's my plan now-

1-Replace PCV valve

2-Replace the TPS sensor and adjust it

3-I got the ignition timing set and the engine pulls strong under acceleration.
jeremyd21 is offline   Reply With Quote
Old 03-18-2018, 10:54 AM   #14
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 39
Posts: 8,879
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 567
Thanked 1,556 Times in 1,270 Posts
Default

Sounds like you still have a vacuum leak somewhere.
__________________
alabama_lowlife is online now   Reply With Quote
Old 03-18-2018, 11:29 PM   #15
jeremyd21
 
Join Date: Mar 2018
Location: Gatlinburg TN
Posts: 96
Vehicle: 1989 d21 pickup
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I have vacuum tube coming from the bottom of the throttle body now its unplugged. Im either going to cap it or figure where it goes.

Also I have a nasty back fire when decelerating in gear (manual transmission)

Last edited by jeremyd21; 03-18-2018 at 11:38 PM.
jeremyd21 is offline   Reply With Quote
Old 03-19-2018, 03:11 PM   #16
jeremyd21
 
Join Date: Mar 2018
Location: Gatlinburg TN
Posts: 96
Vehicle: 1989 d21 pickup
Thanks: 0
Thanked 2 Times in 2 Posts
Default

So I put the timing light on it and checked the timing marks all good, amazing a vacuum leak caused that. Don't take the air cleaner assy off this is whare my major leak was coming from, also caused the engine die while coasting.

I sill have a small leak that I will nail down.

My goal at this point is to get the EGR working so if I will say this topic has been solved. Thank you
jeremyd21 is offline   Reply With Quote
Old 03-19-2018, 04:38 PM   #17
91nissan94
 
91nissan94's Avatar
 
Join Date: Sep 2008
Location: Crescent City FL
Posts: 1,390
Vehicle: 91nissan hb
Thanks: 63
Thanked 137 Times in 125 Posts
Default

Vacuum leaks cause all kinds of hell with these trucks. A can of starting fluid is handy to have laying around.
91nissan94 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.