Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 11-11-2012, 08:13 PM   #1
louielace69
 
louielace69's Avatar
 
Join Date: Dec 2009
Location: Mount Holly,NJ
Posts: 130
Vehicle: 1986.5 Nissan Hardbody D-21 2.4L
Thanks: 1
Thanked 2 Times in 2 Posts
Default Headlights/Brakelights/Turn Signals/Heater???

All of the above will not work on my 86.5 2.4 Hardbody???
Anyone else have these problems???
Fuses are good,IDK about the relays though???
Are they the 3 blue ones just above the fuses under the driver side dash???
Please help,truck starts fine but it's time to get it to my friends garage & I don't want him to follow me then hit me in the back because the tails are out.
Thanks Dudes!!!
louielace69 is offline   Reply With Quote
Old 11-11-2012, 08:23 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 39
Posts: 8,808
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 542
Thanked 1,523 Times in 1,253 Posts
Default

Look at the fusible links at the battery. They look like pieces of wire about 4 inches long. See if one looks cooked.
__________________
alabama_lowlife is offline   Reply With Quote
Old 11-23-2012, 08:51 PM   #3
louielace69
 
louielace69's Avatar
 
Join Date: Dec 2009
Location: Mount Holly,NJ
Posts: 130
Vehicle: 1986.5 Nissan Hardbody D-21 2.4L
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Those links have been gone for a while.I replaced the battery cables in the mid 90's.My alt is bad so I'm gonna replace that hopefully tomorrow since I have a warantee on it.maybe thats why nothing is working.All the fuses are good
louielace69 is offline   Reply With Quote
Old 12-03-2012, 07:48 PM   #4
louielace69
 
louielace69's Avatar
 
Join Date: Dec 2009
Location: Mount Holly,NJ
Posts: 130
Vehicle: 1986.5 Nissan Hardbody D-21 2.4L
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Someone mentioned a dead cell in the battery,could that be true?
louielace69 is offline   Reply With Quote
Old 12-03-2012, 08:32 PM   #5
david29
Administrator
 
Join Date: Sep 2008
Location: Spring(Houston), Texas
Age: 48
Posts: 5,850
Vehicle: 1987 Nissan King Cab
Thanks: 28
Thanked 423 Times in 389 Posts
Default

It could be the actual headlight turn signal/switch that is bad.
__________________
My stable of Nissan trucks includes:
1987 Nissan King Cab(full frame off Restoration).
david29 is offline   Reply With Quote
Old 12-04-2012, 04:15 PM   #6
louielace69
 
louielace69's Avatar
 
Join Date: Dec 2009
Location: Mount Holly,NJ
Posts: 130
Vehicle: 1986.5 Nissan Hardbody D-21 2.4L
Thanks: 1
Thanked 2 Times in 2 Posts
Default

I've got no brake lights either David?
My heater fuses were loose & a few of them blew out or started to melt & not blow.
My wipers have been acting up moving really slowly also?
I'm supposed to get it to my Boy's place so we can work on it during the winter while we work on his Ford Ranger also.
I can finally get some things done on it but just got this drawback.
Sucks Dudes!!!
louielace69 is offline   Reply With Quote
Old 12-04-2012, 05:39 PM   #7
david29
Administrator
 
Join Date: Sep 2008
Location: Spring(Houston), Texas
Age: 48
Posts: 5,850
Vehicle: 1987 Nissan King Cab
Thanks: 28
Thanked 423 Times in 389 Posts
Default

Sounds to me like you have the wiring gremlins going to town there.
I hate trying diagnose wiring issues.
__________________
My stable of Nissan trucks includes:
1987 Nissan King Cab(full frame off Restoration).
david29 is offline   Reply With Quote
Old 12-06-2012, 03:46 PM   #8
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 39
Posts: 8,808
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 542
Thanked 1,523 Times in 1,253 Posts
Default

Well, you've got so many different problems its difficult to pick one to start working on. And even that is compounded by the fact that some of your wiring is not factory.

Easiest one to start on is the brake lights. Read this thread and check the same things I told him to check. http://www.infamousnissan.com/forum/...ad.php?t=24385

Whatever you find post in THIS thread, not that one. We may have to work through them one at a time. But if you'll check what I tell you to check, we'll get it fixed.
__________________
alabama_lowlife is offline   Reply With Quote
Old 12-06-2012, 08:21 PM   #9
louielace69
 
louielace69's Avatar
 
Join Date: Dec 2009
Location: Mount Holly,NJ
Posts: 130
Vehicle: 1986.5 Nissan Hardbody D-21 2.4L
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Thanks Dudes,I will deff check out that link
I wanna take out my dash since I may tweed or glass it anyways
Darn wiring gremlins!!!
louielace69 is offline   Reply With Quote
Old 04-24-2013, 03:49 AM   #10
MrBoomPow
 
MrBoomPow's Avatar
 
Join Date: Apr 2013
Location: Woodbury
Age: 24
Posts: 22
Vehicle: 1990 Nissan Hardbody
Thanks: 4
Thanked 0 Times in 0 Posts
Default

yeah i have the same problem sorta. i have a 1990 hardbody and i bought it cheap and it has a flat bed and it came with no taillights so i bought some trailer lights jus so i can have brake lights and taillights but i have taillights but none of the wire will make the brake lights work. i got brand new fuses. ive tryed all the wires under the rear of the truck but only can get taillights. no brake lights, blinkers or anything . any idea??
MrBoomPow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:26 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.