Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 04-02-2015, 11:32 PM   #1
86NissanV6
'86 Hardbody SE V6 4x4
 
86NissanV6's Avatar
 
Join Date: Apr 2014
Location: Arizona
Posts: 477
Vehicle: 1986.5 Hardbody 4X4 SE-V6 King Cab
Thanks: 20
Thanked 25 Times in 21 Posts
Default Rough Idling/Sputtering While Cold

Let's get straight down to it. On the TBi models of the VG30, which are 1986 to 1989, sometimes they act like they sprained their ankle and don't wanna run while it's cold. However, they run fine when warm with a little sputter here and there.

Give the poor truck some slack. It's probably 30 years old (Like mine will be in December this year), and it's probably NEVER had the wax idle solenoid repacked or replaced. I KNEW I had a bad solenoid, but I chose to just let it be.

Therefore, I don't know how to replace it, but I can tell you that if NOTHING is working for you, and you're sure you have the fast idle screw, timing, an everything else where it's supposed to be, then go buy yourself a wax repacking kit, or a new solenoid. Chances are, that'll be all you need to fix that.

Symptoms are:
Sputtering on takeoff if you haven't let it warm up and idle a while.
Rough idle while cold.
Hard starting while cold.
Some sputtering while warm.
High idle. (Around 1k when warm.)
__________________

'86.5 Nissan D21 SE-V6 4x4 Ext Cab
FS5R30A trans / HG43 axle / VG30i
86NissanV6 is offline   Reply With Quote
Thanked by:
dopedc (01-16-2017), jp2code (04-03-2015)
Old 04-14-2016, 11:53 PM   #2
Drake
 
Join Date: Feb 2015
Location: Washington state
Posts: 20
Vehicle: D21 4x4 86.5 V6 SE Hardbody
Thanks: 5
Thanked 5 Times in 5 Posts
Default

Thank you for the advice on the FIS.
I started having a cold rough idle a few days ago that appeared to come out of no were. Do you think this may be my issue?
Drake is offline   Reply With Quote
Thanked by:
Hiloha (09-13-2016)
Old 01-27-2017, 11:54 PM   #3
slo87
 
Join Date: Mar 2016
Location: Carrollton al
Posts: 71
Vehicle: 6/86 d21 Z24I 4X4 King cab
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Would this apply to a 86.5 D21 w Z24i with almost identical symptoms except mine starts great
slo87 is offline   Reply With Quote
Old 05-10-2017, 05:44 AM   #4
Chekonight.13
 
Chekonight.13's Avatar
 
Join Date: Apr 2017
Location: Rialto,California
Posts: 10
Vehicle: 86' hardbody 3.0
Thanks: 2
Thanked 1 Time in 1 Post
Default

What is a wax repacking kit?
Chekonight.13 is offline   Reply With Quote
Thanked by:
rockytop (05-12-2017)
Old 12-20-2017, 12:05 AM   #5
ke4mcl
rat truck owner
 
Join Date: Jul 2016
Location: homestead, fl
Posts: 68
Vehicle: 1987 Nissan d21
Thanks: 0
Thanked 10 Times in 4 Posts
Default

can we get more info on what this repair is?
ke4mcl is offline   Reply With Quote
Old 12-20-2017, 12:39 AM   #6
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,758
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 315
Thanked 967 Times in 896 Posts
Default

info on the wax solenoid including the part number (still available from nissan) is at http://www.infamousnissan.com/forum/...t=wax+solenoid
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 03-24-2018, 01:50 PM   #7
Raceing
 
Join Date: Mar 2018
Location: Nevada
Posts: 1
Vehicle: 1989 d21 44 pickup
Thanks: 1
Thanked 0 Times in 0 Posts
Angry 89 d21 44 pickup

Hello, I've had a problem with my truck not wanting to go past 2600rpm's it spits and spuudders and loses power till I bring it down , I've changed the map sensor, tps, put a junkyard distributor in , cleaned the throttle body and still same thing the last thing to change is the crank positioning sensor but I look on YouTube for info on it and that's not what my motor has it shows me two spots possible and or the
Raceing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:29 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.