Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Nissan Cars

Reply
 
Thread Tools Display Modes
Old 05-23-2014, 07:51 PM   #1
Mr Dick
 
Join Date: Oct 2009
Location: Neosho Mo
Posts: 12
Vehicle: 97 Nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default 300zx questions and problems

I have a 90 300zx na turbo. I got this off my stepmom. the car was her friends before she got it. the car sat in he friends front yard for 5/6 years with out being moved or being started. then when my stepmom got it she drove it couple of times over the last 3 years. it ran fine and had no problems. they went in had a tune up done on it at one of there friends house. now the car starts and runs like shit it will drive but it has no power and u can only get it up to 60mph on flat land, it will lose speed going up a hill. plugs ,wires and oil is the only thing they changed, I was thinking the wires where crossed. what do u guys think.
Mr Dick is offline   Reply With Quote
Old 05-23-2014, 10:18 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 38
Posts: 8,620
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 481
Thanked 1,470 Times in 1,206 Posts
Default

Check the injectors and coil packs one by one. Unplug each one to see if the car runs worse with it disconnected. If it runs worse, that injector or coil pack is good. If it makes no difference, that cylinder isn't firing. Swap coil packs to isolate or eliminate a coil pack. If those are good it could be the injector. I have had to replace a couple coil packs and injectors on my wife's 93 300zx convertible.
alabama_lowlife is online now   Reply With Quote
Old 05-23-2014, 11:41 PM   #3
Mr Dick
 
Join Date: Oct 2009
Location: Neosho Mo
Posts: 12
Vehicle: 97 Nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks will do.
Mr Dick is offline   Reply With Quote
Old 07-11-2014, 01:40 AM   #4
95_NISMO_HB
Big kids have better toys
 
95_NISMO_HB's Avatar
 
Join Date: Jan 2009
Location: Abilene, Texas
Posts: 336
Vehicle: 1995 Nissan Hardbody Pickup
Thanks: 5
Thanked 11 Times in 11 Posts
Default

Easy check on the injectors is get a long shanked screwdriver and hold it to the injectors and put the handle near your ear. You should hear a pretty loud TICK if its firing off. Good luck!
95_NISMO_HB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.