Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 02-14-2018, 08:01 PM   #1
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,800
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 317
Thanked 975 Times in 902 Posts
Default Temp, fuel sub and main and temp gauges stuck

So in the way home today, I look down to see my temp gauge pegged. I stopped and checked everything and it was normal. Then I see the fuel gauge was higher than this morning and my oil pressure gauge was showing 120 psi. All three gauges are stuck at the same location. All three are pointing to what equals 3/4 a tank of fuel. The volt meter works, its on 14 volts. I had the alternator tested and it passed and it is charging at 14 volts.

And those three gauges show the same readings with the engine off, key on. When the key is turned off, all the gauges return to the resting location. I checked all my fuses and the engine fuel cut was blown, so I changed it and nothing changed. I also swapped two relays under the hood and nothing changed.

Im thinking it is a ground wire. Anyone have any thoughts? It is gonna stay parked until this weekend to be safe.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 02-14-2018, 08:15 PM   #2
YEPEE
 
Join Date: Mar 2013
Location: Phoenix
Posts: 1,604
Vehicle: 86.5 HB, 02 Sentra Spec-V
Thanks: 165
Thanked 237 Times in 206 Posts
Default

there is a voltage regulator on the back of the speedo cluster, little box, could be black or silver
YEPEE is offline   Reply With Quote
Thanked by:
cadillacdude1975 (02-14-2018)
Old 02-14-2018, 09:25 PM   #3
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 5,277
Vehicle: 1986.5 Hardbody
Thanks: 718
Thanked 498 Times in 460 Posts
Default

I'm going to say dash too just because of the oil pressure. Probably worth looking at the voltage regulator for kicks. I'm not sure how the gauges work but I'd be tempted to try to read the signal to them and then try to reproduce it and modify it to see what happens.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Thanked by:
cadillacdude1975 (02-14-2018)
Old 02-14-2018, 09:43 PM   #4
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,800
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 317
Thanked 975 Times in 902 Posts
Default

Guess I’m lucky I have three spare clusters. I know what I will be doing this weekend.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 02-15-2018, 11:11 AM   #5
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 49
Posts: 8,887
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,291
Thanked 1,106 Times in 976 Posts
Default

Don't forget about this guy's post:

http://928intl.com/tips/Instrument%2...epair%20II.htm

While you have your cluster out, back the screws off of the "plastic laminated circuit board" (is there a name for that?), clean all the contacts up, and snug the screws back down. Just don't crank down when you put the screws back in.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Thanked by:
cadillacdude1975 (02-15-2018)
Old 02-15-2018, 08:51 PM   #6
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,800
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 317
Thanked 975 Times in 902 Posts
Default

I replaced that regulator thing with one from a spare cluster. The fuel and temp gauges are normal again. I sanded some of the contacts and replaced two burnt out bulbs. I wonder if that el cheap i oil pressure sender took a shit? I will unplug it this weekend and see if the gauge falls back to zero. It reads correct when cold and correct when hot, but it still shows the previous pressure reading with the key on engine off.
Attached Images
File Type: jpg image.jpg (93.8 KB, 8 views)
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 02-15-2018, 08:52 PM   #7
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,800
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 317
Thanked 975 Times in 902 Posts
Default

Pic with engine running.
Attached Images
File Type: jpg image.jpg (90.6 KB, 9 views)
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:36 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.