Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 02-19-2018, 04:48 AM   #1
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 546
Vehicle: 1990 Nissan hardbody 2wd, 1993 nissan hardbody 4wd
Thanks: 20
Thanked 42 Times in 33 Posts
Default Minor 4x4 issues

Ok guys I just got this truck and you all know lol. Iím having an issue with the 4x4 light not going off. I put it in 2h and it wonít turn off. I also noticed the bright light indicator doesnít come on when the brights are on. I disconnected the battery in hopes of solving both problems but still there. I also need to know how to unfreeze the front hubs because there frozen on unlocked.
__________________
the red sprocket
and the red bone

brandonodom18 is offline   Reply With Quote
Old 02-19-2018, 08:53 AM   #2
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,680
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 316
Thanked 956 Times in 885 Posts
Default

The bright indicator is probably a blown bulb in the cluster.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 02-19-2018, 12:17 PM   #3
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 546
Vehicle: 1990 Nissan hardbody 2wd, 1993 nissan hardbody 4wd
Thanks: 20
Thanked 42 Times in 33 Posts
Default

Quote:
Originally Posted by cadillacdude1975 View Post
The bright indicator is probably a blown bulb in the cluster.
ok i will check that out when i get homeand the front differential is not turning when truck is in gear and moving. we jacked it up and tested it. and when its off and in gear i can turn the front differential drive shaft.
__________________
the red sprocket
and the red bone

brandonodom18 is offline   Reply With Quote
Old 02-19-2018, 12:35 PM   #4
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 5,156
Vehicle: 1986.5 Hardbody
Thanks: 708
Thanked 481 Times in 444 Posts
Default

Is the driveshaft to the front turning?

V6 or 4cyl? Manual or automatic hubs?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
VG33i
Deerhurst is offline   Reply With Quote
Old 02-19-2018, 12:41 PM   #5
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 546
Vehicle: 1990 Nissan hardbody 2wd, 1993 nissan hardbody 4wd
Thanks: 20
Thanked 42 Times in 33 Posts
Default

it is not turning when in 2 high but it does in 4 low or high but the light still stays on and it is a 4cyl and it has manual hubs
__________________
the red sprocket
and the red bone

brandonodom18 is offline   Reply With Quote
Old 02-19-2018, 02:40 PM   #6
Reserector
the Flaming Marshmallow
 
Reserector's Avatar
 
Join Date: Oct 2015
Location: Laurel, MS
Posts: 1,390
Vehicle: Nissan HB KC 4x4
Thanks: 10
Thanked 310 Times in 251 Posts
Default

The harness that plugs into the two switches on the transfer case may be plugged up wrong, causing the light to stay on. Either that, or it has a short to ground somewhere.

Manual or automatic hubs?
Reserector is offline   Reply With Quote
Old 02-19-2018, 04:13 PM   #7
street_rulerr
 
Join Date: Nov 2015
Location: West Coast
Posts: 1,843
Vehicle: 1996 4x4 5spd
Thanks: 0
Thanked 132 Times in 126 Posts
Default

frozen hubs that are frozen unlocked? as in you cant turn the switch?

the outside of the hub can be removed with the wheel on. pull the 6 or 8 cap screw bolts and take off the cover. then, wrench the fuck out of the switch. it just turns and pushes something "inboard" to lock the hubs.

clean the inside of the hub cover, grease it LIGHTLY DO NOT PACK IT. These need space inside to release the 4wd system.

then reassemble. consider a light coat of RTV on the lip to keep a little moisture out.
street_rulerr is offline   Reply With Quote
Old 02-19-2018, 04:53 PM   #8
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 546
Vehicle: 1990 Nissan hardbody 2wd, 1993 nissan hardbody 4wd
Thanks: 20
Thanked 42 Times in 33 Posts
Default

Can do and I think it’s grounding out because it was off when we first cranked it up and I engaged the 4x4 and it didn’t go off
__________________
the red sprocket
and the red bone

brandonodom18 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:42 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.