Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 06-26-2018, 05:29 PM   #1
Asbill71
 
Join Date: Jun 2018
Location: West texas
Posts: 2
Vehicle: 1996 Nissan Pickup
Thanks: 0
Thanked 0 Times in 0 Posts
Default 1996 D21 electrical issue

My Brother was changing a radiator hose on his 1996 Nissan pickup he said antifreeze got on the alternator and it made a sizzling noise and small arc. Once done with the hoses the truck starts and runs fine. Headlights work. But it has no parking lights, horn, A/C, door chime. Any ideas what to check first? Im sure something fried. Any advice or wisdom is appreciated.
Asbill71 is offline   Reply With Quote
Old 06-26-2018, 05:30 PM   #2
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 46
Posts: 8,584
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 308
Thanked 945 Times in 876 Posts
Default

check the fuse links at the battery. id bet one of them is blown.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 06-27-2018, 01:01 AM   #3
Asbill71
 
Join Date: Jun 2018
Location: West texas
Posts: 2
Vehicle: 1996 Nissan Pickup
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. That was it. The fusible link with two wires has one wire blown. Appreciate the help
Asbill71 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:34 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.