Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 06-27-2018, 11:52 PM   #11
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 1,637
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 173
Thanked 193 Times in 176 Posts
Default

Kind of like the rails that Ford uses? Those are a pain to get the injectors out of. I bet the injector seals are the same for both rail types. Patience is it best way to get them out.
SBJ is offline   Reply With Quote
Old 06-29-2018, 12:19 AM   #12
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 355
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 31 Times in 28 Posts
Default

I try not to touch Fords. :-)

Seals went in well this a.m. It's interesting, at least for this rail version, that the injector's washer just mates (touches) the intake manifold's seal with nothing aligning them (e.g., something from the injector down through both. So it is very easy for an injector to not have its jet aligned into its port. Care's needed to get them right before final-tightening the rail's two mounting bolts.

Anyway -- they are in. Small, but not big improvement. :-(

Reading elsewhere, I decided to try something that previous I'd never even consider trying -- pulling the spark plug wires, one-by-one, while the engine is running! Egads!

Wore heavy leather gloves, and had a blanket between my body and the truck to prevent grounding-out. And ... #1 cylinder is weak (little effect on idle quality, unlike #2, 3, and 4).

With the compression test saying that cylinder #1 is fine, I'm guessing injector. But will likely swap in a different spark plug wire to eliminate that (spark sounded strong, though), and maybe check the distributor cap and rotor (almost new, in terms of miles). Then I'll try one of the old but still good injectors that I saved. If none of those fix it, I guess the injector wiring is the only thing left? I doubt the cam is wiped.
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Old 06-29-2018, 11:25 AM   #13
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 49
Posts: 8,760
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,266
Thanked 1,091 Times in 962 Posts
Default

What was the verdict on swapping spark plug cables?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 06-29-2018, 12:00 PM   #14
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 355
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 31 Times in 28 Posts
Default

I likely can't get to it again for a while. Have to work outside in 100+ F!
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Thanked by:
jp2code (06-29-2018)
Old 07-05-2018, 09:58 PM   #15
LugNut1990
 
LugNut1990's Avatar
 
Join Date: Jul 2015
Location: N.E. Kansas
Posts: 355
Vehicle: 1990 Nissan Hardbody
Thanks: 0
Thanked 31 Times in 28 Posts
Default

It's dead, Jim.

A five year old injector, that is. Was a "T type" (only one year warranty), via RockAuto, and only five years old and maybe 5000 miles.

Oddly, I had no old spark plug wires around. So went for the fuel injector instead, since I'm getting good at 'em. :-{

Put in one of my 1990 known good OE injectors that I had cleaned five years ago, and still had on the shelf. Runs great now.

Maybe I'll spring (again) for a new set of injectors in the future.
__________________
Original owner
1990 Nissan Hardbody, Aztec Red
Standard cab, 4x4, KA24E, 5-speed
Intentionally near-stock
Mods: Second OEM horn, stereo/speakers/sub,
mud and snow tires, HD trailer hitch (cat 3+),
liquid bed liner, G1W dashcam
Definitely not for sale!
LugNut1990 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.