Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Early Frontier Forum (D22)

Reply
 
Thread Tools Display Modes
Old 09-09-2020, 06:56 PM   #1
97ta2
 
Join Date: Sep 2012
Location: Central Florida
Posts: 2
Vehicle: 97 nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default 01 frontier crank no start after hitting a bump

So I’ve been searching all over the forum and can’t seem to find a fix. I was driving home from work doing 70mph and because of road construction on I4 in Orlando the road is garbage! My trucks lowered and sitting on the bumps tops so it’s rides like crap in the front, I hit a decent bump then about 30-40 seconds later the truck died and acts like it’s out of gas. I’m getting spark, and it’s getting fuel up the regulator. It cranks over and starts sometimes but once it does it start missing really bad then dies after about 20 seconds. I can’t figure it out. Thanks in advance to anyone who replies. I should also add that for a few weeks before this the truck would stall out when braking hard but it would alway start right up. It’s also a 4cyl automatic.

Last edited by 97ta2; 09-09-2020 at 07:19 PM.
97ta2 is offline   Reply With Quote
Old 09-10-2020, 02:40 PM   #2
SVTCTR
 
Join Date: Mar 2020
Location: Chesapeake, VA
Posts: 244
Vehicle: 1997 Nissan Pickup KA24DE
Thanks: 10
Thanked 29 Times in 27 Posts
Default

id start looking at all the wires hooked to the engine. i have the same motor KA24DE you have but in a HB and there isnt alot to it really. also check and makesure you didnt loose a vacuum line. with you sitting on bump stops (i did for about a day then took them out) it could be a number of things that caused the problem. you just jarred the crap out of it and something had to of come loose.
__________________
Brian
1997 Nissan HB KA24DE swap
2014 Ford Flex
2019 Ford F-250

SVTCTR is offline   Reply With Quote
Old 09-12-2020, 03:54 PM   #3
97ta2
 
Join Date: Sep 2012
Location: Central Florida
Posts: 2
Vehicle: 97 nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That’s kind of what I’ve been thinking. The bump stops have since been taken out. I finally have a chance to go out and work on it again. I’m hoping it’s something simple
97ta2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.