Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 04-29-2022, 12:17 AM   #1
Tetsuichi
 
Join Date: May 2018
Location: toronto
Posts: 20
Vehicle: 1991 d21
Thanks: 3
Thanked 4 Times in 2 Posts
Default Replaced battery, car starts and runs but no electronics work.

Last night I left my headlights on and killed my battery. I tried jumping it a few times to no avail, and decided I would go out and buy a new battery since this one was several years old.

I replaced the battery, car starts and drives fine, but now none of the electronics work, other than the headlights and wipers.

Radio, dash, horn, brake lights, heat/fans, 4-ways, nothing works. I checked all the fuses and they seem fine, and i can't imagine they would all fry at once. Is there a main fuse or something that I might have blown while jumping the truck?

1991 D21, 4cyl.

Last edited by Tetsuichi; 04-29-2022 at 01:27 AM.
Tetsuichi is offline   Reply With Quote
Old 04-29-2022, 03:08 AM   #2
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 5,683
Vehicle: 96 HB
Thanks: 212
Thanked 906 Times in 791 Posts
Default

popped one of the fusible links at the battery.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is online now   Reply With Quote
Old 04-29-2022, 02:50 PM   #3
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 56
Posts: 7,977
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 71
Thanked 1,024 Times in 929 Posts
Default

agree on fusible link, get a test light and check for power on each side of each fusible link, do not replace with a regular fuse, it's not the same.
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 05-07-2022, 07:06 PM   #4
Tetsuichi
 
Join Date: May 2018
Location: toronto
Posts: 20
Vehicle: 1991 d21
Thanks: 3
Thanked 4 Times in 2 Posts
Default

Solved: you guys were right it was just a fusible link, replaced both with an oem set off ebay. 🙏 Thanks a lot!
Tetsuichi is offline   Reply With Quote
Thanked by:
cadillacdude1975 (05-08-2022)
Old 05-08-2022, 02:02 PM   #5
Cusser
 
Cusser's Avatar
 
Join Date: Aug 2016
Location: Hot Arizona
Posts: 791
Vehicle: 2004 Frontier
Thanks: 0
Thanked 145 Times in 128 Posts
Default

Great - it's fixed !!!


But just why did the fusible links blow in the first place??? Trying to understand...
__________________
2004 Frontier King Cab (2WD, 5-speed, 4-cylinder, 105K), 1998 Frontier regular cab (2WD, 5-speed, 4-cylinder 253K), 1988 Mazda B2200 (2WD, 5-speed, 4-cylinder, 220K), 1971 VW Convertible (140K), 2005 Yukon (215K), 1970 VW (260+K)
Cusser is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:06 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.