Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Wiring and Electrical

Reply
 
Thread Tools Display Modes
Old 02-27-2020, 03:06 PM   #1
Robtra1980
 
Join Date: Feb 2020
Location: Louisiana
Posts: 2
Vehicle: 1994 nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default ECU issues

I have a 94 Nissan hardbody with the 4 cylinder and 5 speed. I'm having issues getting throttle response. If I baby it, I can get plenty rpm's. If I stand on it, it just bogs and won't go past 1800ish. Has new fuel pump, filter, pressure regulator, and throttle body. I tested tps and it's fine. Cleaned MAF. I have a check engine light on, went through the sequence to check codes on ECU, but it won't respond. Turned key to on, rolled knob to diagnostic, and nothing. No clearing of check engine light, no flashing of led on ECU. Red is the only one lit. Green never flashed or came on. Red never flashed. It just sits there. Is my ECU bad? Help and advice appreciated.
Robtra1980 is offline   Reply With Quote
Old 02-27-2020, 03:16 PM   #2
Robtra1980
 
Join Date: Feb 2020
Location: Louisiana
Posts: 2
Vehicle: 1994 nissan hardbody
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The ECU does not have a toggle switch, only a knob.
Robtra1980 is offline   Reply With Quote
Old 02-28-2020, 03:38 PM   #3
smith
 
Join Date: Feb 2020
Location: Arizona
Posts: 26
Vehicle: 93 nissan d21
Thanks: 0
Thanked 1 Time in 1 Post
Default

I'm not much help but I do know that the ECU is seldom bad. I would re-read the instructions for accessing mode III for codes. Make sure key is in On position- not accessories and try again. If you need a Factory Service Manual, it can be gotten here. I can put in touch with where I got it.
smith is offline   Reply With Quote
Old 03-02-2020, 06:19 AM   #4
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 48
Posts: 9,872
Vehicle: 87 D21 SE KC V6 2wd 5sp & 87 Pathfinder 4x4 SE
Thanks: 388
Thanked 1,185 Times in 1,090 Posts
Default

Quote:
Originally Posted by Robtra1980 View Post
The ECU does not have a toggle switch, only a knob.
The early model trucks have a toggle. My 86.5 and 87 are like that.
cadillacdude1975 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:15 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.