Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Nissan Cars

Reply
 
Thread Tools Display Modes
Old 12-07-2019, 11:02 PM   #1
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,805
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,561
Thanked 1,325 Times in 1,167 Posts
Default Altima Immobilization System

OK, this is going to be a long shot here. I've posted this on a couple of other Nissan forums since this forum is specific to the Hardbody and Frontier, but I have gotten 0 replies in the last 2 days.

This is long. I apologize, but I want everyone to know what happened.

I have a 2012 Altima with the push button start.

About a week ago, I was working on my aftermarket car stereo because the electrical ground was not making it to the battery. To work on the stereo, I took the center vents out that contain the airbag activation light, which I unplugged so the wire would not have any strain. It remained that way a couple of days while I debugged the intermittent issue, and the airbag warning light blinked in the instrument cluster.

After fixing the stereo and reconnecting the airbag activation light, the airbag warning light in the instrument cluster was still blinking.

I posted a question on one of the Facebook groups about how to get the warning light to reset, and someone told me how to cycle the power 4 or 5 times until the light stops coming on. I was tired from a 12-hour shift, so I wasn't really counting, but I gave up and stopped somewhere around 10 times.

When I got in to drive to work later that day, the car would not do anything. The push button light is ON, and blinks OFF shortly every 15 seconds and goes back ON.

The brake pedal usually gives a little I push the brake to crank, but now it is firm.

The push button does not work at all unless I have the key fob plugged into the fob port.

I had the local Nissan dealership send a technician out. He plugged his consult into the port; we could see the consult register when we turned the car to ACCESSORY/ON, pressed the brake pedal, and a number of other things, but there were no errors. He removed the battery and did a factory reset of the ECU, but there was no change. He said I should have Nissan replace the brake switch, but I pointed out that the brake lights were still coming on when he pressed on the brakes. Then he started talking about needing to replace the ECU, but I pointed out that he had the consult port plugged into the ECU and it was confirming everything. He agreed with the logic of both my findings, and he could not find any reason why the car would not start. He said I would need to have it towed to Nissan where they could do more tests.

My car does not have a warranty. I imagine if I bring my car there, they are going to start replacing all sorts of stuff because that's what they usually do and what usually gets charged to warranty. I cannot get other shops in town to look at it because they aren't sure what would cause this, even though I keep mentioning the Immobilization System.

I have tried various techniques to clear my issue (like the Nissan technician did), but nothing has worked yet.

With all that said, does anyone here have any experience with this type of issue?

__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 12-07-2019, 11:43 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 40
Posts: 10,076
Vehicle: 2012 370Z, 1970 Datsun 521, 1995 Nissan Hardbody x2
Thanks: 876
Thanked 1,963 Times in 1,614 Posts
Default

Are you sure the brake lights and the ecu use the same switch? My Titan had a switch for the lights and a separate switch for the shift lock solenoid.
__________________
alabama_lowlife is offline   Reply With Quote
Old 12-08-2019, 12:08 AM   #3
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,805
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,561
Thanked 1,325 Times in 1,167 Posts
Default

I'm not sure about anything.

I'm inclined to think that it isn't a problem with the switch just because everything worked fine until I did the start sequence to reset the airbag light.

But I don't know.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 12-08-2019, 12:26 AM   #4
mytmouz
 
mytmouz's Avatar
 
Join Date: Sep 2011
Location: Pelahatche, MS
Posts: 1,068
Vehicle: 1989 Nissan Hardbody
Thanks: 70
Thanked 214 Times in 170 Posts
Default

This is what I always did on my older Sentra to reset any lights on then. I replaced the airbags and airbag computer on one with used stuff, it didnt crank afterwards, until I did this...

pen driver door
Get in
Shut door
Turn ignition to the on position The one that will go all the way, but not to start car)
Open door
Reach down with your right hand if your a rightty
Press the door ajar sensor button thing (7) times
Shut door
Start your car
mytmouz is offline   Reply With Quote
Old 12-08-2019, 12:32 AM   #5
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 2,738
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 302
Thanked 463 Times in 415 Posts
Default

What Mytmouz said. I was going to reply with a couple of ideas but I can't top that.

To turn the ignition on (but not start it): Press the start/stop button WITHOUT your foot on the brake. I think you have to press it twice but I'm not sure. You'll know it when all the dash lights come on. If your brake lights come on and you can shift out of park (with the ignition on) I doubt your brake light switch is bad.
SBJ is offline   Reply With Quote
Old 12-08-2019, 06:59 PM   #6
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,805
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,561
Thanked 1,325 Times in 1,167 Posts
Default

What does "pen driver door" mean?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 12-08-2019, 07:15 PM   #7
nunya
 
nunya's Avatar
 
Join Date: Apr 2019
Location: Central Florida
Posts: 779
Vehicle: nissan d21 93 kingcab red
Thanks: 240
Thanked 152 Times in 130 Posts
Default

"open" driver door, maybe?
nunya is offline   Reply With Quote
Old 12-09-2019, 01:58 AM   #8
mytmouz
 
mytmouz's Avatar
 
Join Date: Sep 2011
Location: Pelahatche, MS
Posts: 1,068
Vehicle: 1989 Nissan Hardbody
Thanks: 70
Thanked 214 Times in 170 Posts
Default

Open I must have missed a letter on the copy n paste. I have this in my files for when I need it. It is getting harder to hold my phone or tablet to proofread...
mytmouz is offline   Reply With Quote
Old 12-09-2019, 04:35 AM   #9
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 48
Posts: 9,877
Vehicle: 87 D21 SE KC V6 2wd 5sp & 87 Pathfinder 4x4 SE
Thanks: 388
Thanked 1,186 Times in 1,091 Posts
Default

My dad had a jeep grand cherokee once. The anti theft/immobilization system went bonkers and rendered the vehicle useless. he had to pay a tech to remove the mess.
cadillacdude1975 is offline   Reply With Quote
Old 12-09-2019, 05:53 AM   #10
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: OR
Posts: 2,738
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 302
Thanked 463 Times in 415 Posts
Default

Quote:
Originally Posted by cadillacdude1975 View Post
My dad had a jeep grand cherokee once. The anti theft/immobilization system went bonkers and rendered the vehicle useless. he had to pay a tech to remove the mess.
I hate those things. IMHO they are some of the biggest pieces of crap on the road.
SBJ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.