Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 02-19-2015, 09:12 PM   #31
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

UPDATE: So Yesterday, CEL was off all day....,.......,........etc............etc.....WTF ! Now today its back on....we are receiving record lows here in Eastern NC, (Jacksonville) thought that might have something to do with that, but today was colder than yesterday! I forgot to mention that it is sort of a rough start, but usually after the 2nd attempt it starts right up. Had a friend of mine, ride along with me, and he stated "Dam this thing runs right"! LOL!

Heres what Im thinking, I have to got through the entire evap system...thoughts.....Green light for "expertise"! LOL~!

Really appreciate it fellas!

AJ
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 09:16 PM   #32
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,533
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,491
Thanked 1,269 Times in 1,118 Posts
Default

If you take the gas cap off and put it back on, does the CEL go out?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 02-19-2015, 09:30 PM   #33
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

Checking now....BRB
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 09:41 PM   #34
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

Nope. ran it with it off, then ran it with it on.....
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 09:42 PM   #35
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

with the rough start I was thinking maybe the fuel sending unit....
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 09:58 PM   #36
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,533
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,491
Thanked 1,269 Times in 1,118 Posts
Default

Rats. I was hoping it was something simple.

In really cold weather, the gas cap's rubber seal might not seal too well because rubber shrinks when it gets cold

Take a cold shower and watch!
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Old 02-19-2015, 09:59 PM   #37
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

LMFAO

That made weak as F&^%!!!!
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 10:03 PM   #38
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 32
Posts: 3,836
Vehicle: 1986.5 Nissan D21, 1987 Mercedes 190D Turbo, 2010 Mercedes E350 AWD, 2017 Honda CBR500R
Thanks: 358
Thanked 469 Times in 409 Posts
Default

When the truck's running can you smell fuel? Have you checked the spark plugs to see what the tip looks like? I'm just wondering if it's running super rich for some reason.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
1986.5 FSM GI section - https://imgur.com/gallery/mjT18bV

OldGreyBeast is offline   Reply With Quote
Old 02-19-2015, 10:16 PM   #39
CarolinaBirdDog
 
CarolinaBirdDog's Avatar
 
Join Date: Feb 2013
Location: Jacksonville, North Carolina
Posts: 70
Vehicle: 1996 Nissan Pickup 2.4 4x4
Thanks: 34
Thanked 5 Times in 4 Posts
Default

Only on intial start up do I smell fuel, and the plugs were replaced about 500 miles ago... about a month ago, i ripped (accidentally) one of the wires off and when I repaired the wire, I could feel hard running, like miss firing, checked that first spark plug which was good then repaired the wire again. Great Contact since then....
__________________
In God We trust...All Others Must Authenticate!!!!
USMC
CarolinaBirdDog is offline   Reply With Quote
Old 02-19-2015, 10:27 PM   #40
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 50
Posts: 9,533
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,491
Thanked 1,269 Times in 1,118 Posts
Default

Quote:
Originally Posted by CarolinaBirdDog View Post
Only on initial start up do I smell fuel, and the plugs were replaced about 500 miles ago... about a month ago, i ripped (accidentally) one of the wires off and when I repaired the wire, I could feel hard running, like miss firing, checked that first spark plug which was good then repaired the wire again. Great Contact since then....
Hmmmm... I'm suspecting plug wire issues now.

If you can afford them, Genuine Nissan plug wires (and cap and rotor) can't really be beat.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Factory Service Manuals: https://www.nicoclub.com/FSM/Hardbody/
Walk-through: Checking Nissan Trouble Codes
1994 VG30E to VG33E with H256 Cams

jp2code is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.