Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 12-06-2017, 02:48 PM   #1
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 335
Vehicle: 1990 Nissan D21 HardBody
Thanks: 13
Thanked 24 Times in 21 Posts
Default funny lights

ive been noticing this for awhile but when i press on the brakes not just my rear lights come on but my dash lights up and my parking lights come on. what could be happening here and im almost positive its a ground of some sorts.

__________________
the red sprocket

brandonodom18 is offline   Reply With Quote
Old 12-06-2017, 03:07 PM   #2
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 30
Posts: 3,289
Vehicle: 1986.5 Nissan D21
Thanks: 282
Thanked 365 Times in 321 Posts
Default

Sounds like for some reason your brakes are wired into the tail light circuit instead of the brake lights? Maybe? That's some weird stuff there.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
OldGreyBeast is offline   Reply With Quote
Old 12-06-2017, 03:27 PM   #3
86.5KC
 
86.5KC's Avatar
 
Join Date: Jun 2016
Location: Lehigh Valley PA
Posts: 80
Vehicle: Nissan D21 1986.5, King Cab, Z24i, 5speed, 2wd
Thanks: 6
Thanked 24 Times in 22 Posts
Default

Hi Brandon,
I have seen this before on many different cars. It is almost always a bad filament in the brake/marker bulb.

You can test by removing the two brake/marker light bulbs, and stepping on the brake. If the problem goes away, its the bulbs, if the problem is still there it wiring.

The tail lamp ground COULD also cause a similar condition, but it is almost never that.
86.5KC is offline   Reply With Quote
Old 12-06-2017, 04:11 PM   #4
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 335
Vehicle: 1990 Nissan D21 HardBody
Thanks: 13
Thanked 24 Times in 21 Posts
Default

it didnt do this until i got the truck back from the shop about 6 months ago
__________________
the red sprocket

brandonodom18 is offline   Reply With Quote
Old 12-06-2017, 04:12 PM   #5
brandonodom18
 
brandonodom18's Avatar
 
Join Date: Mar 2017
Location: Mississippi
Posts: 335
Vehicle: 1990 Nissan D21 HardBody
Thanks: 13
Thanked 24 Times in 21 Posts
Default

Quote:
Originally Posted by 86.5KC View Post
Hi Brandon,
I have seen this before on many different cars. It is almost always a bad filament in the brake/marker bulb.

You can test by removing the two brake/marker light bulbs, and stepping on the brake. If the problem goes away, its the bulbs, if the problem is still there it wiring.

The tail lamp ground COULD also cause a similar condition, but it is almost never that.
i will try this when i get the chance. i dont see it hurting anything so as long as it doesnt blow up im ok lol and thanks for the help
__________________
the red sprocket

brandonodom18 is offline   Reply With Quote
Old 12-07-2017, 02:36 PM   #6
raenglehart
 
Join Date: Oct 2016
Location: Kathleen, Ga
Posts: 127
Vehicle: 1) Nissan HB 1995 Ext Cab 4x4 v6 AT (pwr everything) & 2) '95 HB v6 5-spd ExtCab (manual everything)
Thanks: 12
Thanked 9 Times in 8 Posts
Default

I had this on one of my HB's. Climb under your bed and see if you have the inline trailer kit harness installed (see attached picture). I disconnected that thing and re-connected the factory harness and my problem went away. Someone on here told me about those harness add-on's will cause that issue.

I eventually purchased a new one and installed. Problem never returned.
Attached Images
File Type: jpg TC485photo%20primary__ra_p.jpg (30.9 KB, 0 views)
__________________
04 F250 Lariat 4x4 Crew Cab PSD / 72 Layland Mini Pickup / 82 Austin Mini Pickup / 95 HB Ext Cab 4x4 v6 AT / 95 HB Ext Cab 4x4 v6 5-spd / 90 HB Ext Cab KA24e AT / 96 HB Ext Cab 4 cyl 2x4 - SOLD, Threw Rod / 89 HB Ext Cab Z24 2x4 - SOLD, PCS / 93 HB Single Cab 2x4 - SOLD, new owner totaled 1 month later
raenglehart is offline   Reply With Quote
Old 12-07-2017, 03:12 PM   #7
EagleStrike36
 
Join Date: Nov 2017
Location: New River Valley - Virginia
Posts: 6
Vehicle: 1986.5 Nissan D21 King Cab V6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Speaking of lights...

Are the corner lights (next to headlights) supposed to flash when the turn signals (+hazards) are put on? Mine are not, on either side. They just stay on. The bumper signal lights work fine.
EagleStrike36 is offline   Reply With Quote
Old 12-07-2017, 03:28 PM   #8
raenglehart
 
Join Date: Oct 2016
Location: Kathleen, Ga
Posts: 127
Vehicle: 1) Nissan HB 1995 Ext Cab 4x4 v6 AT (pwr everything) & 2) '95 HB v6 5-spd ExtCab (manual everything)
Thanks: 12
Thanked 9 Times in 8 Posts
Default

Quote:
Originally Posted by EagleStrike36 View Post
Speaking of lights...

Are the corner lights (next to headlights) supposed to flash when the turn signals (+hazards) are put on? Mine are not, on either side. They just stay on. The bumper signal lights work fine.
No Eagle, they are not. However, search the forum. There is a way to make them flash alternatively with the bumper turn signal with some wiring work.
__________________
04 F250 Lariat 4x4 Crew Cab PSD / 72 Layland Mini Pickup / 82 Austin Mini Pickup / 95 HB Ext Cab 4x4 v6 AT / 95 HB Ext Cab 4x4 v6 5-spd / 90 HB Ext Cab KA24e AT / 96 HB Ext Cab 4 cyl 2x4 - SOLD, Threw Rod / 89 HB Ext Cab Z24 2x4 - SOLD, PCS / 93 HB Single Cab 2x4 - SOLD, new owner totaled 1 month later
raenglehart is offline   Reply With Quote
Thanked by:
EagleStrike36 (12-08-2017)
Old 12-07-2017, 06:28 PM   #9
Reserector
the Flaming Marshmallow
 
Reserector's Avatar
 
Join Date: Oct 2015
Location: Laurel, MS
Posts: 1,195
Vehicle: Nissan HB KC 4x4
Thanks: 7
Thanked 257 Times in 206 Posts
Default

Quote:
Originally Posted by EagleStrike36 View Post
Speaking of lights...

Are the corner lights (next to headlights) supposed to flash when the turn signals (+hazards) are put on? Mine are not, on either side. They just stay on. The bumper signal lights work fine.
Here's the link: http://www.infamousnissan.com/forum/...ad.php?t=36590
Reserector is offline   Reply With Quote
Thanked by:
Deerhurst (12-07-2017), EagleStrike36 (12-08-2017)
Old 12-08-2017, 02:39 AM   #10
EagleStrike36
 
Join Date: Nov 2017
Location: New River Valley - Virginia
Posts: 6
Vehicle: 1986.5 Nissan D21 King Cab V6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I was changing some bulbs before turned the signals with a bulb missing - and suddenly they started flashing. Didn't know if that was normal for them or not!

Thanks all!
EagleStrike36 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.