Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 07-18-2018, 02:33 PM   #11
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,467
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,204
Thanked 1,056 Times in 930 Posts
Default

KA24E engine?
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Old 07-18-2018, 02:42 PM   #12
jp2code
Software Developer
 
jp2code's Avatar
 
Join Date: Dec 2011
Location: Longview, TX [USA]
Age: 48
Posts: 8,467
Vehicle: 94 LB 2x4 Manual VG33e
Thanks: 1,204
Thanked 1,056 Times in 930 Posts
Default

Looks like you need to go through Diagnostic Procedure 11 - Engine Stalls when the Engine is Hot - EF & EC-209



Here is a link to the EC.pdf file, if you don't already have a copy of that on your computer:

https://app.box.com/s/k8zz8kqigim4qe52rci9dmlgw1gt786s

Basically, you're going to check the fuel injectors and circuits, ignition coil, power transistor, fuel pressure regulator, ECM harness, and ECM.
__________________
Joe (not a mechanic!) Don't have an account? EMAIL ME
Free Service Manuals: https://ownersmanuals2.com/make/nissan
Walk-through: Checking Nissan Trouble Codes
Everyone you meet is fighting a battle you know nothing about. Be kind always.

jp2code is offline   Reply With Quote
Old 07-19-2018, 08:26 AM   #13
XoXSciFiGuy
 
XoXSciFiGuy's Avatar
 
Join Date: May 2017
Location: Auburn, WA
Posts: 990
Vehicle: 1997 D21 King Cab XE 2WD
Thanks: 29
Thanked 136 Times in 125 Posts
Default

I think JP2Code is giving you good advice.

And I know it's a long shot...but have you checked the two switches that connect to the clutch pedal? There is the FORWARD one, against the firewall, and also one on the UPPER side of the clutch pedal. More toward the instrument panel. Both have to work. One engages when you push in the clutch. The other one, the UPPER one, engages when the clutch pedal is at rest in the RELEASED position.

I would check both of those, too.
__________________

1997 King Cab XE, 5-sp, canopy, AC/PS, KA24E, 112,000 miles. Need a technical manual? Drop me a message.
XoXSciFiGuy is offline   Reply With Quote
Old 07-22-2018, 01:39 AM   #14
Bluebeast23
 
Bluebeast23's Avatar
 
Join Date: Apr 2018
Location: Missouri
Posts: 24
Vehicle: 94 Nissan hardbody
Thanks: 0
Thanked 6 Times in 6 Posts
Default

So pulled the throttle body off disassembled it, cleaned it really good. I put on a new IACV and fuel pressure regulator (I bought them when I first bought the truck). Got it started this afternoon, it runs so so smooth and idles like a dream. Drove it around for about an hour, both highway and stop and go. The truck never stalled or shut off on me. I hooked the old IAC up to a battery and it would barely move or even act like it wanted too move. I let it cool down and it moves freely, so I’m hoping that it was the issue.

I wanna say thank you to all you, for your help and ideas.
__________________
DD: 1994 hardbody 2wd base. Currently 223,238
Ever day: 2012 F150 Ecoboost heavily modded
G. whip: 2018 Massey Ferguson
Bluebeast23 is offline   Reply With Quote
Thanked by:
jp2code (07-22-2018)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:26 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.