Go Back   Infamous Nissan - Hardbody / Frontier Forums > Tech Area > Engine and Drivetrain

Reply
 
Thread Tools Display Modes
Old 05-06-2019, 04:07 PM   #1
Shizzank
 
Join Date: Apr 2019
Location: WA
Posts: 13
Vehicle: Nissan d21 1986.5
Thanks: 0
Thanked 0 Times in 0 Posts
Default No Spark intake side

86.5 z24i

The truck runs fine if you drive like old lady. I can rev the truck all the way up and it runs fine until you give it more than 1/3 throttle.
Under low RPM i can floor it and slowly rev/speed up but as soon as the engine goes over about 2500 rpm or so it will bog shake violently if its under load.

If I rev it up slowly with 1/4 throttle it will rev up all the way just fine well passed 5k rpm... If I'm revving up the engine slowly and then floor it, it will completely die /bog out until it slows to where the RPMs are right at that 2500 RPM mark then it will shake violently.

I am only getting spark on the exhaust coils and I believe they are shutting down under high engine load and rpms.

The coils both work as i can switch them and still have the truck run, but again only the exhaust side is working.

It just seems weird to me that all the other ignition parts are working fine for exhuast side but i got nothing on the intake side.

I'm tired of driving like a grandma and want to be able to actually accelerate up a hill. please help guys, i researched so many different post on here.
Shizzank is offline   Reply With Quote
Old 05-06-2019, 04:10 PM   #2
Shizzank
 
Join Date: Apr 2019
Location: WA
Posts: 13
Vehicle: Nissan d21 1986.5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

replaced the ICM (ignition control module/igniter) already and feeling stuck now.

What part would only cause a malfunction on the intake side but not the exhaust side besides their separate coils and ICM. (which have tested good/been replaced)
Shizzank is offline   Reply With Quote
Old 05-06-2019, 06:15 PM   #3
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 4,832
Vehicle: 96 HB
Thanks: 159
Thanked 666 Times in 589 Posts
Default

have you checked your grounds to see if they are dirty?
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 05-06-2019, 10:19 PM   #4
Shizzank
 
Join Date: Apr 2019
Location: WA
Posts: 13
Vehicle: Nissan d21 1986.5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

not 100% sure which ones to check or where they would be at.
Shizzank is offline   Reply With Quote
Old 05-06-2019, 10:33 PM   #5
nunya
 
nunya's Avatar
 
Join Date: Apr 2019
Location: Florida
Posts: 428
Vehicle: nissan d21 93 kingcab red
Thanks: 133
Thanked 73 Times in 62 Posts
Default

Back in the day i had replaced plugs on my 4cyl d21 that had 8plugs. when done it was a dog. Sought advice from Oreilly (had bought plugs from Autozone) and Oreilly guy sold me a set of NGK, but 4 of one part number for intake and 4 of another for the exhaust side. Made the swap and ZOOM I was chirping in second and quicker than ever. Wish I had that truck again.
nunya is offline   Reply With Quote
Old 05-07-2019, 07:03 PM   #6
Shizzank
 
Join Date: Apr 2019
Location: WA
Posts: 13
Vehicle: Nissan d21 1986.5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

already changed the plugs to ngk 7734 for exhuast and ngk 7131 for intake side (which still doesn't spark) from some autolite plugs with number 4 on them.

I also changed the wires to some new duralast gold wires, and the ICM at the same time.

After putting on the new parts it almost made it idle worse. but after it warms up it idles smoothly again.
Shizzank is offline   Reply With Quote
Old 05-07-2019, 09:51 PM   #7
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 47
Posts: 9,495
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 355
Thanked 1,116 Times in 1,030 Posts
Default

Any codes?
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Thanked by:
YEPEE (05-08-2019)
Old 05-09-2019, 05:31 PM   #8
Shizzank
 
Join Date: Apr 2019
Location: WA
Posts: 13
Vehicle: Nissan d21 1986.5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

code 21 for ignition signal.
not really sure what to check for this guy. it said to use a logic probe to test for pulse signals for ecu slot 5, 14 and ground. i dont have a logic probe, but i do have a cheap multimeter. anyway i can test this without a "logic probe?"

code 23
coded 24

i read somewhere these don't matter much. When I reset the battery, one of these guys went away i just don't remember which one.

I daily this and put the passenger seat back on.
Shizzank is offline   Reply With Quote
Old 05-09-2019, 07:41 PM   #9
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 54
Posts: 7,466
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 63
Thanked 888 Times in 814 Posts
Default

Harbor Freight has a logic probe for $10, only thing I can't figure out is in the service manual it shows 4 connections on the logic probe, but everyone I see online only has 3


https://www.harborfreight.com/comput...CABEgKl9_D_BwE
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 05-09-2019, 07:48 PM   #10
ahardb0dy
The Post Count Whore
 
ahardb0dy's Avatar
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 54
Posts: 7,466
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 63
Thanked 888 Times in 814 Posts
Default

Just found this online, sounds like same problem you are having, guy said it turned out to be the ICM inside the distributor:


https://forums.nicoclub.com/1-of-the...y-t551759.html
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.