Go Back   Infamous Nissan - Hardbody / Frontier Forums > Model Specific > Hardbody Forum (D21)

Reply
 
Thread Tools Display Modes
Old 08-22-2017, 02:12 PM   #11
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 4,232
Vehicle: 1986.5 Hardbody
Thanks: 584
Thanked 372 Times in 350 Posts
Default

Bad idle should be simple. It was inconsistent and would go smooth occasionally but its the metallic sound I'm worried about and it was less consistent than the idle. It sounds like a death rattle then goes away then goes away then gently comes back then disappears then sounds like death again.

Not really worried about the idle. It just feels like an unplugged vacuum line.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
Deerhurst is offline   Reply With Quote
Old 08-22-2017, 02:25 PM   #12
OldGreyBeast
1986.5 HB 4x4 3.0V6
 
OldGreyBeast's Avatar
 
Join Date: Mar 2012
Location: North AL
Age: 30
Posts: 3,242
Vehicle: 1986.5 Nissan D21
Thanks: 275
Thanked 363 Times in 319 Posts
Default

Mine rattles fairly regularly. Has been doing so for 2 years or so now. Sometimes the engine sounds like a peanut butter jar full of rocks. Certainly worth looking into, but I've been running mine anyway and it hasn't blown up...

Yet

Also, I have been known to hold it on the limiter for a while doing donuts and junk, lol.
__________________
Build log for the Beast - https://beastbuildlog.blogspot.com - Last Updated 18 OCT 2016
OldGreyBeast is offline   Reply With Quote
Old 08-22-2017, 06:22 PM   #13
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 4,232
Vehicle: 1986.5 Hardbody
Thanks: 584
Thanked 372 Times in 350 Posts
Default

Lol! I havnt found a limiter yet! The one time I tried I backed off at 6500RPM. That was a long time so.

I'm to anal to let to stay like that.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
Deerhurst is offline   Reply With Quote
Old 08-22-2017, 09:27 PM   #14
cadillacdude1975
The Gear Jammer
 
cadillacdude1975's Avatar
 
Join Date: Apr 2013
Location: Chattanooga, TN
Age: 45
Posts: 7,650
Vehicle: 87 D21 SE KC V6 2wd 5sp & 86.5 V6 SE auto
Thanks: 253
Thanked 815 Times in 758 Posts
Default

6500? geeez i have a fit if mine gets much over 3500. the old girl is tired, but shes still working like a champ.

mine made a fucked up noise about 6 months back. i came home one night and when i got home after running it on the highway, it was clanging and rattling. i thought it had spun a bearing. i was furious.

so after i came inside and sat down for dinner, i went back out there and started it again. the noise was gone. so i shut it off and started looking around. this was right before my rear main was replaced. it was three fucking quarts low on oil. i never let it get like that. how not checking it slipped my mind is a mystery.

and since the rear main was replaced, it hasnt used a fucking drop. not an ounce of oil im speechless.
__________________
"Im officially lost" - wildbill
cadillacdude1975 is offline   Reply With Quote
Old 08-22-2017, 11:07 PM   #15
91nissan94
 
91nissan94's Avatar
 
Join Date: Sep 2008
Location: Crescent City FL
Posts: 1,155
Vehicle: 91nissan hb
Thanks: 41
Thanked 87 Times in 80 Posts
Default

Hope it's just low on oil. Mine raises hell when it gets low.
91nissan94 is online now   Reply With Quote
Old 08-23-2017, 12:43 AM   #16
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 4,232
Vehicle: 1986.5 Hardbody
Thanks: 584
Thanked 372 Times in 350 Posts
Default

Yeah, 6500RPM. She was howling and still pulling with the rears spinning. It was about 7-8 years ago I did that. 99% of the time she never sees above 2500RPM with the occasional 3k pull.

She doesn't burn or drip a drop of oil but I'll be checking. Hoping its just a seizing water pump or alternator.
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
Deerhurst is offline   Reply With Quote
Old 08-23-2017, 02:27 AM   #17
synbiotic12
 
synbiotic12's Avatar
 
Join Date: Dec 2013
Location: Newfoundland
Posts: 2,021
Vehicle: 2004 Frontier 2WD (sold), 1993 D21 4x4
Thanks: 87
Thanked 272 Times in 231 Posts
Default

Mine usually goes over 5k pretty well every day, I love to hear this thing growl down the road.

I wouldn't imagine fuel delivery, like you said start with oil and plugs, that will give you a better idea of what you're working with. if there's lots of oil, it's got no metal and the plugs are dry and not covered in soot I'd start looking at possibly a loose wire/connection or bad cap/rotor.
If you're gonna turn the motor over by hand do it while you have all the spark plugs pulled, you'll be able to feel in the wrench the smoothness of the pistons in their travel and you'll have an easier time noticing if anything is touching
__________________
1993 D21 SE-V6, 4x4, X-cab
syn's 4x4 project build
2004 Frontier 4cyl, 2wd, X-cab (Sold)
2007 Subaru Impreza wagon 2.5i
synbiotic12 is offline   Reply With Quote
Old 08-23-2017, 03:21 AM   #18
johnber
grouchy old man
 
Join Date: Oct 2014
Location: Lynden WA
Age: 60
Posts: 815
Vehicle: 89 4X base
Thanks: 6
Thanked 81 Times in 77 Posts
Default

Quote:
Originally Posted by Deerhurst View Post
Yeah, 6500RPM. She was howling and still pulling with the rears spinning. It was about 7-8 years ago I did that. 99% of the time she never sees above 2500RPM with the occasional 3k pull.

She doesn't burn or drip a drop of oil but I'll be checking. Hoping its just a seizing water pump or alternator.
well pull the wp belt and fire it up. question there will be answered. Also gotta look at age....... she aint so new as she once was and might be ready for a refresh. I hope the latter aint the reason for ya tho.Goofy oil pressure makes me think it might be so. REALLY hoping i am wrong.
__________________
89 regular cab, plain as it gets with a z-24 and posi's
johnber is offline   Reply With Quote
Old 08-23-2017, 04:21 AM   #19
Deerhurst
4/86 SE-V6 2 tone 4x4 HB
 
Deerhurst's Avatar
 
Join Date: Apr 2013
Location: Oregon
Posts: 4,232
Vehicle: 1986.5 Hardbody
Thanks: 584
Thanked 372 Times in 350 Posts
Default

So, got it home which was pretty easy. I wasnt the one pushing the truck!

We put it on a trailer and pulled her home. Got to realize how tall she really is and how fat those tires look. Looks good!

Syn, mine growls from 2500 to about 3500 then starts to sound like a tuner. She makes a really nice smooth note around 2700RPM and has a thumpy burble around 2500RPM. Im quite impressed with the sounds a leaky 31 year old muffler and some headers will make!

So, found a couple things. First, the pully on the PS pump is a little loose. Mostly in and out but a hair up and down. That doesnt worry me but steering without power steering and those tires sucks.

Now, remember when I said it has never burned oil or leaked out. Well, its got no oil on the dip stick. I checked all over. Even pulled the gauges off the column and got under the truck to look for drips or fresh spots. Nope. Its dry. Called my buddies dad and he said take a look at the PCV. Pulled the air filter. Dry. Pulled the filter in front of the tube from the valve cover to the filter assembly and it is dripping with oil. Next found a puddle in the filter box. Its been sucking oil into the filter which was replaced with the timing belt so it is a recent thing. Doing that should have created a massive vacuum leak, hence bad and erratic idle, and possibly some nasty detonation, the clatter. I was still pushing roughly 50PSi of oil so I should be fine especially since when it smooth out it ran just like normal.

Gonna do the oil and see if I can find the PCV over the next couple days. Then fire her back up without any accessories and see if life is good or if I need to dig deeper.


PS feels good other than the slack, water pump feels good with no play and alternator feels good but spins easily and makes a very quiet sound like its occasionally dragging on something. The quest alternator upgrade work on the old truck?
__________________
1986.5 SE-V6 4X4 D21 Hardbody
Pacesetter Long Tube Headers
Morimoto Mini D2S HID Projectors and Hella 500s
Deerhurst is offline   Reply With Quote
Old 08-23-2017, 04:33 AM   #20
SBJ
Total Buzzkill
 
Join Date: Nov 2016
Location: WA
Posts: 965
Vehicle: '90 D21 4cyl 5spd 2wd
Thanks: 98
Thanked 108 Times in 99 Posts
Default

Hope it's just a simple PCV valve. I got a car that burns a quart every 800 miles or so and it gets considerably louder on startup if it's more than a quart low. I always keep a jug of oil in the trunk. Kinda scary since the VG has a pretty small oil capacity to begin with.
SBJ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.