Go Back   Infamous Nissan - Hardbody / Frontier Forums > Infamous Nissan > Introductions

Reply
 
Thread Tools Display Modes
Old 10-12-2018, 11:56 PM   #1
MidnightSun
 
Join Date: Oct 2018
Location: AK
Posts: 4
Vehicle: 91 D21
Thanks: 0
Thanked 0 Times in 0 Posts
Default Hello, new to forum and d21s.

A few months ago I picked a 91 D21 SE with a topper, a couple sets of studded tires, and an extra set of wheels for $1600. My first pickup, but i had a z31 in the past, so im familiar with the motor. It has 210k miles, but was told that timing belt was just changed and some of the gaskets were replaced. I just got a new set of non studded tires and had to fix the voltage regulator on the gauge cluster to get the fuel gauge and coolant temp gauge working again. I just put the wires on in the same order that they were on the stock regulator. Today it seemed as if the fuel gauge was higher than before, over the full mark, and it seems to be overheating as well. I'm gonna try to burp the system first and see if that fixes it, but I also wonder if the radiator is clogged. The top hose is warm, the top of the radiator is hot, but the fins and bottom hose is cold.
Attached Images
File Type: jpg 20180801_150715.jpg (98.6 KB, 4 views)
MidnightSun is offline   Reply With Quote
Old 10-12-2018, 11:57 PM   #2
alabama_lowlife
Owner and Administrator
 
alabama_lowlife's Avatar
 
Join Date: Sep 2008
Location: jack, alabama
Age: 39
Posts: 8,945
Vehicle: 2011 Nissan Frontier, 08 altima, 1970 Datsun 521, 1995 Nissan Hardbody
Thanks: 585
Thanked 1,576 Times in 1,288 Posts
Default

Welcome to infamous nissan
__________________
alabama_lowlife is offline   Reply With Quote
Old 10-13-2018, 12:20 AM   #3
dvdswan
Super Moderator
 
dvdswan's Avatar
 
Join Date: Mar 2009
Location: Port Orchard, WA
Posts: 4,478
Vehicle: 96 HB
Thanks: 149
Thanked 585 Times in 517 Posts
Default

Welcome to the site. Sounds like you're working in the right direction.
__________________
Dave
96 HB XE
SAS'd D44 3-link on 35s
http://www.cardomain.com/ride/2618002
dvdswan is offline   Reply With Quote
Old 10-13-2018, 01:58 PM   #4
kellybig
 
Join Date: Oct 2016
Location: Omaha
Posts: 494
Vehicle: 1991 Nissan D21 King Cab V6 4x4 SE
Thanks: 21
Thanked 42 Times in 41 Posts
Default

Welcome
kellybig is offline   Reply With Quote
Old 10-13-2018, 03:00 PM   #5
ahardb0dy
The Post Count Whore
 
Join Date: May 2014
Location: Sorrento, Florida
Age: 52
Posts: 7,292
Vehicle: 2017 Nissan Frontier Desert Runner
Thanks: 63
Thanked 825 Times in 764 Posts
Default

Thermostat may be bad
__________________
My name is Tony and I'm a Infamousaholic

Current truck - 2017 Nissan Frontier Desert Runner ,

(formerly owned: 1993 Nissan Hardbody king cab 2wd, 90 Nissan Sentra, 94 Nissan Pathfinder SE 4x4, 05 Nissan Titan, 87 Nissan SE-V6 4x4 king cab, 94 Infiniti Q45t & 80 Datsun 310GX )
ahardb0dy is offline   Reply With Quote
Old 10-13-2018, 09:23 PM   #6
MidnightSun
 
Join Date: Oct 2018
Location: AK
Posts: 4
Vehicle: 91 D21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ahardb0dy View Post
Thermostat may be bad

I believe I fixed the problem. Actually was not overheating. It was electrical. At first I had just hooked up the wires in the order that they were coming out of the stock regulator. Did some more research and noticed that the input/output was switched. Soldered onto another regulator I had and everything works as it should. I'm just about ready to go for my travels back south( from Alaska to Minnesota) for the winter.
MidnightSun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.