Go Back   Infamous Nissan - Hardbody / Frontier Forums > Search Forums

Showing results 1 to 25 of 30
Search took 0.01 seconds.
Search: Posts Made By: Viggen
Forum: Wheels and Tires 11-06-2019, 07:35 AM
Replies: 6
Views: 203
Posted By Viggen
Thank you very much.

Thank you very much.
Forum: Wheels and Tires 11-05-2019, 08:34 PM
Replies: 6
Views: 203
Posted By Viggen
1997 Pickup. 2WD. 14" stock wheels to 15" for snowtires. What works?

I have a 1997 D21. 2WD. Stock.

Currently have P215/75R14.

The little infoplate by the truck door says rims are 14x6. I thank that's the critical part, correct?



What would fit that? i...
Forum: Wiring and Electrical 05-12-2018, 05:27 AM
Replies: 8
Views: 525
Posted By Viggen
Alabama LL and all - thank you I replaced the...

Alabama LL and all - thank you
I replaced the alternator like you said. You were right.
Forum: Wiring and Electrical 04-26-2018, 10:04 PM
Replies: 8
Views: 525
Posted By Viggen
Thank you very much. I use Rock Auto because...

Thank you very much.

I use Rock Auto because a parts store about 2 miles away sends out parts for Rock Auto and they always seem to have stuff in stock for me.
Forum: Wiring and Electrical 04-26-2018, 08:32 PM
Replies: 8
Views: 525
Posted By Viggen
Any opinion on decent replacement. I generally...

Any opinion on decent replacement. I generally buy through Rock Auto.com

In checking things I also note that one or two of the bolts for belt removal and belt adjustment( to get to alternator),...
Forum: Introductions 04-26-2018, 08:01 PM
Replies: 10
Views: 538
Posted By Viggen
Very nice. Welcome.

Very nice. Welcome.
Forum: Wiring and Electrical 04-26-2018, 06:49 PM
Replies: 8
Views: 525
Posted By Viggen
Battery light ON, E-Brake light ON. Low charge

1997 D21 132,000 miles
All happened at the same time. E-Brake engaged light went On, Battery Light went ON, and also at the same time, unable to read trouble code through that little dongle plug in...
Forum: Hardbody Forum (D21) 10-29-2016, 11:42 PM
Replies: 74
Views: 12,415
Posted By Viggen
1997 King Cab. White. 2-Wheel Drive, 5 Speed. Got...

1997 King Cab. White. 2-Wheel Drive, 5 Speed. Got it in 2004.
As I pulled into the driveway this morning it was at 281,000. Actual number.
Bought it at 98,xxx from original owner.
Changed fluids...
Forum: Hardbody Forum (D21) 04-15-2016, 07:32 PM
Replies: 39
Views: 3,988
Posted By Viggen
Back to the original post, the problem was...

Back to the original post, the problem was backpressure from a plugged "cat". After checking about everything up top, I looked at the exhaust.
I tested by removing the O2 sensor - engine ran fine...
Forum: Hardbody Forum (D21) 04-15-2016, 07:28 PM
Replies: 6
Views: 823
Posted By Viggen
What came out of truck, with a Nissan stamp on...

What came out of truck, with a Nissan stamp on it, was a Bosch - I replaced it with the same design Bosch.
On my '97, it only has one O2 sensor. I know what the diagrams and manuals show, but...
Forum: Hardbody Forum (D21) 04-15-2016, 06:50 PM
Replies: 33
Views: 2,766
Posted By Viggen
I have a '97 that went to limp mode at about...

I have a '97 that went to limp mode at about 2000-2200. Ended up that I was getting back pressure from the exhaust.
I tested by pulling the O2 sensor and checking for acceleration. worked fine....
Forum: Hardbody Forum (D21) 04-15-2016, 06:12 PM
Replies: 18
Views: 2,770
Posted By Viggen
To reset just disconnect battery for a while. A...

To reset just disconnect battery for a while. A couple of hours does the job. Or just disconnect overnight.
Forum: Hardbody Forum (D21) 04-15-2016, 05:52 PM
Replies: 23
Views: 3,493
Posted By Viggen
Rundown on the solution: After going through...

Rundown on the solution:
After going through the process with the sensors and all coming out good, then turned my attention to the exhaust end.
I was starting to suspect backpressure from the cat...
Forum: Hardbody Forum (D21) 04-05-2016, 06:40 PM
Replies: 6
Views: 823
Posted By Viggen
I have been running this truck since 2004 with...

I have been running this truck since 2004 with the one O2 sensor, passing Emission tests every 2 years, go figure.
Currently a little over 273k Miles
Thanks for the Bosch number.
Forum: Hardbody Forum (D21) 04-05-2016, 06:21 PM
Replies: 23
Views: 3,493
Posted By Viggen
I don't know what an A.V.I is...... Am going...

I don't know what an A.V.I is......

Am going to replace the cat and the O2 sensor.
Exhaust is definitely restricted.
Forum: Hardbody Forum (D21) 04-05-2016, 06:19 PM
Replies: 6
Views: 823
Posted By Viggen
Which Bosch(or otherwise O2 sensor for 97 HB?

Which O2 sensor for the 1997 HB with 4 cylinder engine?
It has 273K miles.
On this truck there is only one sensor, before the Cat.

I called a couple of local parts shops and they each gave me...
Forum: Hardbody Forum (D21) 04-02-2016, 08:32 PM
Replies: 23
Views: 3,493
Posted By Viggen
And update. I had checked everything up to what...

And update.
I had checked everything up to what wasn't going to take 4-5 hours to get into so since the engine idled and ran fine below 2000 rpm I began to wonder about back pressure on the exhaust...
Forum: Hardbody Forum (D21) 03-30-2016, 08:53 PM
Replies: 23
Views: 3,493
Posted By Viggen
I forgot. I did clean the MAF. I was thinking...

I forgot. I did clean the MAF.
I was thinking EGR valve.
Both the PVC and EGR require some digging
on the KA24E
Forum: Hardbody Forum (D21) 03-30-2016, 06:37 PM
Replies: 23
Views: 3,493
Posted By Viggen
Is there an easy way to get to the MAF and pcv...

Is there an easy way to get to the MAF and
pcv valve?....LOL
Forum: Hardbody Forum (D21) 03-29-2016, 11:48 PM
Replies: 23
Views: 3,493
Posted By Viggen
Did the timing and checked for vacume leaks, ...

Did the timing and checked for vacume leaks,
Timing sure needed resetting.
Nothing on vacume leaks

Reset everything, not showing any codes.

I think that I am getting backpressure from...
Forum: Hardbody Forum (D21) 03-26-2016, 10:31 PM
Replies: 23
Views: 3,493
Posted By Viggen
'97 D21 - engine bogs at 2200 rpm got pushed down some pages on previous thread

The engine starts fine, idles fine, comes off the line fine, but yesterday on accelerating it would not go past 2000-2200 rpm. Going up a couple of small hills to get home was "interesting". There...
Forum: Hardbody Forum (D21) 03-24-2016, 07:09 AM
Replies: 39
Views: 3,988
Posted By Viggen
Replace the Intake Air Temp Sensor. All good,...

Replace the Intake Air Temp Sensor.
All good, no codes.

No "learn Mode', no jumpers, nothing to unplug(I don't think) - crank it. Got it.
Thank you
Forum: Hardbody Forum (D21) 03-23-2016, 06:23 PM
Replies: 39
Views: 3,988
Posted By Viggen
Read the code and it came out P0110 - Intake Air...

Read the code and it came out P0110 - Intake Air Temperature Sensor
Checked it and one of the wires on the sensor was broken off.
Crappy place to resolder so I will replace the sensor.

Reset...
Forum: Hardbody Forum (D21) 03-22-2016, 07:53 PM
Replies: 39
Views: 3,988
Posted By Viggen
Thanks for all the input and I found the problem....

Thanks for all the input and I found the problem.
I started to take the air filter assembly off to get at thing better, when lo and behold I saw the dirtiest air filter I ever had. I missed...
Forum: Hardbody Forum (D21) 03-21-2016, 05:01 PM
Replies: 39
Views: 3,988
Posted By Viggen
OK. Will be checking distributor/timing/rotor. ...

OK.
Will be checking distributor/timing/rotor.
And I think I will check the TPS sensor as well. To see if it's in specs.
Showing results 1 to 25 of 30

 
Forum Jump

All times are GMT. The time now is 12:41 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.