Infamous Nissan - Hardbody / Frontier Forums

Infamous Nissan - Hardbody / Frontier Forums (http://www.infamousnissan.com/forum/index.php)
-   05+ Frontier Forum (D40) (http://www.infamousnissan.com/forum/forumdisplay.php?f=19)
-   -   2010 Frontier runs like crap sometimes (http://www.infamousnissan.com/forum/showthread.php?t=40718)

Herculou 11-19-2017 12:32 AM

2010 Frontier runs like crap sometimes
 
The truck warms up run fine then all the sudden sputtes to the point it jerks the truck violently. Then it will quit for a minute and do it again.
Trouble code p0102. The maf sensor is only a few months old. The engine light, SLIP light and the vdc off light. Per much trouble shooting and a code p0340 I replaced the right cam sensor no help. Repalced the left cam sensor.. Still same problem.

Help please!

Herculou 11-20-2017 12:48 AM

Update. As long as I keep it under 2500 rpm it runs fine anything over and it starts jerking again. Doesn't matter what gear.

highest_vision 11-20-2017 01:08 AM

I am not familiar with that particular setup, but with that code I would check for air leaks inbetween the MAF and the engine. Anywhere unmetered air could get in. Vacuum hoses, PCV leaks, possibly crank case air intake hoses, intake ductwork after the MAF, etc.

YEPEE 11-20-2017 04:49 PM

Quote:

Originally Posted by Herculou (Post 493331)
Update. As long as I keep it under 2500 rpm it runs fine anything over and it starts jerking again. Doesn't matter what gear.

sounds like it is in "fail safe" is it a 4cy or V6 ??


All times are GMT. The time now is 02:04 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.